Home of the Squeezebox™ & Transporter® network music players.
Results 1 to 3 of 3
  1. #1
    Junior Member
    Join Date
    Feb 2020
    Posts
    4

    [Solved] piCorePlayer - No sound during DSD playback

    Hello all

    I'm discovering the world of network audio players...

    I set up a NAS with a Raspberry Pi 4 and I took the opportunity to install LMS on it.

    For one of my player I have equipped with a PI 4B 2G with a USB DAC, I use piCorePlayer 6 beta and it works perfectly except for the reading of DSD files )

    DSD playback is no problem on PC with Squeezelite-X but as soon as I want to play the same files under pCP I simply don't have sound.

    I spent a long time trying a bunch of different configurations but nothing to do So I decided to ask you the question

    I'm using an "old" DAC Audio-gd (NFB-3.32 if I have good memory) which is not DSD compatible, neither is the SMSL M6 DAC I have on my PC, so there has to be a conversion from DSD to PCM right away so it should work from scratch but no, it doesn't...

    Hopefully you can help me out...

    I'll see you soon.
    Last edited by Sylar; 2020-02-23 at 11:22.

  2. #2
    Junior Member
    Join Date
    Feb 2020
    Posts
    4
    Hello to all

    I continued my tests and I finally found the cause of the problem without being able to solve it for the moment but I don't give up hope...

    My DAC Audio-gd is limited to 192 kHz and obviously pCP was sending a PCM signal at 352 kHz during DSD playback

    It is while trying my second DAC SMSL M6 (v2 with remote control and DSD DoP compatible) that I realized this fact because it indicates the signal frequency on its screen.

    As a result, I know why the Audio-gd DAC doesn't output any sound during DSD playback under piCorePlayer but I don't know yet how to force the output to 192 kHz under these conditions.

    I think we need to add some parameters to Squeezelite but I'm not sure of the result, probably adjust -r or -R.

  3. #3
    Junior Member
    Join Date
    Feb 2020
    Posts
    4
    Here is the configuration that works with my DAC Audio-gd NFB-3.32 (if it can help others).

    I'm not convinced that the -R X gives anything on its own but I had already tried with -r 192000 and it didn't give anything
    Attached Images Attached Images  

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •