Home of the Squeezebox™ & Transporter® network music players.
Results 1 to 4 of 4
  1. #1
    Member
    Join Date
    Jul 2018
    Location
    Germany
    Posts
    57

    Picoreplayer/squeezelite: No sound

    Hello,

    I have a problem with my combination Raspberry2/hifiberry dac. I have no sound. I know about a manual configuration for running but I can't find,...

    aplay -l:
    Code:
    **** List of PLAYBACK Hardware Devices ****
    card 0: sndrpihifiberry [snd_rpi_hifiberry_dac], device 0: HifiBerry DAC HiFi pcm5102a-hifi-0 []
      Subdevices: 0/1
      Subdevice #0: subdevice #0
    /usr/local/etc/pcp/pcp.cfg:

    Code:
    WIFI="off"
    DEBUG="0"
    MODE="30"
    TEST="0"
    NAME="thk-aw5000-pi2"
    OUTPUT="sysdefault:CARD=sndrpihifiberry"
    ALSA_PARAMS="80:4::1:"
    BUFFER_SIZE=""
    _CODEC=""
    XCODEC=""
    PRIORITY=""
    MAX_RATE=""
    UPSAMPLE=""
    MAC_ADDRESS=""
    SERVER_IP=""
    LOGLEVEL=""
    LOGFILE=""
    DSDOUT=""
    VISUALISER=""
    CLOSEOUT=""
    UNMUTE=""
    ALSAVOLUME=""
    OTHER=""
    AUDIO="hifi_dac"
    AUDIOBOOTSCRIPT=""
    HOST="thk-aw5000-pi2"
    TIMEZONE="CET-1CEST,M3.5.0,M10.5.0/3"
    CPUGOVERNOR="ondemand"
    OVERCLOCK="NONE"
    ADVOVERCLOCK="None"
    CPUISOL=""
    SQLAFFINITY=""
    SQLOUTAFFINITY=""
    CMD="Default"
    FIQ="0xF"
    ALSAlevelout="Default"
    ALSAeq="no"
    STREAMER="no"
    REBOOT="Disabled"
    RB_H="0"
    RB_WD="*"
    RB_DMONTH="*"
    RESTART="Disabled"
    RS_H="0"
    RS_WD="*"
    RS_DMONTH="*"
    CRON_COMMAND=""
    AUTOSTARTLMS=""
    A_S_LMS="Disabled"
    AUTOSTARTFAV=""
    A_S_FAV="Disabled"
    USER_COMMAND_1=""
    USER_COMMAND_2=""
    USER_COMMAND_3=""
    JIVELITE="no"
    SCREENROTATE="180"
    JL_SCREEN_WIDTH="0"
    JL_SCREEN_HEIGHT="0"
    SHAIRPORT="no"
    LMSERVER="no"
    LMSDATA="default"
    SQLT_VERSION="basic"
    SQBINARY="default"
    SQUEEZELITE="yes"
    POWER_GPIO=""
    POWER_OUTPUT="L"
    POWER_SCRIPT=""
    GPIOPOWEROFF="no"
    GPIOPOWEROFF_GPIO="17"
    GPIOPOWEROFF_HI="yes"
    GPIOSHUTDOWN="no"
    GPIOSHUTDOWN_GPIO="22"
    GPIOSHUTDOWN_HI="yes"
    GPIOSHUTDOWN_PU="down"
    IR_LIRC="no"
    IR_KEYTABLES="no"
    IR_GPIO_IN="25"
    IR_GPIO_OUT=""
    IR_DEVICE="lirc0"
    IR_CONFIG=""
    LMSWEBPORT=""
    FSM="Default"
    LMSCONTROLS="yes"
    PLAYERTABS="yes"
    HDMIPOWER="on"
    APMODE="no"
    AP_IP=""
    RPI3INTWIFI="on"
    RPIBLUETOOTH="off"
    SAMBA="disabled"
    WOL="no"
    WOL_NIC=""
    WOL_LMSMACADDRESS=""
    SPARAMS1=""
    SPARAMS2=""
    SPARAMS3=""
    SPARAMS4=""
    SPARAMS5=""
    INTERNET_CHECK_IP=""
    ROTDASH="no"
    SHAIRPORT_OUT="hw:CARD=sndrpihifiberry"
    SHAIRPORT_CONTROL=""
    NETWORK_WAIT="50"
    GUI_DISABLE="0"
    WWW_PORT="80"
    I tryed to change the output settings to "sysdefault:CARD=sndrpihifiberry". It didn't help.

    Who has an idea for me??

    Thanks, thk_ms
    Last edited by thk_ms; 2020-02-13 at 14:20.

  2. #2
    Senior Member paul-'s Avatar
    Join Date
    Jan 2013
    Posts
    2,788
    Are you sure you have the old DAC, and not the DAC+.

    Donĺt use sysdefault, Leave it as hw:
    piCorePlayer a small player for the Raspberry Pi in RAM.
    Homepage: https://www.picoreplayer.org

    Please donate if you like the piCorePlayer

  3. #3
    Member
    Join Date
    Jul 2018
    Location
    Germany
    Posts
    57

    Driver

    hello,

    thank you for the question. It opened my mind. It was not the right driver. But there was not the right driver in the list. After go in the beta-settings I have the choice to set the right driver (hifiberryDAC+).

    Now the System runs,...

    But why is the DAC+-driver not in the nomal dropdown-menu?

    Thanks, thk_ms

  4. #4
    Senior Member paul-'s Avatar
    Join Date
    Jan 2013
    Posts
    2,788
    That's a known problem in 5.x.x. It's corrected in the 6.0.0 version.
    piCorePlayer a small player for the Raspberry Pi in RAM.
    Homepage: https://www.picoreplayer.org

    Please donate if you like the piCorePlayer

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •