Home of the Squeezebox™ & Transporter® network music players.
Results 1 to 4 of 4
  1. #1
    Junior Member
    Join Date
    Feb 2020
    Posts
    5

    Activate HDMI output at boot whitout TV

    Hi,
    Thanks for pCP !

    I got a small problem, for the living room I use a Raspberry Pi model 1B with HDMI output.
    I tried first with a HDMI to Toslink converter, each boot I need to connect the HDMI output to a TV, else there is no sound coming.
    I then put it to and HDMI input of an home cinema amplifier I bought, but I've to start the TV at boot if not there is no sound coming.
    I imagine there is an automatic config of the output at boot but is there some way to set it somewhere to avoid starting the TV each time ?

  2. #2
    Senior Member
    Join Date
    Apr 2005
    Location
    UK/London
    Posts
    2,449
    There are settings in config.txt that you can use to force HDMI to be on.

    See https://www.picoreplayer.org/how_to_...nfig_txt.shtml for how to edit it

    If you search for "hdmi" you will find a few different fields that you can adjust and there are comments in there to help.
    More detail on the various settings at https://www.raspberrypi.org/document...g-txt/video.md

    You might only need
    hdmi_safe=1
    Paul Webster
    http://dabdig.blogspot.com
    Author of "Now Playing" plugins covering Radio France (FIP etc), KCRW, Supla Finland, ABC Australia, CBC/Radio-Canada and RTE Ireland

  3. #3
    Junior Member
    Join Date
    Feb 2020
    Posts
    5
    Thanks for the fast answer.
    I check that ASAP and will post the result (I've to install a new server as my actual one is down) :s

  4. #4
    Junior Member
    Join Date
    Feb 2020
    Posts
    5
    I tried first hdmi_safe=1, it was working but with low res display and CEC start of my amplifier an TV on boot.

    Next try was better, hdmi_force_hotplug=1 is the only parameter needed to my problem : Setting hdmi_force_hotplug to 1 pretends that the HDMI hotplug signal is asserted, so it appears that a HDMI display is attached. In other words, HDMI output mode will be used, even if no HDMI monitor is detected.

    To avoid the CEC start, I just had to add hdmi_ignore_cec_init=1

    Thanks a lot !

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •