Home of the Squeezebox™ & Transporter® network music players.
Page 19 of 19 FirstFirst ... 9171819
Results 181 to 184 of 184
  1. #181
    Senior Member
    Join Date
    May 2010
    Location
    London, UK
    Posts
    753
    Quote Originally Posted by ralphy View Post
    Looks like this might be an issue with the v2019.78 as I found this in the changelog for the 2020.79.

    Fix idle detection clashing with keepalives, thanks to jcmathews.
    Feels right. Dropbear certainly dropped a message in the log that it "deliberately" closed the connection.

    I've logged the Radio wi-fi scanning issue on SqueezeOS-SqueezePlay with some thoughts for you to consider.

  2. #182
    Senior Member ralphy's Avatar
    Join Date
    Jan 2006
    Location
    Canada
    Posts
    2,790
    Quote Originally Posted by mrw View Post
    Feels right. Dropbear certainly dropped a message in the log that it "deliberately" closed the connection.
    Updating dropbear to 2020.81 does not fix the "dropped" connections.

    Unfortunately the radio rebooted last night after only 10 days uptime, so I've had to restart the test I was running to help track this down. No crash log either, so I don't have a clue as to why it rebooted.
    Ralphy

    1-Touch, 5-Classics, 3-Booms, 2-UE Radio
    Squeezebox client builds donations always appreciated.

  3. #183
    Senior Member ralphy's Avatar
    Join Date
    Jan 2006
    Location
    Canada
    Posts
    2,790
    Quote Originally Posted by ralphy View Post
    Updating dropbear to 2020.81 does not fix the "dropped" connections.

    Unfortunately the radio rebooted last night after only 10 days uptime, so I've had to restart the test I was running to help track this down. No crash log either, so I don't have a clue as to why it rebooted.
    I've been connected to the radio for two days now.

    Code:
    root     pts/0        192.168.x.x   Mon Dec 28 06:49   still logged in
    root     pts/1        192.168.x.x   Mon Dec 28 06:49   still logged in
    Turns out it's the non-zero keepalive value. You can add -K 0 to dropbear in /etc/inetd.conf and remove -I 0. I've updated the dropbear build configuration file to fix it for the next build.
    Ralphy

    1-Touch, 5-Classics, 3-Booms, 2-UE Radio
    Squeezebox client builds donations always appreciated.

  4. #184
    Senior Member
    Join Date
    May 2010
    Location
    London, UK
    Posts
    753
    Quote Originally Posted by ralphy View Post
    Turns out it's the non-zero keepalive value. You can add -K 0 to dropbear in /etc/inetd.conf and remove -I 0. I've updated the dropbear build configuration file to fix it for the next build.
    Good find. I'll try that out. I find the Dropbear documentation somewhat confusing on the point.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •