Home of the Squeezebox™ & Transporter® network music players.
Results 1 to 6 of 6
  1. #1
    Junior Member
    Join Date
    Oct 2009
    Posts
    9

    Spotty stream disrupted during playback.

    Hi
    New to posting here but have been an avid follower here and using sb for years now. Ultimately as my sb gear die looking to go rasppi generally it is working great. However I have been having intermittent drop outs in my spotty playback. About 1-2 per minute while playing back from spotify. Using same rasppi as lms and picore player. Same problem on wifi and wired network. Don't have the issue when streaming from a second lms on my nas with local stored files.

    Really appreciate any suggestions
    thanks
    Michael

    Running
    PCPVERS="piCorePlayer 5.0.0"
    Squeezelite v1.9.6-1198-pCP
    Rasppi 3 b with hifiberry hat powered speakers
    Networked with wifi 5ghz 2.4 gz
    Using netgear orbi WIFI router

    Here is a cap of the logs the slimpro error connection dead on line 3 is what I see when the audio stops resuming itself when sendstat starts again.

    > [13:17:38.335236] sendSTAT:189 STAT: STMt
    > [13:17:39.336390] sendSTAT:189 STAT: STMt
    > [13:17:40.337566] slimproto_run:600 No messages from server - connection dead
    > [13:17:40.437964] slimproto:926 connected
    > [13:17:40.438025] slimproto:937 local player
    > [13:17:40.438041] sendHELO:142 mac: b8:27:eb:ce:c0:31
    > [13:17:40.438055] sendHELO:144 cap:
    > CanHTTPS=1,Model=squeezelite,AccuratePlayPoints=1, HasDigitalOut=1,HasPolarityInversion=1,Firmware=v1 .9.6-1198-pCP,ModelName=SqueezeLite,MaxSampleRate=384000,dsf ,dff,aac,ogg,ops,ogf,flc,aif,pcm,mp3,loc
    > [13:17:40.442475] sendSTAT:189 STAT: STMt
    > [13:17:40.442565] process:521 strm
    > [13:17:40.442579] process_strm:274 strm command q
    > [13:17:40.442592] decode_flush:237 decode flush
    > [13:17:40.442605] output_flush:435 flush output buffer
    > [13:17:40.442886] sendSTAT:189 STAT: STMf
    > [13:17:40.470484] process:521 audg
    > [13:17:40.470539] process_audg:433 audg gainL: 46592 gainR: 46592 adjust: 1
    > [13:17:40.470556] set_volume:233 setting internal gain left: 46592 right: 46592
    > [13:17:40.474017] process:521 strm
    > [13:17:40.474080] process_strm:274 strm command s
    > [13:17:40.474093] process_strm:344 strm s autostart: 0 transition
    > period: 10 transition type: 0 codec: p
    > [13:17:40.474110] sendSTAT:189 STAT: STMf
    > [13:17:40.474157] codec_open:265 codec open: 'p'
    > [13:17:40.474173] codec_open:283 closing codec: 'o'
    > [13:17:40.474337] pcm_open:397 pcm size: 2 rate: 44100 chan: 2 bigendian: 0
    > [13:17:40.474371] _tcp_connect:486 connecting to 192.168.0.28:9000
    > [13:17:40.474510] stream_sock:577 header: GET
    > /stream.mp3?player=b8:27:eb:ce:c0:31 HTTP/1.0
    >
    >
    > [13:17:40.474596] sendSTAT:189 STAT: STMc
    > [13:17:40.474635] process_strm:377 set fade mode: 0
    > [13:17:40.475162] process:521 audg
    > [13:17:40.475186] process_audg:433 audg gainL: 46592 gainR: 46592 adjust: 1
    > [13:17:40.475201] set_volume:233 setting internal gain left: 46592 right: 46592
    > [13:17:40.476005] process:521 setd
    > [13:17:40.476036] sendSETDName:248 set playername: piCorePlayer
    > [13:17:40.476201] process:521 setd
    > [13:17:40.476597] process:521 aude
    > [13:17:40.476614] process_aude:415 enable spdif: 1 dac: 1
    > [13:17:40.476929] process:521 audg
    > [13:17:40.476946] process_audg:433 audg gainL: 46592 gainR: 46592 adjust: 1
    > [13:17:40.476961] set_volume:233 setting internal gain left: 46592 right: 46592
    > [13:17:40.523209] stream_thread:247 headers: len: 115
    > HTTP/1.1 200 OK
    > Server: Logitech Media Server (7.9.2 - 1567524015)
    > Connection: close
    > Content-Type: audio/L16
    >
    >
    > [13:17:40.523315] slimproto_run:720 output timeout
    > [13:17:40.523333] sendRESP:220 RESP
    > [13:17:40.533568] output_thread:804 disabling output
    > [13:17:46.849984] sendSTAT:189 STAT: STMl
    > [13:17:46.898792] process:521 strm
    > [13:17:46.898845] process_strm:274 strm command u
    > [13:17:46.898861] process_strm:331 unpause at: 1774677 now: 1774479
    > [13:17:46.898878] sendSTAT:189 STAT: STMr
    > [13:17:46.929000] pcm_decode:206 setting track_start
    > [13:17:46.937056] output_thread:687 open output device: hw:CARD=sndrpihifiberry
    > [13:17:46.937114] alsa_open:351 opening device at: 44100
    > [13:17:46.939161] alsa_open:422 opened device hw:CARD=sndrpihifiberry
    > using format: S32_LE sample rate: 44100 mmap: 1
    > [13:17:46.939231] alsa_open:513 buffer: 40 period: 4 -> buffer size:
    > 1764 period size: 441
    > [13:17:47.102933] _output_frames:149 track start sample rate: 44100
    > replay_gain: 65536
    > [13:17:47.899981] sendSTAT:189 STAT: STMs
    > [13:17:47.900102] sendSTAT:189 STAT: STMt
    > [13:17:48.280663] process:521 strm
    > [13:17:48.280712] process_strm:274 strm command a
    > [13:17:48.280726] process_strm:320 skip ahead interval: 24
    > [13:17:48.282728] _output_frames:72 skip 1058 of 1058 frames
    > [13:17:49.281799] sendSTAT:189 STAT: STMt
    > [13:17:50.282962] sendSTAT:189 STAT: STMt
    > [13:17:51.284135] sendSTAT:189 STAT: STMt
    > [13:17:52.285305] sendSTAT:189 STAT: STMt
    > [13:17:53.286458] sendSTAT:189 STAT: STMt
    > [13:17:54.287609] sendSTAT:189 STAT: STMt
    > [13:17:55.288808] sendSTAT:189 STAT: STMt
    > [13:17:56.289990] sendSTAT:189 STAT: STMt
    > [13:17:57.291149] sendSTAT:189 STAT: STMt

  2. #2
    Senior Member
    Join Date
    Jan 2011
    Location
    Staffordshire. UK
    Posts
    3,101
    Hi raoul

    I have two suggestions,

    do the hotfix on pCP to change to v5.0.1

    and

    Update LMS (LMS page...Nightly Update)

    Some folk have experienced problems withthe 'Orbi' router stuff....I don't have a clue if that is possible in your situation

    ronnie

  3. #3
    Junior Member
    Join Date
    Oct 2009
    Posts
    9
    Thanks Ronnie will give that a try.

  4. #4
    Babelfish's Best Boy mherger's Avatar
    Join Date
    Apr 2005
    Location
    Switzerland
    Posts
    20,367

    Spotty stream disrupted during playback.

    > spotify. Using same rasppi as lms and picore player. Same problem on

    Are you saying that you're running Spotty on a pCP? That should
    certainly work. I'm doing this myself. Just make sure you update all
    components to the latest available. Then please go check the server's
    server.log file, too.

    --

    Michael

  5. #5
    Junior Member
    Join Date
    Oct 2009
    Posts
    9
    Ok have updated to
    piCorePlayer | piCorePlayer v5.0.1 | linux 4.19.40-pcpCore_v7 | piCore v10.1pCP | Squeezelite v1.9.6-1198-pCP
    Logitech Media Server Version: 7.9.2 - 1567524015 @ Wed Sep 4 12:29:09 CEST 2019
    The lms nightly build did not have anything to upgrade to when selecting that
    However the bianaries update did update quite a lot of items.
    Nothing of note in the server log

    Stream drop still happening tho.

    [21:09:03.015142] sendSTAT:189 STAT: STMt
    [21:09:04.016305] sendSTAT:189 STAT: STMt
    [21:09:05.017453] slimproto_run:600 No messages from server - connection dead
    [21:09:05.117814] slimproto:926 connected
    [21:09:05.117867] slimproto:937 local player
    [21:09:05.117883] sendHELO:142 mac: b8:27:eb:ce:c0:31
    [21:09:05.117896] sendHELO:144 cap: CanHTTPS=1,Model=squeezelite,AccuratePlayPoints=1, HasDigitalOut=1,HasPolarityInversion=1,Firmware=v1 .9.6-1198-pCP,ModelName=SqueezeLite,MaxSampleRate=384000,dsf ,dff,aac,ogg,ops,ogf,flc,aif,pcm,mp3,loc
    [21:09:05.122715] sendSTAT:189 STAT: STMt
    [21:09:05.122799] process:521 strm
    [21:09:05.122813] process_strm:274 strm command q
    [21:09:05.122827] decode_flush:237 decode flush
    [21:09:05.122839] output_flush:435 flush output buffer
    [21:09:05.123080] sendSTAT:189 STAT: STMf
    [21:09:05.148293] process:521 audg
    [21:09:05.148348] process_audg:433 audg gainL: 46592 gainR: 46592 adjust: 1
    [21:09:05.148364] set_volume:233 setting internal gain left: 46592 right: 46592
    [21:09:05.151496] process:521 strm
    [21:09:05.151549] process_strm:274 strm command s
    [21:09:05.151562] process_strm:344 strm s autostart: 0 transition period: 10 transition type: 0 codec: p
    [21:09:05.151580] sendSTAT:189 STAT: STMf
    [21:09:05.151621] codec_open:265 codec open: 'p'
    [21:09:05.151636] pcm_open:397 pcm size: 2 rate: 44100 chan: 2 bigendian: 0
    [21:09:05.151680] _tcp_connect:486 connecting to 192.168.0.28:9000
    [21:09:05.151838] stream_sock:577 header: GET /stream.mp3?player=b8:27:eb:ce:c0:31 HTTP/1.0


    [21:09:05.151855] sendSTAT:189 STAT: STMc
    [21:09:05.151874] process_strm:377 set fade mode: 0
    [21:09:05.152311] process:521 audg
    [21:09:05.152330] process_audg:433 audg gainL: 46592 gainR: 46592 adjust: 1
    [21:09:05.152345] set_volume:233 setting internal gain left: 46592 right: 46592
    [21:09:05.152953] process:521 setd
    [21:09:05.152974] sendSETDName:248 set playername: piCorePlayer
    [21:09:05.153133] process:521 setd
    [21:09:05.153496] process:521 aude
    [21:09:05.153514] process_aude:415 enable spdif: 1 dac: 1
    [21:09:05.153817] process:521 audg
    [21:09:05.153836] process_audg:433 audg gainL: 46592 gainR: 46592 adjust: 1
    [21:09:05.153851] set_volume:233 setting internal gain left: 46592 right: 46592
    [21:09:05.165547] stream_thread:247 headers: len: 115
    HTTP/1.1 200 OK
    Server: Logitech Media Server (7.9.2 - 1567524015)
    Connection: close
    Content-Type: audio/L16


    [21:09:05.165660] slimproto_run:720 output timeout
    [21:09:05.165679] sendRESP:220 RESP
    [21:09:05.178554] output_thread:804 disabling output
    [21:09:13.084291] sendSTAT:189 STAT: STMl
    [21:09:13.118719] process:521 strm
    [21:09:13.118773] process_strm:274 strm command u
    [21:09:13.118790] process_strm:331 unpause at: 1720722 now: 1720524
    [21:09:13.118825] sendSTAT:189 STAT: STMr
    [21:09:13.164765] pcm_decode:206 setting track_start
    [21:09:13.186029] output_thread:687 open output device: hw:CARD=sndrpihifiberry
    [21:09:13.186090] alsa_open:351 opening device at: 44100
    [21:09:13.188146] alsa_open:422 opened device hw:CARD=sndrpihifiberry using format: S32_LE sample rate: 44100 mmap: 1
    [21:09:13.188221] alsa_open:513 buffer: 40 period: 4 -> buffer size: 1764 period size: 441
    [21:09:13.321798] _output_frames:149 track start sample rate: 44100 replay_gain: 65536
    [21:09:14.119912] sendSTAT:189 STAT: STMs
    [21:09:14.120025] sendSTAT:189 STAT: STMt
    [21:09:14.972672] process:521 strm
    [21:09:14.972730] process_strm:274 strm command a
    [21:09:14.972746] process_strm:320 skip ahead interval: 26
    [21:09:14.991644] _output_frames:72 skip 1146 of 1146 frames
    [21:09:15.973803] sendSTAT:189 STAT: STMt
    [21:09:16.974979] sendSTAT:189 STAT: STMt
    [21:09:17.976147] sendSTAT:189 STAT: STMt
    [21:09:18.977293] sendSTAT:189 STAT: STMt
    [21:09:19.978470] sendSTAT:189 STAT: STMt
    [21:09:20.979644] sendSTAT:189 STAT: STMt
    Last edited by raoul; 2020-02-10 at 03:12.

  6. #6
    Junior Member
    Join Date
    Oct 2009
    Posts
    9
    I did some listening tests today. Found that the connect dead meassages in the log no longer coincide with the audio being disrupted. So we might have a fix after all.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •