Recently purchased Pi 3B+ with Inno Hat DAC and official 7" touchcreen. Hooked all the hardware up and loaded pCp. On the first boot the touchscreen showed the boot page. Then loaded driver for DAC - using 'Allo Boss DAC (and mini Boss)' per Inno instructions, loaded Wifi and configured - then loaded Jivelite and got nothing on the screen. Things I have tried:
- Loaded NOOBS on separate SD card - no screen response
- Double checked ribbon cable/power supply jumpers - everything seems proper
- Tried to run screen using separate power supply with jumper wires pulled - no screen response
- Reformatted and reloaded pCp - this time boot screen did not come up
- Loaded Putty and SSH - tried commands on this link: https://www.raspberrypi.org/document...bleshooting.md

Running 'dmesg | grep -i ft5406' yields:
[ 7.268672] rpi-ft5406 rpi_ft5406: Probing device
[ 7.274748] input: FT5406 memory based driver as /devices/virtual/input/input0

Which looks correct to my 'early learning' Linux eye.

Running 'cat /proc/cmdline | grep bcm2708_fb' yields:
coherent_pool=1M 8250.nr_uarts=1 bcm2708_fb.fbwidth=800 bcm2708_fb.fbheight=480 bcm2708_fb.fbdepth=16 bcm2708_fb.fbswap=1 vc_mem.mem_base=0x3f000000 vc_mem.mem_size=0x3f600000 tz=EST5EDT,M3.2.0,M11.1.0 dwc_otg.fiq_fsm_mask=0xF host=piCorePlayer dwc_otg.lpm_enable=0 console=tty1 root=/dev/ram0 elevator=deadline rootwait quiet nortc loglevel=3 noembed smsc95xx.turbo_mode=N noswap consoleblank=0 waitusb=2

Which also looks correct (but I'm not sure on all the settings here)

pCp/Squeezelite is running just fine and the hat DAC sounds good - just need to determine if the touchscreen issue is hardware fault or software set up error. Ready to return screen and re-order but want to make sure I'm not missing something in the troubleshooting. Please let me know any suggestions to try.