Home of the Squeezebox™ & Transporter® network music players.
Results 1 to 5 of 5
  1. #1
    Junior Member
    Join Date
    Feb 2020
    Posts
    2

    No Output Device AKA No Sound on Picoreplayer 5.0 Pi3

    I had picoreplayer configured and set up on Pi3, player seems to be detected fine on Qnap version LMS server, plays fine through audio jack on Pi but for the life of me, I couldn't get it to work with external USB DAC.
    I am using Jolida Glass FX DAC DSD connected to picoreplayer through USB, for some reason player does not recognize external USB DAC (multiple reboot with different sqeezelite dac options). I am not familiar with Linux, based on my research I found command dmessg | grep USB, the result shows Pi seeing Jolida DAC but when I run aplay -L command, it does not detect output hardware.
    Any idea how to get DAC recognized?

  2. #2
    Senior Member paul-'s Avatar
    Join Date
    Jan 2013
    Posts
    2,802
    Looks like we might be missing a codec driver for that dac. I should be able to add it in the next 6.0.0 release.
    piCorePlayer a small player for the Raspberry Pi in RAM.
    Homepage: https://www.picoreplayer.org

    Please donate if you like the piCorePlayer

  3. #3
    Junior Member
    Join Date
    Feb 2020
    Posts
    2
    Quote Originally Posted by paul- View Post
    Looks like we might be missing a codec driver for that dac. I should be able to add it in the next 6.0.0 release.
    Thank you for your reply.
    Would upgrading picoreplayer to ver. 6.0 beta fix DAC issue?

  4. #4
    Senior Member paul-'s Avatar
    Join Date
    Jan 2013
    Posts
    2,802
    No......but the next release. But something Iĺll need to check before I can release it.....hope soon.
    piCorePlayer a small player for the Raspberry Pi in RAM.
    Homepage: https://www.picoreplayer.org

    Please donate if you like the piCorePlayer

  5. #5
    Senior Member paul-'s Avatar
    Join Date
    Jan 2013
    Posts
    2,802
    Actually, did some digging, I don't see anything missing. USB should work without extra drivers. But the rpi USB is very sketchy for DAC's

    Can you post the end of the dmesg section.....I want to see what is there.

    Then go to the tweaks page, and try making changes to these settings....see if you can find a combination that works.

    Name:  2020-02-03_21-55.png
Views: 36
Size:  87.5 KB
    piCorePlayer a small player for the Raspberry Pi in RAM.
    Homepage: https://www.picoreplayer.org

    Please donate if you like the piCorePlayer

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •