Home of the Squeezebox™ & Transporter® network music players.
Results 1 to 6 of 6
  1. #1
    Junior Member
    Join Date
    Mar 2012
    Posts
    10

    Extremely loud distortion (popping crackling sound) when switching sampling rate

    Help is very much needed here.

    My SBT is fed to an external DAC and thereafter an amplifier. For a long time I have noticed that there is an extremely loud clipping/crackling/scratchy distorted sound (of almost explosive proportions) when changing between tracks that have different sampling or bit rates, or between flac and mp3 tracks. Not sure when changing from a lower rate to a higher rate or the other way round.

    Unfortunately, after many occasions of that loud distortion/noise my tweeters are fried, i think. (or could it be the amp?)

    I'm in the process of getting a new pair, but am desperately seeking advice on how to safely use the SBT with a new pair of speakers so as to avoid a repeat of this debacle.

    Advice is most appreciated.

    Regards
    Fred

  2. #2
    Senior Member Apesbrain's Avatar
    Join Date
    Jun 2005
    Location
    East Coast, USA
    Posts
    1,438
    Does the same thing happen if you temporarily connect the Touch analog out to your amp?

  3. #3
    Junior Member
    Join Date
    Mar 2012
    Posts
    10
    Quote Originally Posted by Apesbrain View Post
    Does the same thing happen if you temporarily connect the Touch analog out to your amp?
    unfortunately, right now, my speakers are fried and i am not able to test out your suggestion.

    i have also done a bit of further searching on this forum and am wondering if this loud, explosive, distortion/noise is what is referred to in these forums as 'white noise' ?

  4. #4
    Senior Member
    Join Date
    Jan 2010
    Location
    Hertfordshire
    Posts
    3,869
    Quote Originally Posted by syrah View Post
    unfortunately, right now, my speakers are fried and i am not able to test out your suggestion.

    i have also done a bit of further searching on this forum and am wondering if this loud, explosive, distortion/noise is what is referred to in these forums as 'white noise' ?
    What are your cross-fade settings?

    Sent from my Pixel 3a using Tapatalk

  5. #5
    Junior Member
    Join Date
    Mar 2012
    Posts
    10
    [QUOTE=slartibartfast;963176]What are your cross-fade settings?

    cross fade is checked.

    i think the distortion noise always happens at the end of a track, in particular if the next track has a different format (mp3 vs flac) of if the sampling rate or bit depth is different.

  6. #6
    Senior Member
    Join Date
    Jan 2010
    Location
    Hertfordshire
    Posts
    3,869
    [QUOTE=syrah;963178]
    Quote Originally Posted by slartibartfast View Post
    What are your cross-fade settings?

    cross fade is checked.

    i think the distortion noise always happens at the end of a track, in particular if the next track has a different format (mp3 vs flac) of if the sampling rate or bit depth is different.
    Try it with cross fade turned off.
    https://forums.slimdevices.com/showt...at-end-of-song

    Sent from my Pixel 3a using Tapatalk

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •