Home of the Squeezebox™ & Transporter® network music players.
Page 2 of 4 FirstFirst 1234 LastLast
Results 11 to 20 of 39
  1. #11
    Senior Member paul-'s Avatar
    Join Date
    Jan 2013
    Posts
    3,067
    Quote Originally Posted by Aldoszx View Post
    I think i2c-tools is missing !
    i2c-tools is not needed. You need to manually load the i2c-dev module. This does not load automatically.

    sudo modprobe i2c-dev
    piCorePlayer a small player for the Raspberry Pi in RAM.
    Homepage: https://www.picoreplayer.org

    Please donate if you like the piCorePlayer

  2. #12
    Senior Member
    Join Date
    Apr 2019
    Location
    Wunstorf, Germany
    Posts
    261
    Quote Originally Posted by paul- View Post
    sudo modprobe i2c-dev
    Ok. I did it. Do we have to do it every time after boot?
    I used this command as the first user command.

    Now it starts without any problem. I will test if the fan is starting now.
    Last edited by carsten_h; 2020-01-25 at 15:21.

  3. #13
    Senior Member paul-'s Avatar
    Join Date
    Jan 2013
    Posts
    3,067
    Quote Originally Posted by carsten_h View Post
    Ok. I did it. Do we have to do it every time after boot? Then I would start it in the script.

    Then I get this error:
    Code:
    Exception in thread Thread-2:
    Traceback (most recent call last):
      File "/usr/local/lib/python3.6/threading.py", line 916, in _bootstrap_inner
        self.run()
      File "/usr/local/lib/python3.6/threading.py", line 864, in run
        self._target(*self._args, **self._kwargs)
      File "argononed.py", line 81, in temp_check
        val = float(temp.replace("'C",""))
    ValueError: could not convert string to float: 'VCHI initialization failed\n'
    Yes you need to load i2c-dev before starting the script. The script has to run with root permissions, as it make a call to vcgencmd, which requires it.
    piCorePlayer a small player for the Raspberry Pi in RAM.
    Homepage: https://www.picoreplayer.org

    Please donate if you like the piCorePlayer

  4. #14
    Junior Member
    Join Date
    Jan 2020
    Posts
    14
    Quote Originally Posted by paul- View Post
    Yes you need to load i2c-dev before starting the script. The script has to run with root permissions, as it make a call to vcgencmd, which requires it.
    Thanks Paul !
    Now it is working !
    The fan also is on, according to temp settings !

  5. #15
    Senior Member
    Join Date
    Apr 2019
    Location
    Wunstorf, Germany
    Posts
    261
    Quote Originally Posted by paul- View Post
    The script has to run with root permissions, as it make a call to vcgencmd, which requires it.
    Which script? The argononed.py?

    I wrote another temperature entry inside the py script, as my Pi was only 46°C and now the fan is running. Thank you very much for your help!

    The gpio-shutdown script from the tweaks page will be deleted when I set this to "No"?
    I am only asking because the shutdown button is still shutting down so that the USB drives are not cleanly dismounted.

    Oh, the fan is really loud. I think I should only use the fan when the Pi is getting really hot.

  6. #16
    Junior Member
    Join Date
    Jan 2020
    Posts
    14
    Quote Originally Posted by carsten_h View Post
    The gpio-shutdown script from the tweaks page will be deleted when I set this to "No"?
    I am only asking because the shutdown button is still shutting down so that the USB drives are not cleanly dismounted.
    I think you only should uninstall the extension.
    The shutdown button must be ON, in order to define the GPIO pin for shutdown.

    Paul, it is correct ?

    Yes, the fan is loud ! I intend to replace it with another one more silent.
    Mine is set to start at 40 degrees, at 10% speed.
    Usually the temp stays below 40.
    Last edited by Aldoszx; 2020-01-25 at 15:45.

  7. #17
    Senior Member
    Join Date
    Apr 2019
    Location
    Wunstorf, Germany
    Posts
    261
    Quote Originally Posted by Aldoszx View Post
    The shutdown button must be ON, in order to define the GPIO pin for shutdown.
    If I look into the script, I find the following line:
    Code:
    GPIO.setup(shutdown_pin, GPIO.IN,  pull_up_down=GPIO.PUD_DOWN)
    So I think the correct setting should be used.

    But I saw the following reaction to the pressed button. Regardless how long I press it, the reaction is always a shutdown.
    Although in the code I see that from 2 to 3 seconds (pulses) there should be a reboot happen and from 4 to 5 seconds there should be a shutdown happen. But there is no difference between pressing long or short.

  8. #18
    Senior Member paul-'s Avatar
    Join Date
    Jan 2013
    Posts
    3,067
    Yes, remove the shutdown overlay and the shutdown monitor extension.

    The python script should call “pcp rb” for a reboot. Or “pcp sd” for shutdown.

    Drives should be unmounted, but exfat is an odd file system. It doesn’t have direct kernel support.
    piCorePlayer a small player for the Raspberry Pi in RAM.
    Homepage: https://www.picoreplayer.org

    Please donate if you like the piCorePlayer

  9. #19
    Junior Member
    Join Date
    Jan 2020
    Posts
    14
    Thank you !
    There is another way to load the i2c-dev module besides user commands?
    Could be done automatically via auto start script?
    Last edited by Aldoszx; 2020-01-26 at 01:53.

  10. #20
    Senior Member
    Join Date
    Apr 2019
    Location
    Wunstorf, Germany
    Posts
    261
    Quote Originally Posted by paul- View Post
    Yes, remove the shutdown overlay and the shutdown monitor extension.
    What is the correct ist way to do it? Only switching to „No“.?

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •