Home of the Squeezebox™ & Transporter® network music players.
Results 1 to 8 of 8

Threaded View

  1. #1
    Junior Member
    Join Date
    May 2015
    Posts
    21

    Transporter only displays phonatic translation of Chinese (pinyin).

    HI there,

    NAS: Readynas RN31400
    Readynas OS: 6.10.2
    LMS version: 7.9.3 nightly
    perl version on the NAS: 5.20.2

    I have been struggling to get this work. I just bought a Readynas RN314 and trying to set it up as a LMS. Everything works fine except the display of Chinese on the Transporter. However, my logitech Radio displays Chinese perfectly correct under the same LMS. I have researched the forum here and recognized the mismatch of "freetype font". I am unable to fix it as I would need a more step by step instruction.

    Here is bit more detail. The server starts fine without an player running.Once I tried to start the Transporter, the line of log would show up:

    Code:
    [20-01-24 06:22:19.3014] Slim::Display::Lib::Fonts::__ANON__ (84) Warning: Unable to load TrueType font support: Can't locate loadable object for module Font::FreeType in @INC (@INC contains: /var/lib/squeezeboxserver/cache/InstalledPlugins /usr/share/squeezeboxserver/CPAN/arch/5.20/x86_64-linux-thread-multi /usr/share/squeezeboxserver/CPAN/arch/5.20/x86_64-linux-thread-multi/auto /usr/share/squeezeboxserver/CPAN/arch/5.20.2/x86_64-linux-gnu-thread-multi /usr/share/squeezeboxserver/CPAN/arch/5.20.2/x86_64-linux-gnu-thread-multi/auto /usr/share/squeezeboxserver/CPAN/arch/5.20/x86_64-linux-gnu-thread-multi /usr/share/squeezeboxserver/CPAN/arch/5.20/x86_64-linux-gnu-thread-multi/auto /usr/share/squeezeboxserver/CPAN/arch/x86_64-linux-gnu-thread-multi /usr/share/squeezeboxserver/CPAN/arch/5.20 /usr/share/squeezeboxserver/lib /usr/share/squeezeboxserver/CPAN /usr/share/squeezeboxserver /usr/share/squeezeboxserver/CPAN /usr/share/squeezeboxserver /usr/sbin /etc/perl /usr/local/lib/x86_64-linux-gnu/perl/5.20.2 /usr/local/share/perl/5.20.2 /usr/lib/x86_64-linux-gnu/perl5/5.20 /usr/share/perl5 /usr/lib/x86_64-linux-gnu/perl/5.20 /usr/share/perl/5.20 /usr/local/lib/site_perl .) at /usr/share/perl5/Slim/Display/Lib/Fonts.pm line 83.
    Compilation failed in require at /usr/share/perl5/Slim/Display/Lib/Fonts.pm line 83.
    I have tried different ways of installation (the stock 7.9 and two step installation with the nightly first then lms.xxx.deb. No difference.

    your help is greatly appreciated.

    I Have also tried Qnap TVS471 with @digimaster 's qLMS, with same result. So is with a Docker. The only way it works right now is running the LMS on Win10 Virtual machine.

    Thanks
    Last edited by tigs; 2020-01-24 at 07:50.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •