Home of the Squeezebox™ & Transporter® network music players.
Page 3 of 3 FirstFirst 123
Results 21 to 30 of 30
  1. #21
    Senior Member
    Join Date
    Apr 2008
    Location
    Paris, France
    Posts
    2,242
    Hello Michael, all, long time no see.

    I'm glad to discover projects like LMS 8 or that dizzying squeezeAMP thing. And also I broke out picoreplayer 6.0 yesterday, looks great and works great as always.

    I was wondering if any thoughts would go towards making LMS more "container native"?


    It is possible to spawn an entire system (all RPis in my case) in one go: server, players (squeezelite), and dedicated network. I have a feeling it might be useful, although pCP and -I suppose- squeezeAMP simplify deployment greatly in their own way.

    In general, running LMS as a component feels a little contrary. The squeezeboxserver_safe thing is redundant with external means of ensuring health checking and restart, preferences are buried deep in the fs, logging to stdout would be more natural etc.
    Perhaps LMS could be componentized a bit so that it could support, e.g. a clustered front-end. I don't know if that make sense; only thing I know is that running without the web frontend makes the server use less RAM.
    I played only with radio streams, so did not went on to explore the distributed audio files situation; I feel it's feasible but I know something would happen to the DB if, say, half of the files go away at runtime or between runs.

    Image building is not optimal. With limited time to dedicate to the container, I ended up with a rather fat debian+LMS package image, and an "entrypoint" that summons "squeezeboxserver" directly.
    I visited the Alpine alley in hope of a quick weight gain and found no usable (or recent?) package. I then had the idea of creating a makefile set for buildroot but I backed off in a hurry (sorry for that.)

    Again, glad to see the community in great shape.
    2 SB 3 • 1 PCP 6 • Libratone Loop, Zipp, Zipp Mini • iPeng (iPhone + iPad) • LMS 7.9 (linux) with plugins: CD Player, WaveInput, Triode's BBC iPlayer by bpa • IRBlaster by Gwendesign (Felix) • Smart Mix, Music Walk With Me, What Was That Tune? by Michael Herger • PowerSave by Jason Holtzapple • Song Info, Song Lyrics by Erland Isaksson • AirPlay Bridge by philippe_44 • WeatherTime by Martin Rehfeld • Auto Dim Display, SaverSwitcher, ContextMenu by Peter Watkins.

  2. #22
    That means LMS LogitechMediaServer-7.9.3-1582867832.exe is the latest and last version of the 7.9 development?
    It's totally fine if it is, it works great. I will hold off 8.x for now if it's in Alpha state.

  3. #23
    Babelfish's Best Boy mherger's Avatar
    Join Date
    Apr 2005
    Location
    Switzerland
    Posts
    20,430

    Announcement thread LMS 8.0 - whatare the differences?

    > That means LMS LogitechMediaServer-7.9.3-1582867832.exe is the latest

    Yes, as of today.

    > and last version of the 7.9 development?


    I don't know. I'm still going to apply fixes if there are crucial issues
    to be fixed.

    --

    Michael

  4. #24
    Babelfish's Best Boy mherger's Avatar
    Join Date
    Apr 2005
    Location
    Switzerland
    Posts
    20,430

    Announcement thread LMS 8.0 - whatare the differences?

    > I was wondering if any thoughts would go towards making LMS more
    > "container-native"?


    Please follow up in this thread:

    http://forums.slimdevices.com/showthread.php?t=111828

    --

    Michael

  5. #25
    Member
    Join Date
    Dec 2017
    Location
    PARIS, Fr
    Posts
    93
    Hello and thank you so much for providing this great software for us.
    I just installed version 8.0 on my Synology ds418j.
    It runs perfectly so far, but one thing changed here, compared to 7.9.2:
    In 7.9.2 all my various artists CDs showed up in compilations.
    Now in version eight compilations is empty.
    The CDs are not tagged as compilations, but the album artist is various artists.
    I did not change anything, could someone maybe help me to make these CDs show up in compilations again?
    Just a small minor issue,, thanks a lot.
    The Earth Has Music For Those Who Listen

  6. #26
    Member
    Join Date
    Dec 2017
    Location
    PARIS, Fr
    Posts
    93
    Quote Originally Posted by Pommes View Post
    Hello and thank you so much for providing this great software for us.
    I just installed version 8.0 on my Synology ds418j.
    It runs perfectly so far, but one thing changed here, compared to 7.9.2:
    In 7.9.2 all my various artists CDs showed up in compilations.
    Now in version eight compilations is empty.
    The CDs are not tagged as compilations, but the album artist is various artists.
    I did not change anything, could someone maybe help me to make these CDs show up in compilations again?
    Just a small minor issue,, thanks a lot.
    After a rescan the various artists albums show in compilations again:-)
    The Earth Has Music For Those Who Listen

  7. #27

    update to version 8.0 loosing all settings

    I did an update more then two weeks ago.
    In fact i did three updates and every time i am loosing all my settings.
    Restoring cache and prefs solves most but even the scan location is lost.
    Is that a known problem or am i missing something?
    i am on : Logitech Media Server Versie: 8.0.0 - 1588799628 @ Wed May 6 23:43:18 WEDT 2020

  8. #28
    Babelfish's Best Boy mherger's Avatar
    Join Date
    Apr 2005
    Location
    Switzerland
    Posts
    20,430

    Announcement thread LMS 8.0 - whatare the differences?

    > In fact i did three updates and every time i am loosing all my settings.
    > Restoring cache and prefs solves most but even the scan location is
    > lost.


    What OS are you using? Is there anything in the server.log while LMS is
    running?

    --

    Michael

  9. #29
    Not really.. only some plugin errors after te reinstallation of them ( sugarcube)
    Running on Windows 10/1909

    Looks like the install, source: http://downloads.slimdevices.com/nig...ex.php?ver=8.0
    deleted all the settings during the installation.

    Any tips what to activate in the logfiles? Lots of options, but not sure how useful they are.

    (Plugins::SugarCube::Plugin::commandCallback (715) We Paused
    Plugins::SugarCube::Plugin::commandCallback (709) We Stopped )

  10. #30
    Babelfish's Best Boy mherger's Avatar
    Join Date
    Apr 2005
    Location
    Switzerland
    Posts
    20,430

    Announcement thread LMS 8.0 - whatare the differences?

    > Running on Windows 10/1909
    >
    > Looks like the install, source:
    > http://downloads.slimdevices.com/nig...ex.php?ver=8.0
    > deleted all the settings during the installation.


    There's an option to delete them when you _uninstall_. But a normal
    update shouldn't touch them.

    --

    Michael

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •