Home of the Squeezebox™ & Transporter® network music players.
Page 1 of 3 123 LastLast
Results 1 to 10 of 27
  1. #1
    Senior Member kidstypike's Avatar
    Join Date
    Feb 2007
    Location
    Brindle
    Posts
    3,622

    Browse Discs and folders problem

    Pi4/pCP, latest LMS nightly, 18000+ music files on mounted SSD drive, LMS scans the music folder on this drive.

    I also have 60,000+ music files on this drive that I access through Discs and folders. This works okay most of the time. However, for some time (months?), browsing D&F shows "Empty". This occurs even when I'm actually playing an album/tracks that I've started by browsing D&F.

    Restarting LMS always fixes the problem, but it's becoming a pain. LMS/Settings/Information/Server logs shows -

    Code:
    [20-01-10 17:21:48.9232] main::init (387) Starting Logitech Media Server (v7.9.2, 1578587389, Thu Jan  9 17:49:43 CET 2020) perl 5.028000 - arm-linux-gnueabihf-thread-multi-64int
    [20-01-10 20:50:55.8675] Slim::Utils::Misc::findAndScanDirectoryTree (1035) Error: Couldn't find a topLevelObj!
    [20-01-10 20:51:00.1623] Slim::Utils::Misc::findAndScanDirectoryTree (1035) Error: Couldn't find a topLevelObj!
    [20-01-10 20:51:23.1691] Slim::Utils::Misc::findAndScanDirectoryTree (1035) Error: Couldn't find a topLevelObj!
    [20-01-10 20:53:24.4181] Slim::Utils::Misc::findAndScanDirectoryTree (1035) Error: Couldn't find a topLevelObj!
    [20-01-10 20:55:38.1376] Slim::Utils::Misc::findAndScanDirectoryTree (1035) Error: Couldn't find a topLevelObj!
    [20-01-10 20:56:11.4053] Slim::Utils::Misc::findAndScanDirectoryTree (1035) Error: Couldn't find a topLevelObj! 
    [20-01-10 21:07:05.7352] Slim::Utils::Misc::findAndScanDirectoryTree (1035) Error: Couldn't find a topLevelObj!


    Any thoughts?

    Thanks.

    Name:  empty01.jpg
Views: 252
Size:  10.2 KB
    Server - LMS 8.0.0 Pi4B 4GB/Flirc case/pCP 6.0.0 18K library, playlists & LMS cache on SSD (ntfs)
    Study - Pi3B+/pCP 5.0.0/pi screen/HiFiBerry DAC+/jivelite,
    Lounge - Pi2/pCP 5.0.0 > HiFiBerry DIGI+ > AudioEngine DAC1 > AVI DM5
    Dining Room - Squeezebox Boom
    Garage - Squeezebox Touch > Edifier R980T

    Spares - 1xTouch, 1xSB3, 1xRadio, 7xRPi

  2. #2
    Senior Member kidstypike's Avatar
    Join Date
    Feb 2007
    Location
    Brindle
    Posts
    3,622
    More to above.

    Behavior is the same on all LMS servers I've tried (Pi4, Pi3B+, Win10).

    Discs and folders works for a while then all attached/network drives show empty, even though player(s) are playing music from alleged empty drive.

    Restarting LMS cures the problem for a while.

    Code:
    [20-01-11 11:27:58.0717] Slim::Utils::Misc::findAndScanDirectoryTree (1035) Error: Couldn't find a topLevelObj!
    [20-01-11 11:33:43.3156] Slim::Utils::Misc::findAndScanDirectoryTree (1035) Error: Couldn't find a topLevelObj!
    [20-01-11 12:14:01.5774] Slim::Utils::Misc::findAndScanDirectoryTree (1035) Error: Couldn't find a topLevelObj! 
    [20-01-11 12:14:07.5405] Slim::Utils::Misc::findAndScanDirectoryTree (1035) Error: Couldn't find a topLevelObj!
    
    Server - LMS 8.0.0 Pi4B 4GB/Flirc case/pCP 6.0.0 18K library, playlists & LMS cache on SSD (ntfs)
    Study - Pi3B+/pCP 5.0.0/pi screen/HiFiBerry DAC+/jivelite,
    Lounge - Pi2/pCP 5.0.0 > HiFiBerry DIGI+ > AudioEngine DAC1 > AVI DM5
    Dining Room - Squeezebox Boom
    Garage - Squeezebox Touch > Edifier R980T

    Spares - 1xTouch, 1xSB3, 1xRadio, 7xRPi

  3. #3
    Babelfish's Best Boy mherger's Avatar
    Join Date
    Apr 2005
    Location
    Switzerland
    Posts
    20,422

    Browse Discs and folders problem

    > I also have 60,000+ music files on this drive that I access through
    > Discs and folders. This works okay most of the time. However, for some
    > time (months?), browsing D&F shows "Empty". This occurs even when I'm
    > actually playing an album/tracks that I've started by browsing D&F.


    Once you've played an item from D&F, would that menu be unusable until
    the next restart? Or would it recover once you stopped the playback?

    Would it always break once you start playback, or only every now and then?

    I obviously can't reproduce this...

    --

    Michael

  4. #4
    Senior Member kidstypike's Avatar
    Join Date
    Feb 2007
    Location
    Brindle
    Posts
    3,622
    Quote Originally Posted by mherger View Post
    > I also have 60,000+ music files on this drive that I access through
    > Discs and folders. This works okay most of the time. However, for some
    > time (months?), browsing D&F shows "Empty". This occurs even when I'm
    > actually playing an album/tracks that I've started by browsing D&F.


    Once you've played an item from D&F, would that menu be unusable until
    the next restart? Or would it recover once you stopped the playback?

    Would it always break once you start playback, or only every now and then?

    I obviously can't reproduce this...

    --

    Michael
    Thanks Michael.

    There's no pattern to the problem. I might not use D&F for days or weeks. When I choose to use it, sometimes it's fine, sometimes all drives are apparently empty.

    This morning I fired up a Pi3 and used this in place of my Pi4 as server, played a couple of albums, no problem (LMS had just started you see). At the same time I fired up LMS on my Win10 PC, without connecting any players to it. I could browse D&F no problem (again LMS had just started). Checking the Pi3 LMS and the PC LMS sometime later, all drives were apparently empty.

    Log below is from Win10 LMS, started at 07:45 no problems browsing D&F. Checking again at 11:30 - problems. (no players connected to this server)

    Code:
    
    [20-01-11 07:45:12.6224] main::init (387) Starting Logitech Media Server (v7.9.2, 1578587389, Thu Jan  9 17:38:02 WEST 2020) perl 5.014001 - MSWin32-x86-multi-thread
    [20-01-11 11:30:19.0679] Slim::Utils::Misc::findAndScanDirectoryTree (1035) Error: Couldn't find a topLevelObj!
    [20-01-11 11:30:23.2407] Slim::Utils::Misc::findAndScanDirectoryTree (1035) Error: Couldn't find a topLevelObj!
    [20-01-11 11:30:40.8357] Slim::Utils::Misc::findAndScanDirectoryTree (1035) Error: Couldn't find a topLevelObj!
    [20-01-11 11:31:07.5486] Slim::Utils::Misc::findAndScanDirectoryTree (1035) Error: Couldn't find a topLevelObj!
    
    Server - LMS 8.0.0 Pi4B 4GB/Flirc case/pCP 6.0.0 18K library, playlists & LMS cache on SSD (ntfs)
    Study - Pi3B+/pCP 5.0.0/pi screen/HiFiBerry DAC+/jivelite,
    Lounge - Pi2/pCP 5.0.0 > HiFiBerry DIGI+ > AudioEngine DAC1 > AVI DM5
    Dining Room - Squeezebox Boom
    Garage - Squeezebox Touch > Edifier R980T

    Spares - 1xTouch, 1xSB3, 1xRadio, 7xRPi

  5. #5
    Babelfish's Best Boy mherger's Avatar
    Join Date
    Apr 2005
    Location
    Switzerland
    Posts
    20,422

    Browse Discs and folders problem

    > There's no pattern to the problem. I might not use D&F for days or
    > weeks. When I choose to use it, sometimes it's fine, sometimes all
    > drives are apparently empty.


    Would this happen at the very first menu level? Eg. the drives list on
    Windows, or / on Linux? With any UI? Or only web or mobile app or player?

    --

    Michael

  6. #6
    Senior Member kidstypike's Avatar
    Join Date
    Feb 2007
    Location
    Brindle
    Posts
    3,622
    Quote Originally Posted by mherger View Post
    > There's no pattern to the problem. I might not use D&F for days or
    > weeks. When I choose to use it, sometimes it's fine, sometimes all
    > drives are apparently empty.


    Would this happen at the very first menu level? Eg. the drives list on
    Windows, or / on Linux? With any UI? Or only web or mobile app or player?

    --

    Michael
    All UIs, player, android app, webui default and Material.

    Levels vary, see pics below, both mounted on Pi4 (pCP).

    I can't test Windows yet, I've only just started LMS, and of course it's working fine ATM.

    Name:  levels1.jpg
Views: 81
Size:  10.6 KB

    Name:  levels2.jpg
Views: 82
Size:  9.2 KB
    Server - LMS 8.0.0 Pi4B 4GB/Flirc case/pCP 6.0.0 18K library, playlists & LMS cache on SSD (ntfs)
    Study - Pi3B+/pCP 5.0.0/pi screen/HiFiBerry DAC+/jivelite,
    Lounge - Pi2/pCP 5.0.0 > HiFiBerry DIGI+ > AudioEngine DAC1 > AVI DM5
    Dining Room - Squeezebox Boom
    Garage - Squeezebox Touch > Edifier R980T

    Spares - 1xTouch, 1xSB3, 1xRadio, 7xRPi

  7. #7
    Senior Member kidstypike's Avatar
    Join Date
    Feb 2007
    Location
    Brindle
    Posts
    3,622
    Michael

    As Windows is working ATM, I thought I'd post this, as you can see this is plenty levels down and works fine (until it doesn't)

    Name:  levels3.jpg
Views: 80
Size:  29.7 KB
    Server - LMS 8.0.0 Pi4B 4GB/Flirc case/pCP 6.0.0 18K library, playlists & LMS cache on SSD (ntfs)
    Study - Pi3B+/pCP 5.0.0/pi screen/HiFiBerry DAC+/jivelite,
    Lounge - Pi2/pCP 5.0.0 > HiFiBerry DIGI+ > AudioEngine DAC1 > AVI DM5
    Dining Room - Squeezebox Boom
    Garage - Squeezebox Touch > Edifier R980T

    Spares - 1xTouch, 1xSB3, 1xRadio, 7xRPi

  8. #8
    Senior Member w3wilkes's Avatar
    Join Date
    Jan 2009
    Location
    Utah, USA
    Posts
    1,374
    Can you see the drive from a file manager when you have the D&F failure? When you get the failure in D&F can you still play music on the drive from Genres, Albums, Album Artists, etc?
    Main system - Rock Solid with LMS 7.9.3 Official on WHS 2011 - 2 Duets and Squeeseslave
    Cabin system - Rock solid with LMS 7.9.3 Official on Win10 Pro - 1 RPi 3 Model B/Hifiberry DAC+ Pro/PiCorePlayer and Squeezeslave
    Squeezebox Boom - "At Large" player around both home and cabin
    Headphones and car - Android phone/Bluetooth w/full library on MicroSD card - PowerAmp music player app (similar to Material Skin)

  9. #9
    Senior Member kidstypike's Avatar
    Join Date
    Feb 2007
    Location
    Brindle
    Posts
    3,622
    Quote Originally Posted by w3wilkes View Post
    Can you see the drive from a file manager when you have the D&F failure? When you get the failure in D&F can you still play music on the drive from Genres, Albums, Album Artists, etc?
    Yes I can see the drive from a file manager with D&F failure.

    I don't think you understand the problem This isn't Browse Music Folders (BMF), which is the folder that LMS scans.

    This is Browse Discs and folders, which allows you to browse and play albums/tracks on drives on your network, without adding the albums/tracks to the database.

    So, no I can't play music on the drive from Genres, Albums, Artists etc,. because they are not in the LMS database.

    Name:  BMF BD&F.jpg
Views: 96
Size:  22.3 KB
    Server - LMS 8.0.0 Pi4B 4GB/Flirc case/pCP 6.0.0 18K library, playlists & LMS cache on SSD (ntfs)
    Study - Pi3B+/pCP 5.0.0/pi screen/HiFiBerry DAC+/jivelite,
    Lounge - Pi2/pCP 5.0.0 > HiFiBerry DIGI+ > AudioEngine DAC1 > AVI DM5
    Dining Room - Squeezebox Boom
    Garage - Squeezebox Touch > Edifier R980T

    Spares - 1xTouch, 1xSB3, 1xRadio, 7xRPi

  10. #10
    Senior Member kidstypike's Avatar
    Join Date
    Feb 2007
    Location
    Brindle
    Posts
    3,622
    Windows Discs and folders has now failed, at the first level, apparently the drive is empty. Windows file manager doesn't think so.

    Name:  levels4.jpg
Views: 94
Size:  7.4 KB

    Name:  Files.jpg
Views: 97
Size:  18.8 KB
    Server - LMS 8.0.0 Pi4B 4GB/Flirc case/pCP 6.0.0 18K library, playlists & LMS cache on SSD (ntfs)
    Study - Pi3B+/pCP 5.0.0/pi screen/HiFiBerry DAC+/jivelite,
    Lounge - Pi2/pCP 5.0.0 > HiFiBerry DIGI+ > AudioEngine DAC1 > AVI DM5
    Dining Room - Squeezebox Boom
    Garage - Squeezebox Touch > Edifier R980T

    Spares - 1xTouch, 1xSB3, 1xRadio, 7xRPi

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •