Home of the Squeezebox™ & Transporter® network music players.
Page 2 of 3 FirstFirst 123 LastLast
Results 11 to 20 of 27
  1. #11
    Senior Member
    Join Date
    Feb 2011
    Location
    Cheshire, UK
    Posts
    4,509
    Is the server W10?
    I think this is one of M$s recently added security features. It closes network drive connections until they are required. The various GUI’s are being recognised as a requirement whereas file explorer is.
    VB2.4 storage QNAP TS419p (NFS)
    Living Room - Joggler & SB3 -> Onkyo TS606 -> Celestion F20s
    Office - Pi3+Sreen -> Sony TAFE320 -> Celestion F10s / Pi2+DAC & SB3 -> Onkyo CRN755 -> Wharfedale Modus Cubes
    Dining Room -> SB Boom
    Kitchen -> UE Radio (upgraded to SB Radio)
    Bedroom (Bedside) - Pi2+DAC ->ToppingTP21 ->AKG Headphones
    Bedroom (TV) - SB Touch ->Sherwood AVR ->Mordaunt Short M10s
    Everything controlled by iPeng

  2. #12
    Senior Member kidstypike's Avatar
    Join Date
    Feb 2007
    Location
    Brindle
    Posts
    3,477
    Quote Originally Posted by d6jg View Post
    Is the server W10?
    I think this is one of M$s recently added security features. It closes network drive connections until they are required. The various GUI’s are being recognised as a requirement whereas file explorer is.
    Affects all servers I have, Win10, pCP on Pi4 & Pi3.
    Server - LMS 8.0.0 Pi4B 4GB/Flirc case/pCP 6.0.0-rc1 18K library, playlists & LMS cache on SSD (ntfs)
    Study - Pi3B+/pCP 5.0.0/pi screen/HiFiBerry DAC+/jivelite,
    Lounge - Pi2/pCP 5.0.0 > HiFiBerry DIGI+ > AudioEngine DAC1 > AVI DM5
    Dining Room - Squeezebox Boom
    Garage - Pi3B/Pi screen/HiFiBerry DAC+/pCP 5.0.0 > Edifier R980T

    Spares - 2xTouch, 1xSB3, 1xRadio, 6xRPi

  3. #13
    Babelfish's Best Boy mherger's Avatar
    Join Date
    Apr 2005
    Location
    Switzerland
    Posts
    20,366

    Browse Discs and folders problem

    > Affects all servers I have, Win10, pCP on Pi4 & Pi3.

    Where does the data live? Is it on a remote share, or a local disk?

    --

    Michael

  4. #14
    Senior Member kidstypike's Avatar
    Join Date
    Feb 2007
    Location
    Brindle
    Posts
    3,477
    Quote Originally Posted by mherger View Post
    > Affects all servers I have, Win10, pCP on Pi4 & Pi3.

    Where does the data live? Is it on a remote share, or a local disk?

    --

    Michael
    Both local disc and any remote share.

    I think my original post explains the problem, but to try to make it simple:

    Server is a Pi4 running pCP.
    Latest LMS 7.9.2.
    Music files are on a physically attached USB SSD.
    LMS scans a folder (18000+ music files) on this SSD. I can play these files either through Artists, Albums etc., or "Music Folder" (BMF) without the slightest problem.

    Also on this SSD are some 60,000 files that I don't want LMS to add to the database (mostly ancient low bitrate mp3s).
    I can usually play these files through "Discs and folders", but at some point this no longer works and all user interfaces show the drive as being empty, even though I can still use BMF on the LMS scanned folder.

    Restarting LMS always fixes the problem (until it stops working, usually within hours) as shown in pictures post#6
    Server - LMS 8.0.0 Pi4B 4GB/Flirc case/pCP 6.0.0-rc1 18K library, playlists & LMS cache on SSD (ntfs)
    Study - Pi3B+/pCP 5.0.0/pi screen/HiFiBerry DAC+/jivelite,
    Lounge - Pi2/pCP 5.0.0 > HiFiBerry DIGI+ > AudioEngine DAC1 > AVI DM5
    Dining Room - Squeezebox Boom
    Garage - Pi3B/Pi screen/HiFiBerry DAC+/pCP 5.0.0 > Edifier R980T

    Spares - 2xTouch, 1xSB3, 1xRadio, 6xRPi

  5. #15
    Senior Member
    Join Date
    Feb 2011
    Location
    Cheshire, UK
    Posts
    4,509
    Not a fix but might help you achieve what you want in a different way.

    Use a second Pi (pi2) installed with LMS and scan the 60,000 tracks but only those tracks.

    On pi1 (main) use the Remote Libraries feature to access pi2 tracks when required.
    VB2.4 storage QNAP TS419p (NFS)
    Living Room - Joggler & SB3 -> Onkyo TS606 -> Celestion F20s
    Office - Pi3+Sreen -> Sony TAFE320 -> Celestion F10s / Pi2+DAC & SB3 -> Onkyo CRN755 -> Wharfedale Modus Cubes
    Dining Room -> SB Boom
    Kitchen -> UE Radio (upgraded to SB Radio)
    Bedroom (Bedside) - Pi2+DAC ->ToppingTP21 ->AKG Headphones
    Bedroom (TV) - SB Touch ->Sherwood AVR ->Mordaunt Short M10s
    Everything controlled by iPeng

  6. #16
    Senior Member kidstypike's Avatar
    Join Date
    Feb 2007
    Location
    Brindle
    Posts
    3,477
    Quote Originally Posted by d6jg View Post
    Not a fix but might help you achieve what you want in a different way.

    Use a second Pi (pi2) installed with LMS and scan the 60,000 tracks but only those tracks.

    On pi1 (main) use the Remote Libraries feature to access pi2 tracks when required.
    Well I've thought about doing this many times, but you know how it is with more than one LMS server running, every time you do anything and have to reboot an LMS server machine, or even restart LMS after a plugin or LMS update, half your players have buggered off and connected to a running LMS.

    But I'll give it a go and see how I get on with it. A good percentage of the spare albums are badly tagged though, but I suppose I could BMF them through the Remote Libraries route???

    Just a thought, it's a good thing that the 60,000 tracks are also on my NAS, as I wouldn't know how to mount a USB SSD thats connected to Pi1, onto Pi2
    Server - LMS 8.0.0 Pi4B 4GB/Flirc case/pCP 6.0.0-rc1 18K library, playlists & LMS cache on SSD (ntfs)
    Study - Pi3B+/pCP 5.0.0/pi screen/HiFiBerry DAC+/jivelite,
    Lounge - Pi2/pCP 5.0.0 > HiFiBerry DIGI+ > AudioEngine DAC1 > AVI DM5
    Dining Room - Squeezebox Boom
    Garage - Pi3B/Pi screen/HiFiBerry DAC+/pCP 5.0.0 > Edifier R980T

    Spares - 2xTouch, 1xSB3, 1xRadio, 6xRPi

  7. #17
    Senior Member
    Join Date
    Feb 2011
    Location
    Cheshire, UK
    Posts
    4,509
    Quote Originally Posted by kidstypike View Post
    Well I've thought about doing this many times, but you know how it is with more than one LMS server running, every time you do anything and have to reboot an LMS server machine, or even restart LMS after a plugin or LMS update, half your players have buggered off and connected to a running LMS.

    But I'll give it a go and see how I get on with it. A good percentage of the spare albums are badly tagged though, but I suppose I could BMF them through the Remote Libraries route???

    Just a thought, it's a good thing that the 60,000 tracks are also on my NAS, as I wouldn't know how to mount a USB SSD thats connected to Pi1, onto Pi2
    Is there a Dlna server on the NaS because if I remember correctly you can access that via remote libraries if you switch on dlna discovery somewhere. If so no second LMS at all to bugger up your players. Can’t remember how you switch it on though
    VB2.4 storage QNAP TS419p (NFS)
    Living Room - Joggler & SB3 -> Onkyo TS606 -> Celestion F20s
    Office - Pi3+Sreen -> Sony TAFE320 -> Celestion F10s / Pi2+DAC & SB3 -> Onkyo CRN755 -> Wharfedale Modus Cubes
    Dining Room -> SB Boom
    Kitchen -> UE Radio (upgraded to SB Radio)
    Bedroom (Bedside) - Pi2+DAC ->ToppingTP21 ->AKG Headphones
    Bedroom (TV) - SB Touch ->Sherwood AVR ->Mordaunt Short M10s
    Everything controlled by iPeng

  8. #18
    Senior Member kidstypike's Avatar
    Join Date
    Feb 2007
    Location
    Brindle
    Posts
    3,477
    Quote Originally Posted by d6jg View Post
    Is there a Dlna server on the NaS because if I remember correctly you can access that via remote libraries if you switch on dlna discovery somewhere. If so no second LMS at all to bugger up your players. Can’t remember how you switch it on though
    It's a WD MyCloud, probably not what you'd call a true NAS, I just use it for storage really.

    And as I'm just setting up Pi2, I'll continue with that, see how it pans out.
    Server - LMS 8.0.0 Pi4B 4GB/Flirc case/pCP 6.0.0-rc1 18K library, playlists & LMS cache on SSD (ntfs)
    Study - Pi3B+/pCP 5.0.0/pi screen/HiFiBerry DAC+/jivelite,
    Lounge - Pi2/pCP 5.0.0 > HiFiBerry DIGI+ > AudioEngine DAC1 > AVI DM5
    Dining Room - Squeezebox Boom
    Garage - Pi3B/Pi screen/HiFiBerry DAC+/pCP 5.0.0 > Edifier R980T

    Spares - 2xTouch, 1xSB3, 1xRadio, 6xRPi

  9. #19
    Senior Member
    Join Date
    Feb 2011
    Location
    Cheshire, UK
    Posts
    4,509
    Quote Originally Posted by kidstypike View Post
    It's a WD MyCloud, probably not what you'd call a true NAS, I just use it for storage really.

    And as I'm just setting up Pi2, I'll continue with that, see how it pans out.
    Any player that is piCorePlayer based has a preferred server option. Might help a bit
    VB2.4 storage QNAP TS419p (NFS)
    Living Room - Joggler & SB3 -> Onkyo TS606 -> Celestion F20s
    Office - Pi3+Sreen -> Sony TAFE320 -> Celestion F10s / Pi2+DAC & SB3 -> Onkyo CRN755 -> Wharfedale Modus Cubes
    Dining Room -> SB Boom
    Kitchen -> UE Radio (upgraded to SB Radio)
    Bedroom (Bedside) - Pi2+DAC ->ToppingTP21 ->AKG Headphones
    Bedroom (TV) - SB Touch ->Sherwood AVR ->Mordaunt Short M10s
    Everything controlled by iPeng

  10. #20
    Babelfish's Best Boy mherger's Avatar
    Join Date
    Apr 2005
    Location
    Switzerland
    Posts
    20,366

    Browse Discs and folders problem

    As you're able to reproduce this issue on all your systems, could you
    please edit Slim/Utils/Misc.pm, the line given in the error log. Replace
    logError() with logBacktrace(), and add the following two lines after it:

    warn Data:ump::dump($params);
    warn Data:ump::dump($topLevelObj);

    This should give us more information about the failure.

    --

    Michael

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •