Home of the Squeezebox™ & Transporter® network music players.
Page 1 of 3 123 LastLast
Results 1 to 10 of 22
  1. #1

    Spotify only plays first six minutes of a track then skips to next track in album

    As thread title. Ever since I've been using Spotty on my SBT, if an album track is longer than about six minutes, it only plays the first six minutes or so, then skips to the next track.

    It doesn't happen every time, but it only ever skips on longer tracks, never anything under 6 minutes. I didn't use Spotify much before, but now with LMS 8, and the excellent Spotify integration, I'd like to use it a lot more if it wasn't for this issue.

    Any ideas?

    Thanks
    S

  2. #2
    Senior Member
    Join Date
    Jan 2011
    Location
    Staffordshire. UK
    Posts
    3,964
    Hey Sergie, baby, how yer doin?

    This won't do any harm, and are you bang upto date withe the LMS version ?

    v8.0.1 lives here


    https://forums.slimdevices.com/showt...l=1#post997696

    stay safe

    ronnie

  3. #3

    Hi.

    Thanks Ronnie,

    Yes, keeping well, trying to find enough to do.

    I'll install the update, and I've also now got a Spotify ID, so I'll try both.

    Hope you're equally well,

    S.

  4. #4
    Senior Member
    Join Date
    Jan 2011
    Location
    Staffordshire. UK
    Posts
    3,964
    Serge, one might have to wait for an hour or so, for any cache to expire, after doing the ID thing.

    Read through the linked thread to the end.

    If that doesn't work then come back for Mr Herger's expertise

    There is also a Spotty specific thread

    I'm still breathing, so I guess that's a good thing

    ronnie

  5. #5

    Still skipping

    I've installed LMS 8.1 and added my new Spotify ID but it's still skipping on long tracks. LMS is on a W10 laptop, and I'm controlling it through Soundicity on a W10 tablet.

    Works fine on music files stored on the laptop, for streaming from BBC, other internet radio stations and Radio Paradise. It only misbehaves on Spotify and on long tracks, and not every time, but perhaps 80% of the time.

    Really annoying!

    S

  6. #6
    Senior Member
    Join Date
    Jan 2011
    Location
    Staffordshire. UK
    Posts
    3,964
    Quote Originally Posted by Sergeauckland View Post
    I've installed LMS 8.1 and added my new Spotify ID but it's still skipping on long tracks. LMS is on a W10 laptop, and I'm controlling it through Soundicity on a W10 tablet.

    Works fine on music files stored on the laptop, for streaming from BBC, other internet radio stations and Radio Paradise. It only misbehaves on Spotify and on long tracks, and not every time, but perhaps 80% of the time.

    Really annoying!

    S
    I have no idea on this Serge.

    Perhaps you can check the server log when it happens; that's Settings > Information > scroll to the bottom of the page.

    And a couple of sample tracks would help others try to replicate the problem.

    ronnie

  7. #7
    Babelfish's Best Boy mherger's Avatar
    Join Date
    Apr 2005
    Location
    Switzerland
    Posts
    20,505

    Spotify only plays first six minutes ofa track then skips to next track in album

    > I've installed LMS 8.1 and added my new Spotify ID but it's still
    > skipping on long tracks. LMS is on a W10 laptop, and I'm controlling it
    > through Soundicity on a W10 tablet.


    Are you using any kind of modification on the Touch?

    --

    Michael

  8. #8
    Quote Originally Posted by mherger View Post
    > I've installed LMS 8.1 and added my new Spotify ID but it's still
    > skipping on long tracks. LMS is on a W10 laptop, and I'm controlling it
    > through Soundicity on a W10 tablet.


    Are you using any kind of modification on the Touch?

    --

    Michael
    Hi Michael,
    Thanks for replying. No, the SBT is completely standard. I also tried using Spotify's app on my tablet, and using Connect to the SBT. It still skipped to the next track on the album on long tracks. However, Soundicity was still running whilst Connect was streaming. I'll later try Connect without Soundicity.

    Just did some more testing, using Squeeze Control rather than Soundicity, and it did the same on Spotify, skipped to the next track after about 6 minutes. I also tried using the Spotify app on its own, using Connect to the SBT, with the same result.

    Don't know what to do next, as it's consistently (mostly!) dropping long tracks, so not usable for classical and some Jazz, which is what I listen to most!


    S
    Last edited by Sergeauckland; 2020-12-09 at 12:34.

  9. #9

    Continuing Spotty problems

    Still trying to understand what's happening with this.

    I've downloaded and enabled Reliable, just in case that had any bearing, and it's still skipping after 6 minutes or so.

    I've tried using Spotify's app on my tablets, and it's fine, no skipping. I've tried using Squeezeplayer on my tablet and sending to the SBT, it skips.

    The only consistent thing is that whenever Spotify plays through the SBT, it only plays the first 6 minutes or so of a long track.

    I'm not sufficiently knowledgeable on the logs to know what they're telling me. I can't see a time-stamp so don't know when an event happened, so don't know whether a log entry is relevant, but I accept that could be me, just not understanding the log entries.

    If anyone can advise exactly where the Spotty logs are kept, I'll have a look and post the relevant parts.

    Thanks.

    S.

  10. #10
    Babelfish's Best Boy mherger's Avatar
    Join Date
    Apr 2005
    Location
    Switzerland
    Posts
    20,505

    Spotify only plays first six minutes ofa track then skips to next track in album

    > I've downloaded and enabled Reliable, just in case that had any bearing,
    > and it's still skipping after 6 minutes or so.


    Spotty doesn't use http. Reliable won't help here.

    > I'm not sufficiently knowledgeable on the logs to know what they're
    > telling me. I can't see a time-stamp so don't know when an event


    Feel free to upload, and I'll take a look. You'll find server.log.zip
    linked in Settings/Information:

    https://www.dropbox.com/request/T3RctyzGgNg0oFDubq6a


    --

    Michael

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •