Home of the Squeezebox™ & Transporter® network music players.
Page 74 of 74 FirstFirst ... 2464727374
Results 731 to 740 of 740
  1. #731
    Babelfish's Best Boy mherger's Avatar
    Join Date
    Apr 2005
    Location
    Switzerland
    Posts
    20,525

    Online music service integration - how to test

    > That did the trick. Thanks. I am still getting this error though when
    > scanning spotify albums:


    That's a spotty issue and should best be discussed in a relevant thread
    (start a new one if in doubt).

    --

    Michael

  2. #732
    Senior Member
    Join Date
    Jan 2010
    Location
    Hertfordshire
    Posts
    6,206
    Quote Originally Posted by slartibartfast View Post
    Something odd happening with latest LMS 8.0.0. I happened to notice an automatic scan removing all my integrated Spotify tracks from the library. I performed an online music scan manually and they reappeared. A short while later another automatic scan removed them again.

    Sent from my Pixel 3a using Tapatalk
    Did this get missed somehow? This is still happening. I have attached the last scan info.
    Attached Images Attached Images  

  3. #733
    Senior Member
    Join Date
    Jan 2010
    Location
    Hertfordshire
    Posts
    6,206
    Quote Originally Posted by slartibartfast View Post
    Did this get missed somehow? This is still happening. I have attached the last scan info.
    An hour later an automatic scan has restored the Spotify tracks to my library. I wonder if this is an issue at Spotify's end and the workaround is to turn of automatic scanning of online tracks.

    Sent from my Pixel 3a using Tapatalk

  4. #734
    Lately, I've been using more than one online service, and they integrate fine with my library using this plugin, but there is a very minor issue. If the services don't agree with capitalization or where to use lower or upper case, the bands get duplicated in the library.

    Example:
    - One service has the Kiss band as "KISS", all upper case.
    - Another service has the band name as "Kiss", only the fist letter as capital.

    Then, in the library I have both "KISS" and "Kiss". So, it would be great to tell the plugin to just ignore case distinction and merge them together.

  5. #735
    Senior Member
    Join Date
    Apr 2005
    Location
    UK/London
    Posts
    3,617
    Same is true with a local only library - it is a feature of how LMS works.
    Historically the answer has been "fix your tags" ... which is not feasible with an on-line service.
    Paul Webster
    http://dabdig.blogspot.com
    Author of "Now Playing" plugins covering Radio France (FIP etc), KCRW, Supla Finland, ABC Australia, CBC/Radio-Canada and RTE Ireland

  6. #736
    Junior Member
    Join Date
    Jun 2014
    Posts
    17
    Onlinde Media Sources is reporting:

    Slim::Plugin::OnlineLibrary::Plugin::__ANON__ (176) Disabling polling for Slim::Plugin::WiMP::Plugin lack of account information
    The last time this happened, other users pointed out the material skin isn't compatible with online media sources. I'm getting this error again and have removed practically every plugin. Then it dawned on me, just for funsies I decided to run the LMS 8.2 dev branch of the lmscommunity docker.

    Does online media sources function in LMS 8.2?

    Are there other known plugins that break online media sources besides the material skin?

  7. #737
    Senior Member
    Join Date
    Mar 2017
    Posts
    2,610
    Quote Originally Posted by MongarEric View Post
    other users pointed out the material skin isn't compatible with online media sources. ...
    Are there other known plugins that break online media sources besides the material skin?
    Um, Material (AFAIK) works just fine with online services. I don't personally use any of these, but am unaware of any problems.
    Material debug: 1. Launch via http: //SERVER:9000/material/?debug=json (Use http: //SERVER:9000/material/?debug=json,cometd to also see update messages, e.g. play queue) 2. Open browser's developer tools 3. Open console tab in developer tools 4. REQ/RESP messages sent to/from LMS will be logged here.

  8. #738
    Senior Member
    Join Date
    Jan 2010
    Location
    Hertfordshire
    Posts
    6,206
    Quote Originally Posted by MongarEric View Post
    Onlinde Media Sources is reporting:



    The last time this happened, other users pointed out the material skin isn't compatible with online media sources. I'm getting this error again and have removed practically every plugin. Then it dawned on me, just for funsies I decided to run the LMS 8.2 dev branch of the lmscommunity docker.

    Does online media sources function in LMS 8.2?

    Are there other known plugins that break online media sources besides the material skin?
    So if you change the setting for Tidal integration in the default skin and then look in the Material Skin is the setting still the same? Maybe you didn't save settings in Material Skin.

    Sent from my Pixel 3a using Tapatalk

  9. #739
    Junior Member
    Join Date
    Jun 2014
    Posts
    17
    Quote Originally Posted by slartibartfast View Post
    So if you change the setting for Tidal integration in the default skin and then look in the Material Skin is the setting still the same? Maybe you didn't save settings in Material Skin.

    Sent from my Pixel 3a using Tapatalk

    I deleted the material skin plugin and still got the same error. I slowly went through and deleted plugins I really wasn't using, just in case there was a conflict. When I change the setting to "integrate library..." and run a scan, it does not appear to even attempt to pull music from Tidal. At some point I'll go back into advanced settings page for online music library integration, and the setting will have changed itself back to "do not integrate..". I'm sure I've occasionally forgotten to hit apply, but I'm sure I haven't forgotten it every time.

    I can play music from Tidal just fine, library integration just not working.
    .

  10. #740
    Junior Member
    Join Date
    Jun 2014
    Posts
    17
    Not sure what happened, but online music integration is functioning now. Whatever someone did, fixed it. Thanks!

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •