Home of the Squeezebox™ & Transporter® network music players.
Page 22 of 52 FirstFirst ... 12202122232432 ... LastLast
Results 211 to 220 of 519
  1. #211
    Senior Member
    Join Date
    Jan 2010
    Location
    Hertfordshire
    Posts
    3,692
    Quote Originally Posted by mherger View Post
    > This is the server log from the time of the never ending scan. Anything
    > useful?


    "database is locked". Something had a lock on the file, and did not free
    it. You didn't use any external tool to access the file while the scan
    was running, did you?

    --

    Michael
    Don't think so. What kind of tool would do that? I used WinSCP this morning to delete library.db but I didn't do anything else before that. I first noticed something was wrong when new Spotify favourites were not added to my library clearly because the previous scan was still running. As far as I know the database wasn't even being accessed by the server as the HDD was sleeping.

    Sent from my Pixel 3a using Tapatalk

  2. #212
    Senior Member
    Join Date
    Feb 2011
    Location
    Cheshire, UK
    Posts
    4,509
    Apart from some “efficiency” issues with the scanning this seems pretty much done as far as Spotify & Qobuz go.

    I have decided to switch off auto polling and will rely upon an overnight rescan (the overnight scan didn’t find a new Qobuz album last night but I have added more today to check that again).

    Any progress on the “source indicator”?
    VB2.4 storage QNAP TS419p (NFS)
    Living Room - Joggler & SB3 -> Onkyo TS606 -> Celestion F20s
    Office - Pi3+Sreen -> Sony TAFE320 -> Celestion F10s / Pi2+DAC & SB3 -> Onkyo CRN755 -> Wharfedale Modus Cubes
    Dining Room -> SB Boom
    Kitchen -> UE Radio (upgraded to SB Radio)
    Bedroom (Bedside) - Pi2+DAC ->ToppingTP21 ->AKG Headphones
    Bedroom (TV) - SB Touch ->Sherwood AVR ->Mordaunt Short M10s
    Everything controlled by iPeng

  3. #213
    Senior Member
    Join Date
    Jan 2010
    Location
    Hertfordshire
    Posts
    3,692
    Quote Originally Posted by d6jg View Post
    Apart from some “efficiency” issues with the scanning this seems pretty much done as far as Spotify & Qobuz go.

    I have decided to switch off auto polling and will rely upon an overnight rescan (the overnight scan didn’t find a new Qobuz album last night but I have added more today to check that again).

    Any progress on the “source indicator”?
    Before you turned off auto polling did it work correctly? I had a case of a never ending scan.

    Sent from my Pixel 3a using Tapatalk

  4. #214
    Senior Member
    Join Date
    Feb 2011
    Location
    Cheshire, UK
    Posts
    4,509
    Quote Originally Posted by slartibartfast View Post
    Before you turned off auto polling did it work correctly? I had a case of a never ending scan.

    Sent from my Pixel 3a using Tapatalk
    Yes it worked fine but the scanning took some time to complete.
    VB2.4 storage QNAP TS419p (NFS)
    Living Room - Joggler & SB3 -> Onkyo TS606 -> Celestion F20s
    Office - Pi3+Sreen -> Sony TAFE320 -> Celestion F10s / Pi2+DAC & SB3 -> Onkyo CRN755 -> Wharfedale Modus Cubes
    Dining Room -> SB Boom
    Kitchen -> UE Radio (upgraded to SB Radio)
    Bedroom (Bedside) - Pi2+DAC ->ToppingTP21 ->AKG Headphones
    Bedroom (TV) - SB Touch ->Sherwood AVR ->Mordaunt Short M10s
    Everything controlled by iPeng

  5. #215
    Babelfish's Best Boy mherger's Avatar
    Join Date
    Apr 2005
    Location
    Switzerland
    Posts
    20,367

    Online music service integration - how to test

    > Apart from some “efficiency” issues with the scanning this seems pretty
    > much done as far as Spotify & Qobuz go.


    There's still a lot of room for improvements... eg. the link to the
    services could be improved, artists integrated somehow etc.

    > Any progress on the “source indicator”?


    No. There won't be a generic solution, as UIs are very different.
    Therefore this is way down the list.

    --

    Michael

  6. #216
    Senior Member
    Join Date
    May 2006
    Location
    Silicon Valley
    Posts
    546

    Qobuz Plugin v1.901

    I must be missing something obvious, but I am stuck. I cloned Qobuz from Github; LMS v8.0 will load the Qobuz plugin from the master branch v1.531, but when I switch to the library-integration branch, v1.901 - LMS fails to load it, with the log message:

    [20-01-22 13:10:52.0440] Slim::Utils::PluginManager::load (322) Error: Couldn't load Plugins::Qobuz::Plugin


    [20-01-22 13:10:52.0437] Slim::bootstrap::tryModuleLoad (285) Warning: Module [Plugins::Qobuz::Plugin] failed to load:
    Can't locate Plugins/Qobuz/API/Common.pm in @INC (you may need to install the Plugins::Qobuz::API::Common module) (@INC contains: /home/user/build/slimserver-master/Plugins/MusicArtistInfo/lib /home/user/build/slimserver-master/Cache/InstalledPlugins/Plugins/MusicArtistInfo/lib /home/user/build/slimserver-master/Cache/InstalledPlugins /home/user/build/slimserver-master/CPAN/arch/5.26/x86_64-linux-thread-multi /home/user/build/slimserver-master/CPAN/arch/5.26/x86_64-linux-thread-multi/auto /home/user/build/slimserver-master/CPAN/arch/5.26.1/x86_64-linux-gnu-thread-multi /home/user/build/slimserver-master/CPAN/arch/5.26.1/x86_64-linux-gnu-thread-multi/auto /home/user/build/slimserver-master/CPAN/arch/5.26/x86_64-linux-gnu-thread-multi /home/user/build/slimserver-master/CPAN/arch/5.26/x86_64-linux-gnu-thread-multi/auto /home/user/build/slimserver-master/CPAN/arch/x86_64-linux-gnu-thread-multi /home/user/build/slimserver-master/CPAN/arch/5.26 /home/user/build/slimserver-master/lib /home/user/build/slimserver-master/CPAN /home/user/build/slimserver-master /etc/perl /usr/local/lib/x86_64-linux-gnu/perl/5.26.1 /usr/local/share/perl/5.26.1 /usr/lib/x86_64-linux-gnu/perl5/5.26 /usr/share/perl5 /usr/lib/x86_64-linux-gnu/perl/5.26 /usr/share/perl/5.26 /usr/local/lib/site_perl /usr/lib/x86_64-linux-gnu/perl-base) at /home/user/build/slimserver-master/Cache/InstalledPlugins/Plugins/Qobuz/API.pm line 17.
    BEGIN failed--compilation aborted at /home/user/build/slimserver-master/Cache/InstalledPlugins/Plugins/Qobuz/API.pm line 17.
    Compilation failed in require at /home/user/build/slimserver-master/Cache/InstalledPlugins/Plugins/Qobuz/Plugin.pm line 15.
    BEGIN failed--compilation aborted at /home/user/build/slimserver-master/Cache/InstalledPlugins/Plugins/Qobuz/Plugin.pm line 15.
    Compilation failed in require at (eval 927) line 1.
    BEGIN failed--compilation aborted at (eval 927) line 1.

    So, I went back to using v1.531.
    Living Room: SB Touch + DIY PSU > CI Audio VDA.2 DAC + VAC.1 PSU > VRX.1 cables > Emotiva XSP-1 Gen 2 preamp + XPA-DR2 amp > Blue Jeans cables > B&W 804 speakers
    Laptop: System76 Galago + Ubuntu 16.04 + Squeezelite/gmrender + Material Skin > Emotiva Little Ego DAC > Senn HD 650 headphones
    Phone: Pixel 3a Phone + BubbleUPnP + Kiwi/Material > Bluetooth > Bose SoundLink Revolve
    Server: Puget Systems Serenity + Ubuntu 18.04 + LMS 8.0
    Music: Personal FLAC, Radio Paradise FLAC, Qobuz, Spotify

  7. #217
    Babelfish's Best Boy mherger's Avatar
    Join Date
    Apr 2005
    Location
    Switzerland
    Posts
    20,367

    Online music service integration - how to test

    > [20-01-22 13:10:52.0437] Slim::bootstrap::tryModuleLoad (285) Warning:
    > Module [Plugins::Qobuz::Plugin] failed to load:
    > Can't locate Plugins/Qobuz/API/Common.pm in @INC (you may need to


    Did you check whether that file indeed did not exist?

    > So, I went back to using v1.531.


    Could you try installing the plugin from my testing repository?

    --

    Michael

  8. #218
    Babelfish's Best Boy mherger's Avatar
    Join Date
    Apr 2005
    Location
    Switzerland
    Posts
    20,367

    Online music service integration - how to test

    > I have decided to switch off auto polling and will rely upon an
    > overnight rescan (the overnight scan didn’t find a new Qobuz album last
    > night but I have added more today to check that again).


    About your hanging scan: are you using Spotty with multiple users?

    --

    Michael

  9. #219
    Senior Member
    Join Date
    Feb 2011
    Location
    Cheshire, UK
    Posts
    4,509
    Quote Originally Posted by mherger View Post
    > I have decided to switch off auto polling and will rely upon an
    > overnight rescan (the overnight scan didn’t find a new Qobuz album last
    > night but I have added more today to check that again).


    About your hanging scan: are you using Spotty with multiple users?

    --

    Michael
    My scan wasn’t hanging - that was slartibartfast - my overnight scan seemed to miss a Qobuz album on Tues night but last night it picked up new albums correctly.
    FLAC playback is working after applying your one line fix.

    A thought about the album art pre cache. Why not keep all existing album art rather than removing and recreating just scan new items. The fact that you may end up with art in the cache that’s no longer required must be more efficient than recreating everything every time?
    VB2.4 storage QNAP TS419p (NFS)
    Living Room - Joggler & SB3 -> Onkyo TS606 -> Celestion F20s
    Office - Pi3+Sreen -> Sony TAFE320 -> Celestion F10s / Pi2+DAC & SB3 -> Onkyo CRN755 -> Wharfedale Modus Cubes
    Dining Room -> SB Boom
    Kitchen -> UE Radio (upgraded to SB Radio)
    Bedroom (Bedside) - Pi2+DAC ->ToppingTP21 ->AKG Headphones
    Bedroom (TV) - SB Touch ->Sherwood AVR ->Mordaunt Short M10s
    Everything controlled by iPeng

  10. #220
    Senior Member
    Join Date
    May 2006
    Location
    Silicon Valley
    Posts
    546
    Quote Originally Posted by mherger View Post
    > [20-01-22 13:10:52.0437] Slim::bootstrap::tryModuleLoad (285) Warning:
    > Module [Plugins::Qobuz::Plugin] failed to load:
    > Can't locate Plugins/Qobuz/API/Common.pm in @INC (you may need to


    Did you check whether that file indeed did not exist?

    > So, I went back to using v1.531.


    Could you try installing the plugin from my testing repository?

    --

    Michael
    Thank you. Yes - I made an inane mistake. I had not copied the API folder into the Qobuz plugin folder, in my LMS v8.0 working tree ... I goofed. Pretty obvious, once I understood it. I have the Qobuz plugin v1.901 working now. My online albums are appearing nicely in New Music.
    Living Room: SB Touch + DIY PSU > CI Audio VDA.2 DAC + VAC.1 PSU > VRX.1 cables > Emotiva XSP-1 Gen 2 preamp + XPA-DR2 amp > Blue Jeans cables > B&W 804 speakers
    Laptop: System76 Galago + Ubuntu 16.04 + Squeezelite/gmrender + Material Skin > Emotiva Little Ego DAC > Senn HD 650 headphones
    Phone: Pixel 3a Phone + BubbleUPnP + Kiwi/Material > Bluetooth > Bose SoundLink Revolve
    Server: Puget Systems Serenity + Ubuntu 18.04 + LMS 8.0
    Music: Personal FLAC, Radio Paradise FLAC, Qobuz, Spotify

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •