Home of the Squeezebox™ & Transporter® network music players.
Page 1 of 2 12 LastLast
Results 1 to 10 of 17
  1. #1
    Junior Member
    Join Date
    Jun 2007
    Location
    United Kingdom
    Posts
    25

    Tidal stutter using LMS

    I'm getting stuttering on some, but not all, music streamed from TIDAL. I think the problem is LMS.

    I'm using LMS 7.9.2 on a Windows 10 PC, streaming to three SB Classics. My internet connection is stable and is adequate for music and video streaming (36 mbps).

    I'm trying to stream TIDAL hi-fi content i.e CD quality in FLAC. I encounter no stuttering at all when streaming from Quobuz (CD quality also).

    To try and identify the problem, I've listened to the same music from TIDAL on my PC - there is no stuttering. I've also streamed TIDAL from my Samsung tablet (via bluetooth) to an ARCAM IR DAC connected to my main hi-fi system. Again there is no stuttering (although the music sounds somewhat tinny compared to streaming through LMS with its wi-fi connection).

    Is there an adjustment I can make to LMS to get over this stuttering? Many thanks.

  2. #2
    Senior Member
    Join Date
    Jan 2008
    Posts
    292
    Stutter as in buffering?

    Sent from my SM-G975W using Tapatalk

  3. #3
    Junior Member
    Join Date
    Jun 2007
    Location
    United Kingdom
    Posts
    25
    Quote Originally Posted by doctor_big View Post
    Stutter as in buffering?

    Sent from my SM-G975W using Tapatalk
    Not buffering. The music jitters and judders as if it's having difficulty with peaks of volume or frequency. My impression is that TIDAL is trying to send lots of data some of which is being choked off.

  4. #4
    Senior Member
    Join Date
    Jan 2009
    Location
    Sor°, Denmark
    Posts
    696
    Quote Originally Posted by jazzguy View Post
    I'm getting stuttering on some, but not all, music streamed from TIDAL. I think the problem is LMS.

    I'm using LMS 7.9.2 on a Windows 10 PC, streaming to three SB Classics. My internet connection is stable and is adequate for music and video streaming (36 mbps).

    I'm trying to stream TIDAL hi-fi content i.e CD quality in FLAC. I encounter no stuttering at all when streaming from Quobuz (CD quality also).

    To try and identify the problem, I've listened to the same music from TIDAL on my PC - there is no stuttering. I've also streamed TIDAL from my Samsung tablet (via bluetooth) to an ARCAM IR DAC connected to my main hi-fi system. Again there is no stuttering (although the music sounds somewhat tinny compared to streaming through LMS with its wi-fi connection).

    Is there an adjustment I can make to LMS to get over this stuttering? Many thanks.
    I had that issue too. I am using Tidal with LMS. It seems like some tracks after about March 2019 is getting compressed at too high level. Many squeezebox devices don't like that, and make stuttering sound. I fixed this using SOX to transcode.
    Make a custom-convert.conf file containing this:

    flc flc * *
    [sox] -q -t flac $FILE$ -t flac -

    That solved the problem for me.
    Last edited by callesoroe; 2020-01-03 at 07:38.
    Callesoroe
    Living room: Transporter, Tact RCS 2.2X digital preamp, Martin Logan Vista speakers, AMPS(Icepower): Acoustic Reality Ear Enigma PLUS(PANELS), Acoustic Reality Ear TWO MKII(Bas)
    Kitchen: Transporter - Prodipe Pro 5 active bi-amp speakers. Bedroom: Receiver+UE boombox, Kids: Receiver+Active speakers, Guestroom: Touch - Bencmark DAC1, JBL LSR305 active speakers , TIDAL HIFI flac streaming.
    http://www.last.fm/user/callesoroe

  5. #5
    Senior Member
    Join Date
    Jan 2009
    Location
    Sor°, Denmark
    Posts
    696
    Quote Originally Posted by callesoroe View Post
    I had that issue too. I am using Tidal with LMS. It seems like some tracks after about March 2019 is getting compressed at to high level. Many squeezebox devices don't like that, and make stuttering sound. I fixed this using SOX to transcode.
    Make a custom-convert.conf file containing this:

    flc flc * *
    [sox] -q -t flac $FILE$ -t flac -

    That solved the problem for me.
    OR

    you can edit the convert.conf file :

    Name:  2019-12-30 13_12_32-C__Program Files (x86)_Squeezebox_server_convert.conf - Notepad++.jpg
Views: 190
Size:  11.8 KB
    Callesoroe
    Living room: Transporter, Tact RCS 2.2X digital preamp, Martin Logan Vista speakers, AMPS(Icepower): Acoustic Reality Ear Enigma PLUS(PANELS), Acoustic Reality Ear TWO MKII(Bas)
    Kitchen: Transporter - Prodipe Pro 5 active bi-amp speakers. Bedroom: Receiver+UE boombox, Kids: Receiver+Active speakers, Guestroom: Touch - Bencmark DAC1, JBL LSR305 active speakers , TIDAL HIFI flac streaming.
    http://www.last.fm/user/callesoroe

  6. #6
    Senior Member
    Join Date
    Oct 2005
    Location
    Ireland
    Posts
    18,075
    Quote Originally Posted by callesoroe View Post
    OR

    you can edit the convert.conf file :
    If you edit convert.conf file then any changes in the file will be lost after LMS update whereas custom-convert.conf will be kept after an LMS update.

  7. #7
    Junior Member
    Join Date
    Jun 2007
    Location
    United Kingdom
    Posts
    25
    Quote Originally Posted by bpa View Post
    If you edit convert.conf file then any changes in the file will be lost after LMS update whereas custom-convert.conf will be kept after an LMS update.
    Many thanks to both of you. I've created a custom-convert.conf file containing the text suggested by callesoroe. That has solved the problem.

  8. #8
    Senior Member
    Join Date
    Dec 2005
    Location
    Brussels, Belgium
    Posts
    305
    Hi guys,

    It seems I have the same issue with Qobuz on some of my Players - Radio and Boom, with suttering and rebuffering (see https://forums.slimdevices.com/showt...l=1#post961183).
    I would like to try the custom-config solution but how do I proceed? Where is this config file located?

    Thx for the help ;-)
    Transporter, Cambridge Audio 651R + Q Acoustics Concept 40 --- Touch + Onkyo TX-SR309 + Morel Applause MKII --- SB2, SB3, Duet, 2 Booms, 7 Radios --- Ipeng & Material --- LMS 7.9.3 - 1579448956 on Pi4 4GB - Max2Play --- Qobuz

  9. #9
    Senior Member
    Join Date
    Jan 2009
    Location
    Sor°, Denmark
    Posts
    696
    Quote Originally Posted by didjean View Post
    Hi guys,

    It seems I have the same issue with Qobuz on some of my Players - Radio and Boom, with suttering and rebuffering (see https://forums.slimdevices.com/showt...l=1#post961183).
    I would like to try the custom-config solution but how do I proceed? Where is this config file located?

    Thx for the help ;-)
    Hi

    First you can try to see if changing sound settings to "Stream through Proxy" does the trick. If not you can create the custom-convert file as described. It shall be placed here.... :

    Name:  custom-convert.png
Views: 86
Size:  9.2 KB
    Callesoroe
    Living room: Transporter, Tact RCS 2.2X digital preamp, Martin Logan Vista speakers, AMPS(Icepower): Acoustic Reality Ear Enigma PLUS(PANELS), Acoustic Reality Ear TWO MKII(Bas)
    Kitchen: Transporter - Prodipe Pro 5 active bi-amp speakers. Bedroom: Receiver+UE boombox, Kids: Receiver+Active speakers, Guestroom: Touch - Bencmark DAC1, JBL LSR305 active speakers , TIDAL HIFI flac streaming.
    http://www.last.fm/user/callesoroe

  10. #10
    Junior Member
    Join Date
    Oct 2013
    Posts
    4
    I'm also having this issue with stuttering and jittering sound from Tidal, but going through mysqueezebox.com (using FLAC). It appears only with newer albums or tracks, and I first noticed the problem sometime beginning of 2019. Strangely enough it does not happen with all tracks from newer albums - sometimes it is hardly noticable and sometimes tracks will just stutter really badly. It's happening a lot more frequently with new albums. Will I need to give up my squeeebox? Can we expect Tidal to survive in squeezebox, or is it simply passing due date slowly with Tidals updates to their encoding...??

    Is anyone looking into this? Anyone knows what is going on?

    --

    Daniel

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •