Home of the Squeezebox™ & Transporter® network music players.
Page 4 of 6 FirstFirst ... 23456 LastLast
Results 31 to 40 of 53
  1. #31
    Senior Member
    Join Date
    Oct 2009
    Location
    Western/Northern New York
    Posts
    1,033
    Quote Originally Posted by mherger View Post
    > Could someone walk me through inserting a custom conf file in the
    > appropriate place to solve this for me.


    The latest LMS8 should have the necessary changes which would allow you
    to transcode to PCM.


    --

    Michael
    I read a variety of posts in two threads on this and hope someone can summarize a solution.

    I am new to Tidal, trying a tidal hi-fi+ trial. I am running 8.2.0 - 1627922070

    I have been running a few tidal "mixes" on a touch synced with a receiver. Occasionally a song song will stutter, primarily on the receiver, but the sync might trip up the touch a bit. It's the typical strawberry jam on the CD sound.

    my current solution is just to skip to the next track.

    Best way to address? Saying "ditch the receiver" is an acceptable solution Perhaps the fix is in 8+ but it a setting I have to tweak?

    Jim

  2. #32
    Senior Member
    Join Date
    Oct 2009
    Location
    Western/Northern New York
    Posts
    1,033
    Quote Originally Posted by Redrum View Post
    I read a variety of posts in two threads on this and hope someone can summarize a solution.

    I am new to Tidal, trying a tidal hi-fi+ trial. I am running 8.2.0 - 1627922070

    I have been running a few tidal "mixes" on a touch synced with a receiver. Occasionally a song song will stutter, primarily on the receiver, but the sync might trip up the touch a bit. It's the typical strawberry jam on the CD sound.

    my current solution is just to skip to the next track.

    Best way to address? Saying "ditch the receiver" is an acceptable solution Perhaps the fix is in 8+ but it a setting I have to tweak?

    Jim
    Sorry to bump this. I am having tidal stuttering on a receiver, touches play fine. I am assuming that I have to change a setting in LMS (per one of Michael's previous posts), and am guessing that it's on settings->advanced->file types, but I am unclear what the change? There are alot of buttons and knobs on this page.

    Jim

  3. #33
    Senior Member
    Join Date
    May 2008
    Location
    United States, Florida
    Posts
    12,679
    Quote Originally Posted by mherger View Post
    > Could someone walk me through inserting a custom conf file in the
    > appropriate place to solve this for me.


    The latest LMS8 should have the necessary changes which would allow you
    to transcode to PCM.


    --

    Michael
    I'm not sure exactly what Michael is referring to here. I don't use Tidal, don't use a custom_convert, and use the default settings on filetype. But perhaps the answer is in the LMS > Settings > Advanced > Filetypes, the user would set FLAC to "disabled" instead of "native" and PCM to disabled. Not sure, but if that causes any issues, just set them back to FLAC > native and PCM > FLAC. You won't break anything trying. See picture. (other thoughts are useful from someone more knowledgeable about this).

    edit: maybe on that filetypes settings page you need to also (or instead) untick the "prefer native format (decoding on player) when possible"
    Name:  Capture.JPG
Views: 52
Size:  14.8 KB
    Last edited by garym; 2022-01-20 at 06:04.
    Home: Pi4B-8GB/pCP8.x/4TB>LMS 8.2.x>Transporter, Touch, Boom, Radio (all ethernet)
    Cottage: rPi4B-4GB/pCP8.x/4TB>LMS 8.2.x>Touch>Benchmark DAC I, Boom, Radio w/Battery (Radio WIFI)
    Office: Win10(64)>foobar2000
    The Wild: rPi3B+/pCP7.x/4TB>LMS 8.1.x>hifiberry Dac+Pro (LMS & Squeezelite)
    Controllers: iPhone11 & iPadAir3 (iPeng), CONTROLLER, Material Skin, or SqueezePlay 7.8 on Win10(64)
    Files: Ripping: dBpoweramp > FLAC; Post-rip: mp3tag, PerfectTunes, TuneFusion; Streaming: Spotify

  4. #34
    Senior Member
    Join Date
    May 2008
    Location
    United States, Florida
    Posts
    12,679
    Also, in another thread, @mherger noted that he had "added a flag" to LMS8 to solve stuttering. Where is this 'flag' setting in LMS > Settings? Is that the "prefer native format (decode on player)" option I mention in post above? Thanks.

    > I'm never sure about the alternatives when native flac gets disabled.
    > This might be related to "type" I think standard flc rules "PCM" and
    > "MP3" are just "F" and no "I". Maybe need to add the Flac PCM "I" to
    > convert.conf


    I added the I flag to LMS8. You should be able to transcode to PCM, and
    it certainly solved the stuttering for aforementioned tracks. Please
    updated to the latest LMS8 build and disable native FLAC playback.
    Last edited by garym; 2022-01-20 at 06:17.
    Home: Pi4B-8GB/pCP8.x/4TB>LMS 8.2.x>Transporter, Touch, Boom, Radio (all ethernet)
    Cottage: rPi4B-4GB/pCP8.x/4TB>LMS 8.2.x>Touch>Benchmark DAC I, Boom, Radio w/Battery (Radio WIFI)
    Office: Win10(64)>foobar2000
    The Wild: rPi3B+/pCP7.x/4TB>LMS 8.1.x>hifiberry Dac+Pro (LMS & Squeezelite)
    Controllers: iPhone11 & iPadAir3 (iPeng), CONTROLLER, Material Skin, or SqueezePlay 7.8 on Win10(64)
    Files: Ripping: dBpoweramp > FLAC; Post-rip: mp3tag, PerfectTunes, TuneFusion; Streaming: Spotify

  5. #35
    Senior Member
    Join Date
    Oct 2009
    Location
    Western/Northern New York
    Posts
    1,033
    Quote Originally Posted by garym View Post
    Also, in another thread, @mherger noted that he had "added a flag" to LMS8 to solve stuttering. Where is this 'flag' setting in LMS > Settings? Is that the "prefer native format (decode on player)" option I mention in post above? Thanks.
    Right, that is what I was trying to get clarification on, what exactly is meant by "disable native FLAC playback" in Michael's message? I was hoping he was listening
    Jim

  6. #36
    Babelfish's Best Boy mherger's Avatar
    Join Date
    Apr 2005
    Location
    Switzerland
    Posts
    20,718

    Tidal stutter using LMS

    > Right, that is what I was trying to get clarification on, what exactly
    > is meant by "disable native FLAC playback" in Michael's message? I was
    > hoping he was listening


    I am... but sometimes I don't read in real time!

    They quote garym posted already is outdated :-). Philippe subsequently
    did even more work to improve the streaming reliability. Please check
    Settings/Advanced/Networking where you'll find three options for the
    http streaming mode.

  7. #37
    Senior Member
    Join Date
    Oct 2009
    Location
    Western/Northern New York
    Posts
    1,033
    Quote Originally Posted by mherger View Post

    I am... but sometimes I don't read in real time!
    You could have fooled me, understood. Sorry to be persistent, but I was trying to resolve since 12/25 and there were "crickets" (not the sport, bug noise) https://forums.slimdevices.com/showt...=1#post1041298

    I was familiar with persistent mode as a successor to reliable (for podcasts), but are you suggesting that this should address Tidal stutter on only a receiver, rather than the transcoding via LMS as suggested earlier?

    oops, I just looked, I was in normal mode, now how did that happen?

    Thank you!
    Jim

  8. #38
    Senior Member
    Join Date
    May 2008
    Location
    United States, Florida
    Posts
    12,679
    Quote Originally Posted by Redrum View Post
    You could have fooled me, understood. Sorry to be persistent, but I was trying to resolve since 12/25 and there were "crickets" (not the sport, bug noise) https://forums.slimdevices.com/showt...=1#post1041298

    I was familiar with persistent mode as a successor to reliable (for podcasts), but are you suggesting that this should address Tidal stutter on only a receiver, rather than the transcoding via LMS as suggested earlier?

    oops, I just looked, I was in normal mode, now how did that happen?

    Thank you!
    Jim
    Yes, that's what he is saying. Try the persistent mode (ignore my filetypes suggestions!)
    Home: Pi4B-8GB/pCP8.x/4TB>LMS 8.2.x>Transporter, Touch, Boom, Radio (all ethernet)
    Cottage: rPi4B-4GB/pCP8.x/4TB>LMS 8.2.x>Touch>Benchmark DAC I, Boom, Radio w/Battery (Radio WIFI)
    Office: Win10(64)>foobar2000
    The Wild: rPi3B+/pCP7.x/4TB>LMS 8.1.x>hifiberry Dac+Pro (LMS & Squeezelite)
    Controllers: iPhone11 & iPadAir3 (iPeng), CONTROLLER, Material Skin, or SqueezePlay 7.8 on Win10(64)
    Files: Ripping: dBpoweramp > FLAC; Post-rip: mp3tag, PerfectTunes, TuneFusion; Streaming: Spotify

  9. #39
    Babelfish's Best Boy mherger's Avatar
    Join Date
    Apr 2005
    Location
    Switzerland
    Posts
    20,718

    Tidal stutter using LMS

    > You could have fooled me, understood. Sorry to be persistent, but I was
    > trying to resolve since 12/25 and there were "crickets" (not the sport,
    > bug noise)
    > https://forums.slimdevices.com/showt...=1#post1041298


    Oops... sorry... I'm currently a bit busy - in between vacations :-).

    > I was familiar with persistent mode as a successor to reliable (for
    > podcasts), but are you suggesting that this should address Tidal stutter
    > on only a receiver, rather than the transcoding via LMS as suggested
    > earlier?


    Yes, I think so. There's no direct streaming anyway, as the players
    don't support https.

  10. #40
    Senior Member
    Join Date
    May 2008
    Location
    Canada
    Posts
    7,880
    Quote Originally Posted by mherger View Post
    > You could have fooled me, understood. Sorry to be persistent, but I was
    > trying to resolve since 12/25 and there were "crickets" (not the sport,
    > bug noise)
    > https://forums.slimdevices.com/showt...=1#post1041298


    Oops... sorry... I'm currently a bit busy - in between vacations :-).

    > I was familiar with persistent mode as a successor to reliable (for
    > podcasts), but are you suggesting that this should address Tidal stutter
    > on only a receiver, rather than the transcoding via LMS as suggested
    > earlier?


    Yes, I think so. There's no direct streaming anyway, as the players
    don't support https.
    Isnt that rather the issue with high compression rate of flac that does not work well with SB3, diet and Boom? We added a forced transcode option that plugins could set, but AFAIR, we activated it in Deezer only. I might be wrong, but isnt tidal doing flac as well now ?
    LMS 8.2 on Odroid-C4 - SqueezeAMP!, 5xRadio, 5xBoom, 2xDuet, 1xTouch, 1xSB3. Sonos PLAY:3, PLAY:5, Marantz NR1603, Foobar2000, ShairPortW, 2xChromecast Audio, Chromecast v1 and v2, Squeezelite on Pi, Yamaha WX-010, AppleTV 4, Airport Express, GGMM E5, RivaArena 1 & 3

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •