Home of the Squeezebox™ & Transporter® network music players.
Results 1 to 6 of 6
  1. #1
    Senior Member
    Join Date
    Dec 2006
    Location
    UK
    Posts
    503

    Blocked out of LMS

    Fiddling with settings in LMS's browser interface, for some reason in Advanced/Security I changed Block Incoming Connections to Block.

    Now, of course, I can't get to the server with any of my players, and I can't get back into the browser (or the pref panel) -- I'm blocked! --- to change the setting back.

    A bit like being locked out of your house because the key is locked inside.

    I'm on MacOS 10.14.6, LMS 7.9.1.

    Can't think what to do. Probably something obvious, but don't know what.

    Help!

  2. #2
    Senior Member
    Join Date
    Apr 2005
    Location
    UK/London
    Posts
    1,887
    Like when locking your keys in the house ... you need to go around the back to see if there are any windows open.

    In this case ... find your slimserver/prefs/server.prefs and have a look through it (it is a text file).
    (the path for this is in LMS web interface under Settings/Information/Preferences Folder)

    Somewhere in server.prefs will be the field for this ...

    If you find it you can probably set it to 0 or remove the line ... but don't do that until you have made a backup of the file AND shutdown LMS (because it can write out to the prefs file when it exits so your change would be lost).

    Check the file permisssions and ownership before and after you edit it and make sure that they are the same.

    Then restart LMS
    Paul Webster
    http://dabdig.blogspot.com
    Author Radio France (FIP etc) plugin

  3. #3
    Senior Member
    Join Date
    Dec 2006
    Location
    UK
    Posts
    503
    Thanks, Paul. Will give it a try later. One point tho: I can't close LMS, because the sysytem prefs place, where I usually switch the server off and on when required, is also not seeing it. So when I click Stop Server, nothing happens. Is there another way to do it?

  4. #4
    Babelfish's Best Boy mherger's Avatar
    Join Date
    Apr 2005
    Location
    Switzerland
    Posts
    20,326

    Blocked out of LMS

    > Thanks, Paul. Will give it a try later. One point tho: I can't close
    > LMS, because the sysytem prefs place, where I usually switch the server
    > off and on when required, is also not seeing it. So when I click Stop
    > Server, nothing happens. Is there another way to do it?


    /Library/PreferencePanes/Squeezebox.prefPane/Contents/Resources/stop-server.sh


    --

    Michael

  5. #5
    Senior Member
    Join Date
    Dec 2006
    Location
    UK
    Posts
    503
    Thanks both, will give it a whirl later and report back.

  6. #6
    Senior Member
    Join Date
    Dec 2006
    Location
    UK
    Posts
    503
    Gentlemen, ta very much, those tips worked to get me back and running with LMS.

    As I and many others have said before, what on earth would we do without such helpful people at this helpful forum?

    Before I go...

    In case anyone in the future is as daft as me (and using MacOS) and lands here for advice...

    To manually turn the server off when access is blocked, Michael's path is accurate. Open that text file, copy it, paste it into Terminal, and return. LMS is off.

    Path to the server,prefs is:

    ~/Library/Application Support/Squeezebox/server.prefs

    Open with Textedit or similar. The relevant line to change to a 0 is "ts_allowedHosts:"

    Start LMS in usual way. All good. Thank your helpers.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •