Home of the Squeezebox™ & Transporter® network music players.
Page 2 of 6 FirstFirst 1234 ... LastLast
Results 11 to 20 of 52
  1. #11
    Senior Member kidstypike's Avatar
    Join Date
    Feb 2007
    Location
    Brindle
    Posts
    3,392
    Quote Originally Posted by Learnincurve View Post
    Thanks for the advice, I see three cache.db files (when the server is running:

    locate cache.db
    /var/lib/squeezeboxserver/cache/cache.db
    /var/lib/squeezeboxserver/cache/cache.db-shm
    /var/lib/squeezeboxserver/cache/cache.db-wal

    Should I delete all three?

    Firefox and Chrome caches deleted.
    You can't delete all three.

    Stop LMS and you'll just see the first one - delete that.
    Server - LMS 8.0.0 Pi4B 4GB/Flirc case/pCP 6.0.0-b7 18K library, playlists & LMS cache on SSD (ntfs)
    Study - Pi3B+/pCP 5.0.0/pi screen/HiFiBerry DAC+/jivelite,
    Lounge - Pi2/pCP 5.0.0 > HiFiBerry DIGI+ > AudioEngine DAC1 > AVI DM5
    Dining Room - Squeezebox Boom
    Garage - Pi3B/Pi screen/HiFiBerry DAC+/pCP 5.0.0 > Edifier R980T

    Spares - 2xTouch, 1xSB3, 1xRadio, 6xRPi

  2. #12
    Senior Member
    Join Date
    Oct 2005
    Location
    Ireland
    Posts
    18,002
    When LMS is stopped there should only be cache.db -IIRC wal is for process locking and shm is shared memory maybe for performance. I'd delete all three. I delete cache.db everytime I start LMS as I do testing with internet streams and caching plays havok with trying to get reproducible results. Deleting cache everytime may cause a performance hit for people who play a lot of local files.

    DNS records show there is an ok internet connection. I/F stats look clean no errors so no timeout expected due to network connections issues.
    The problem seems to be limited to mysqueezebox.com.
    Port 443 is SSL stuff. Is your OpenSSL up to date ? I have Ubuntu 18.04.3 LTS and OpenSSL should be at 1.1.1-1ubuntu2.1 (about Dec 2018) .
    I've seen SSL issues with old versions causing network delays / timeouts.

    I'll try to find a https MP3 to try to play - it may help test SSL separate from mysqueezebox.com

  3. #13
    Senior Member
    Join Date
    Sep 2015
    Posts
    173
    Quote Originally Posted by bpa View Post
    When LMS is stopped there should only be cache.db -IIRC wal is for process locking and shm is shared memory maybe for performance. I'd delete all three. I delete cache.db everytime I start LMS as I do testing with internet streams and caching plays havok with trying to get reproducible results. Deleting cache everytime may cause a performance hit for people who play a lot of local files.

    DNS records show there is an ok internet connection. I/F stats look clean no errors so no timeout expected due to network connections issues.
    The problem seems to be limited to mysqueezebox.com.
    Port 443 is SSL stuff. Is your OpenSSL up to date ? I have Ubuntu 18.04.3 LTS and OpenSSL should be at 1.1.1-1ubuntu2.1 (about Dec 2018) .
    I've seen SSL issues with old versions causing network delays / timeouts.

    I'll try to find a https MP3 to try to play - it may help test SSL separate from mysqueezebox.com
    Thanks bpa and thanks also to kidstypike.

    I'll delete the cache this evening. One thing I forgot to mention is that I'm ripping my entire CD collection at present, so lots of local files are being moved on the filesystem, could be corrupting gthe cache with loads of invalid paths. Just a thought.

    Anyway, will see if that helps and also check OpenSSL.

    BR.

    --Marius--

  4. #14
    Senior Member
    Join Date
    Sep 2015
    Posts
    173
    Quote Originally Posted by bpa View Post
    When LMS is stopped there should only be cache.db -IIRC wal is for process locking and shm is shared memory maybe for performance. I'd delete all three. I delete cache.db everytime I start LMS as I do testing with internet streams and caching plays havok with trying to get reproducible results. Deleting cache everytime may cause a performance hit for people who play a lot of local files.

    DNS records show there is an ok internet connection. I/F stats look clean no errors so no timeout expected due to network connections issues.
    The problem seems to be limited to mysqueezebox.com.
    Port 443 is SSL stuff. Is your OpenSSL up to date ? I have Ubuntu 18.04.3 LTS and OpenSSL should be at 1.1.1-1ubuntu2.1 (about Dec 2018) .
    I've seen SSL issues with old versions causing network delays / timeouts.

    I'll try to find a https MP3 to try to play - it may help test SSL separate from mysqueezebox.com
    "openssl is already the newest version (1.1.1-1ubuntu2.2)"

    Tried deleting cache with no improvement:

    2019-11-13 17:14:45 squeezeboxserver_safe started.
    [19-11-13 17:14:46.4650] main::init (387) Starting Logitech Media Server (v7.9.2, 1572699180, Sat Nov 2 14:13:52 CET 2019) perl 5.026002 - x86_64-linux-gnu-thread-multi
    [19-11-13 17:15:17.4145] Slim::Networking::Async::connect (115) Failed to connect to www.mysqueezebox.com:443, because
    Net::HTTP: connect: timeout
    [19-11-13 17:15:17.4154] Slim::Formats::XML::gotErrorViaHTTP (339) Error: getting https://www.mysqueezebox.com/api/sounds/v1/opml
    Connect timed out: Connection timed out
    [19-11-13 17:15:17.4159] Slim::Plugin::Sounds::Plugin::_gotSoundsError (83) Error: Unable to cache Sounds & Effects menu from SN: Connect timed out: Connection timed out
    2019-11-13 17:15:46 squeezeboxserver_safe stopped.
    2019-11-13 17:16:50 squeezeboxserver_safe started.
    [19-11-13 17:16:52.4106] main::init (387) Starting Logitech Media Server (v7.9.2, 1572699180, Sat Nov 2 14:13:52 CET 2019) perl 5.026002 - x86_64-linux-gnu-thread-multi
    [19-11-13 17:17:23.4476] Slim::Networking::Async::connect (115) Failed to connect to www.mysqueezebox.com:443, because
    Net::HTTP: connect: timeout
    [19-11-13 17:17:23.4485] Slim::Formats::XML::gotErrorViaHTTP (339) Error: getting https://www.mysqueezebox.com/api/sounds/v1/opml
    Connect timed out: Connection timed out
    [19-11-13 17:17:23.4491] Slim::Plugin::Sounds::Plugin::_gotSoundsError (83) Error: Unable to cache Sounds & Effects menu from SN: Connect timed out: Connection timed out
    [19-11-13 17:18:23.7740] Slim::Networking::Async::connect (115) Failed to connect to www.mysqueezebox.com:443, because
    Net::HTTP: connect: timeout
    [19-11-13 17:18:23.7748] Slim::Networking::SqueezeNetwork::_error (497) Unable to login to SN: Connect timed out: Connection timed out
    [19-11-13 17:18:23.7755] Slim::Networking::SqueezeNetwork::_init_error (177) Unable to login to mysqueezebox.com, sync is disabled: Connect timed out: Connection timed out (https://www.mysqueezebox.com)
    [19-11-13 17:18:23.7765] Slim::Networking::SqueezeNetwork::_init_error (193) mysqueezebox.com sync init failed: Connect timed out: Connection timed out, will retry in 33600 (https://www.mysqueezebox.com)
    [19-11-13 17:18:23.7839] Slim::Networking::Repositories::__ANON__ (146) Failed to fetch https://sourceforge.net/projects/bpa...ease-repo.xml: Connect timed out:
    [19-11-13 17:18:23.7845] Slim::Networking::Repositories::__ANON__ (149) https lookup failed - trying plain text http instead: http://sourceforge.net/projects/bpap...lease-repo.xml
    [19-11-13 17:18:23.8293] Slim::Networking::Repositories::__ANON__ (146) Failed to fetch https://repos.squeezecommunity.org/extensions.xml: Connect timed out:
    [19-11-13 17:18:23.8296] Slim::Networking::Repositories::__ANON__ (149) https lookup failed - trying plain text http instead: http://repos.squeezecommunity.org/extensions.xml
    [19-11-13 17:18:23.8381] Slim::Networking::Repositories::__ANON__ (146) Failed to fetch https://sourceforge.net/projects/bpa...ease-repo.xml: Connect timed out: Bad file descriptor
    [19-11-13 17:18:23.8384] Slim::Networking::Repositories::__ANON__ (149) https lookup failed - trying plain text http instead: http://sourceforge.net/projects/bpap...lease-repo.xml
    [19-11-13 17:18:23.8399] Slim::Networking::Repositories::__ANON__ (146) Failed to fetch https://repos.squeezecommunity.org/extensions.xml: Connect timed out: Bad file descriptor
    [19-11-13 17:18:23.8402] Slim::Networking::Repositories::__ANON__ (149) https lookup failed - trying plain text http instead: http://repos.squeezecommunity.org/extensions.xml
    [19-11-13 17:18:23.8420] Slim::Networking::Repositories::__ANON__ (146) Failed to fetch https://repos.squeezecommunity.org/extensions.xml: Connect timed out: Bad file descriptor
    [19-11-13 17:18:23.8422] Slim::Networking::Repositories::__ANON__ (149) https lookup failed - trying plain text http instead: http://repos.squeezecommunity.org/extensions.xml
    [19-11-13 17:18:23.8437] Slim::Networking::Repositories::__ANON__ (146) Failed to fetch https://sourceforge.net/projects/bpa...ease-repo.xml: Connect timed out: Bad file descriptor
    [19-11-13 17:18:23.8439] Slim::Networking::Repositories::__ANON__ (149) https lookup failed - trying plain text http instead: http://sourceforge.net/projects/bpap...lease-repo.xml



    Can you give advice on how to play .mp3 files directly over https?

  5. #15
    Senior Member
    Join Date
    Oct 2005
    Location
    Ireland
    Posts
    18,002
    Quote Originally Posted by Learnincurve View Post
    Can you give advice on how to play .mp3 files directly over https?
    Can't play mp3 files over https as such - I was looking for a radio station (ideally MP3) which uses https.

    All your problems seems to be https related. Possibly just mysqueeze.com. Sourceforge is unreliable (I get sourceforge timeout all the time) so these errors cannot be attributed to https.

    As a test - can you replace your bpa repo ( https://sourceforge.net/projects/bpa...lease-repo.xml ) in plugins tab with the following - it eventually points to same code but avoid sourceforege errors.

    https://bpa-code.github.io/bpaplugin...lease-repo.xml

    When the URL has been changed - check the log to see if you get an error on this https URL.

    If there is an error then it seems to point to a generic https issue.

  6. #16
    Senior Member
    Join Date
    Sep 2015
    Posts
    173
    Tried deleting cache with no improvement:

    2019-11-13 17:14:45 squeezeboxserver_safe started.
    [19-11-13 17:14:46.4650] main::init (387) Starting Logitech Media Server (v7.9.2, 1572699180, Sat Nov 2 14:13:52 CET 2019) perl 5.026002 - x86_64-linux-gnu-thread-multi
    [19-11-13 17:15:17.4145] Slim::Networking::Async::connect (115) Failed to connect to www.mysqueezebox.com:443, because
    Net::HTTP: connect: timeout
    [19-11-13 17:15:17.4154] Slim::Formats::XML::gotErrorViaHTTP (339) Error: getting https://www.mysqueezebox.com/api/sounds/v1/opml
    Connect timed out: Connection timed out
    [19-11-13 17:15:17.4159] Slim::Plugin::Sounds::Plugin::_gotSoundsError (83) Error: Unable to cache Sounds & Effects menu from SN: Connect timed out: Connection timed out
    2019-11-13 17:15:46 squeezeboxserver_safe stopped.
    2019-11-13 17:16:50 squeezeboxserver_safe started.
    [19-11-13 17:16:52.4106] main::init (387) Starting Logitech Media Server (v7.9.2, 1572699180, Sat Nov 2 14:13:52 CET 2019) perl 5.026002 - x86_64-linux-gnu-thread-multi
    [19-11-13 17:17:23.4476] Slim::Networking::Async::connect (115) Failed to connect to www.mysqueezebox.com:443, because
    Net::HTTP: connect: timeout
    [19-11-13 17:17:23.4485] Slim::Formats::XML::gotErrorViaHTTP (339) Error: getting https://www.mysqueezebox.com/api/sounds/v1/opml
    Connect timed out: Connection timed out
    [19-11-13 17:17:23.4491] Slim::Plugin::Sounds::Plugin::_gotSoundsError (83) Error: Unable to cache Sounds & Effects menu from SN: Connect timed out: Connection timed out
    [19-11-13 17:18:23.7740] Slim::Networking::Async::connect (115) Failed to connect to www.mysqueezebox.com:443, because
    Net::HTTP: connect: timeout
    [19-11-13 17:18:23.7748] Slim::Networking::SqueezeNetwork::_error (497) Unable to login to SN: Connect timed out: Connection timed out
    [19-11-13 17:18:23.7755] Slim::Networking::SqueezeNetwork::_init_error (177) Unable to login to mysqueezebox.com, sync is disabled: Connect timed out: Connection timed out (https://www.mysqueezebox.com)
    [19-11-13 17:18:23.7765] Slim::Networking::SqueezeNetwork::_init_error (193) mysqueezebox.com sync init failed: Connect timed out: Connection timed out, will retry in 33600 (https://www.mysqueezebox.com)
    [19-11-13 17:18:23.7839] Slim::Networking::Repositories::__ANON__ (146) Failed to fetch https://sourceforge.net/projects/bpa...ease-repo.xml: Connect timed out:
    [19-11-13 17:18:23.7845] Slim::Networking::Repositories::__ANON__ (149) https lookup failed - trying plain text http instead: http://sourceforge.net/projects/bpap...lease-repo.xml
    [19-11-13 17:18:23.8293] Slim::Networking::Repositories::__ANON__ (146) Failed to fetch https://repos.squeezecommunity.org/extensions.xml: Connect timed out:
    [19-11-13 17:18:23.8296] Slim::Networking::Repositories::__ANON__ (149) https lookup failed - trying plain text http instead: http://repos.squeezecommunity.org/extensions.xml
    [19-11-13 17:18:23.8381] Slim::Networking::Repositories::__ANON__ (146) Failed to fetch https://sourceforge.net/projects/bpa...ease-repo.xml: Connect timed out: Bad file descriptor
    [19-11-13 17:18:23.8384] Slim::Networking::Repositories::__ANON__ (149) https lookup failed - trying plain text http instead: http://sourceforge.net/projects/bpap...lease-repo.xml
    [19-11-13 17:18:23.8399] Slim::Networking::Repositories::__ANON__ (146) Failed to fetch https://repos.squeezecommunity.org/extensions.xml: Connect timed out: Bad file descriptor
    [19-11-13 17:18:23.8402] Slim::Networking::Repositories::__ANON__ (149) https lookup failed - trying plain text http instead: http://repos.squeezecommunity.org/extensions.xml
    [19-11-13 17:18:23.8420] Slim::Networking::Repositories::__ANON__ (146) Failed to fetch https://repos.squeezecommunity.org/extensions.xml: Connect timed out: Bad file descriptor
    [19-11-13 17:18:23.8422] Slim::Networking::Repositories::__ANON__ (149) https lookup failed - trying plain text http instead: http://repos.squeezecommunity.org/extensions.xml
    [19-11-13 17:18:23.8437] Slim::Networking::Repositories::__ANON__ (146) Failed to fetch https://sourceforge.net/projects/bpa...ease-repo.xml: Connect timed out: Bad file descriptor
    [19-11-13 17:18:23.8439] Slim::Networking::Repositories::__ANON__ (149) https lookup failed - trying plain text http instead: http://sourceforge.net/projects/bpap...lease-repo.xml

  7. #17
    Senior Member
    Join Date
    Sep 2015
    Posts
    173
    Continuation...

    regarding SSL:

    telnet sourceforge.net 443
    Trying 216.105.38.13...
    Connected to sourceforge.net.
    Escape character is '^]'.
    Connection closed by foreign host.

    telnet www.mysqueezebox.com 443
    Trying 34.229.43.96...
    ^C
    telnet www.mysqueezebox.com 80
    Trying 34.229.43.96...
    ^C

    But traceroute is weird. Here's what I get from the LMS host:

    Code:
    traceroute www.mysqueezebox.com
    traceroute to www.mysqueezebox.com (34.229.43.96), 30 hops max, 60 byte packets
     1  pfsense (192.168.253.1)  0.137 ms  0.098 ms  0.065 ms
     2  home (192.168.10.1)  0.717 ms  1.028 ms  1.369 ms
     3  1.92-221-64.customer.lyse.net (92.221.64.1)  8.318 ms  8.428 ms  8.511 ms
     4  217.213-167-114.customer.lyse.net (213.167.114.217)  15.803 ms  15.910 ms  16.053 ms
     5  et-0-0-13.bar1.Oslo2.Level3.net (62.140.27.57)  28.504 ms  28.614 ms et-0-0-23.bar1.Oslo2.Level3.net (62.140.27.5)  26.257 ms
     6  * * *
     7  AMAZON.COM.edge1.Washington1.Level3.net (4.28.125.110)  127.493 ms  120.318 ms  122.450 ms
     8  54.239.109.126 (54.239.109.126)  138.023 ms 54.239.109.160 (54.239.109.160)  126.378 ms 54.239.109.92 (54.239.109.92)  138.664 ms
     9  52.93.114.237 (52.93.114.237)  119.826 ms 52.93.114.133 (52.93.114.133)  122.175 ms 52.93.114.153 (52.93.114.153)  121.766 ms
    10  * * *
    11  * * *
    12  * * *
    13  52.93.28.186 (52.93.28.186)  117.605 ms 52.93.28.188 (52.93.28.188)  119.691 ms 52.93.28.190 (52.93.28.190)  118.629 ms
    14  * * *
    15  * * *
    16  * * *
    17  * * *
    18  * * *
    19  * * *
    20  * * *
    21  * * *
    22  * * *
    23  * * *
    24  * * *
    25  * * *
    26  * * *
    27  * * *
    28  * * *
    29  * * *
    30  * * *
    Doesn't seem to matter what port or method I try. results are the same:

    Code:
    traceroute -M tcp -p 443 www.mysqueezebox.com
    traceroute to www.mysqueezebox.com (34.229.43.96), 30 hops max, 60 byte packets
     1  pfsense (192.168.253.1)  0.107 ms  0.114 ms  0.090 ms
     2  home (192.168.10.1)  1.021 ms  1.365 ms  1.660 ms
     3  1.92-221-64.customer.lyse.net (92.221.64.1)  6.628 ms  6.739 ms  6.895 ms
     4  217.213-167-114.customer.lyse.net (213.167.114.217)  14.155 ms  14.271 ms  14.376 ms
     5  et-0-0-13.bar1.Oslo2.Level3.net (62.140.27.57)  26.523 ms et-0-0-23.bar1.Oslo2.Level3.net (62.140.27.5)  25.424 ms et-0-0-25.bar1.Oslo2.Level3.net (62.140.27.1)  25.592 ms
     6  * * *
     7  AMAZON.COM.edge1.Washington1.Level3.net (4.28.125.110)  125.825 ms  122.775 ms  120.834 ms
     8  54.239.110.6 (54.239.110.6)  140.111 ms 54.239.109.92 (54.239.109.92)  139.032 ms 54.239.109.194 (54.239.109.194)  151.729 ms
     9  52.93.114.233 (52.93.114.233)  119.116 ms 52.93.114.137 (52.93.114.137)  119.688 ms 52.93.114.211 (52.93.114.211)  117.081 ms
    10  * * *
    11  * * *
    12  * * *
    13  52.93.28.182 (52.93.28.182)  122.792 ms 52.93.28.160 (52.93.28.160)  117.282 ms  117.332 ms
    14  * * *
    15  * * *
    16  * * *
    17  * * *
    18  * * *
    19  * * *
    20  * * *
    21  * * *
    22  * * *
    23  * * *
    24  * * *
    25  * * *
    26  * * *
    27  * * *
    28  * * *
    29  * * *
    30  * * *
    But if I try from a different host on the same network, I get this:

    Code:
    traceroute www.mysqueezebox.com
    traceroute to www.mysqueezebox.com (34.244.111.131), 30 hops max, 60 byte packets
     1  pfsense (192.168.253.1)  3.405 ms  3.339 ms  3.251 ms
     2  home (192.168.10.1)  4.053 ms  4.044 ms  4.952 ms
     3  1.92-221-64.customer.lyse.net (92.221.64.1)  11.568 ms  11.552 ms  11.509 ms
     4  219.213-167-114.customer.lyse.net (213.167.114.219)  16.829 ms  16.817 ms  16.772 ms
     5  99.82.176.134 (99.82.176.134)  16.736 ms  16.692 ms  16.655 ms
     6  52.93.138.118 (52.93.138.118)  37.185 ms 52.93.138.102 (52.93.138.102)  16.756 ms 52.93.138.86 (52.93.138.86)  16.673 ms
     7  52.93.138.95 (52.93.138.95)  20.226 ms 52.93.138.67 (52.93.138.67)  12.592 ms 52.93.138.47 (52.93.138.47)  21.818 ms
     8  * * *
     9  52.93.129.45 (52.93.129.45)  63.560 ms  60.901 ms  60.868 ms
    10  52.93.2.27 (52.93.2.27)  61.929 ms  61.903 ms  63.509 ms
    11  54.239.42.170 (54.239.42.170)  63.503 ms  63.502 ms  63.481 ms
    12  150.222.240.170 (150.222.240.170)  61.475 ms  63.030 ms  63.046 ms
    13  * * *
    14  * * *
    15  * * *
    16  * * *
    17  150.222.240.42 (150.222.240.42)  62.203 ms 150.222.240.44 (150.222.240.44)  61.303 ms 150.222.240.54 (150.222.240.54)  61.323 ms
    18  * * *
    19  52.93.6.176 (52.93.6.176)  61.373 ms 52.93.6.174 (52.93.6.174)  61.444 ms 52.93.6.238 (52.93.6.238)  62.037 ms
    20  52.93.101.21 (52.93.101.21)  61.124 ms 52.93.101.27 (52.93.101.27)  60.364 ms 52.93.101.55 (52.93.101.55)  60.517 ms
    21  52.93.101.48 (52.93.101.48)  61.481 ms 52.93.101.26 (52.93.101.26)  60.580 ms 52.93.101.16 (52.93.101.16)  62.055 ms
    22  52.93.7.129 (52.93.7.129)  60.420 ms 52.93.7.147 (52.93.7.147)  60.419 ms 52.93.7.159 (52.93.7.159)  61.969 ms
    23  * * *
    24  * * *
    25  * * *
    26  * * *
    27  * * *
    28  * * *
    29  * * *
    30  * * *
    Code:
    traceroute -M tcp -p 443 www.mysqueezebox.com
    traceroute to www.mysqueezebox.com (63.34.162.152), 30 hops max, 60 byte packets
     1  pfsense (192.168.253.1)  3.203 ms  3.162 ms  3.150 ms
     2  home (192.168.10.1)  4.090 ms  4.896 ms  4.896 ms
     3  1.92-221-64.customer.lyse.net (92.221.64.1)  9.343 ms  9.320 ms  9.311 ms
     4  219.213-167-114.customer.lyse.net (213.167.114.219)  14.310 ms  14.331 ms  14.322 ms
     5  99.82.176.134 (99.82.176.134)  19.668 ms  19.681 ms  19.670 ms
     6  52.93.138.70 (52.93.138.70)  16.350 ms 52.93.138.38 (52.93.138.38)  14.665 ms 52.93.138.70 (52.93.138.70)  14.645 ms
     7  52.93.138.61 (52.93.138.61)  14.623 ms 52.93.138.81 (52.93.138.81)  13.441 ms 52.93.138.83 (52.93.138.83)  12.740 ms
     8  * * *
     9  52.93.129.45 (52.93.129.45)  62.381 ms  60.072 ms  60.067 ms
    10  52.93.2.27 (52.93.2.27)  60.050 ms  61.731 ms  63.245 ms
    11  54.239.42.170 (54.239.42.170)  61.730 ms  63.145 ms  63.161 ms
    12  150.222.240.170 (150.222.240.170)  66.088 ms  66.106 ms  60.626 ms
    13  * * *
    14  * * *
    15  * * *
    16  * * *
    17  150.222.240.46 (150.222.240.46)  61.727 ms 150.222.240.42 (150.222.240.42)  61.236 ms 150.222.240.44 (150.222.240.44)  63.577 ms
    18  * * *
    19  52.93.6.194 (52.93.6.194)  62.528 ms 52.93.6.150 (52.93.6.150)  61.191 ms 52.93.6.226 (52.93.6.226)  61.554 ms
    20  52.93.101.63 (52.93.101.63)  60.615 ms 52.93.101.15 (52.93.101.15)  61.350 ms 52.93.101.7 (52.93.101.7)  61.064 ms
    21  52.93.101.24 (52.93.101.24)  61.523 ms 52.93.101.52 (52.93.101.52)  61.499 ms 52.93.101.38 (52.93.101.38)  60.873 ms
    22  52.93.7.63 (52.93.7.63)  60.837 ms 52.93.7.65 (52.93.7.65)  60.821 ms 52.93.7.77 (52.93.7.77)  61.178 ms
    23  * * *
    24  * * *
    25  * * *
    26  * * *
    27  * * *
    28  * * *
    29  * * *
    30  ec2-63-34-162-152.eu-west-1.compute.amazonaws.com (63.34.162.152)  61.193 ms  61.273 ms  61.263 ms

  8. #18
    Senior Member
    Join Date
    Sep 2015
    Posts
    173
    Quote Originally Posted by bpa View Post
    Can't play mp3 files over https as such - I was looking for a radio station (ideally MP3) which uses https.

    All your problems seems to be https related. Possibly just mysqueeze.com. Sourceforge is unreliable (I get sourceforge timeout all the time) so these errors cannot be attributed to https.

    As a test - can you replace your bpa repo ( https://sourceforge.net/projects/bpa...lease-repo.xml ) in plugins tab with the following - it eventually points to same code but avoid sourceforege errors.

    https://bpa-code.github.io/bpaplugin...lease-repo.xml

    When the URL has been changed - check the log to see if you get an error on this https URL.

    If there is an error then it seems to point to a generic https issue.
    Thanks.

    Trying that:
    [19-11-13 20:02:06.2725] Slim::Networking::Repositories::__ANON__ (146) Failed to fetch https://bpa-code.github.io/bpaplugin...ease-repo.xml: 404 Not Found
    [19-11-13 20:02:06.2729] Slim::Networking::Repositories::__ANON__ (149) https lookup failed - trying plain text http instead: http://bpa-code.github.io/bpaplugins...lease-repo.xml
    [19-11-13 20:02:15.0319] Slim::Networking::Repositories::__ANON__ (146) Failed to fetch https://bpa-code.github.io/bpaplugin...ease-repo.xml: 404 Not Found
    [19-11-13 20:02:15.0322] Slim::Networking::Repositories::__ANON__ (149) https lookup failed - trying plain text http instead: http://bpa-code.github.io/bpaplugins...lease-repo.xml
    2019-11-13 20:02:49 squeezeboxserver_safe stopped.
    2019-11-13 20:02:58 squeezeboxserver_safe started.
    [19-11-13 20:02:59.6597] main::init (387) Starting Logitech Media Server (v7.9.2, 1572699180, Sat Nov 2 14:13:52 CET 2019) perl 5.026002 - x86_64-linux-gnu-thread-multi
    [19-11-13 20:03:30.6180] Slim::Networking::Async::connect (115) Failed to connect to www.mysqueezebox.com:443, because
    Net::HTTP: connect: timeout
    [19-11-13 20:03:30.6187] Slim::Formats::XML::gotErrorViaHTTP (339) Error: getting https://www.mysqueezebox.com/api/sounds/v1/opml
    Connect timed out: Connection timed out
    [19-11-13 20:03:30.6191] Slim::Plugin::Sounds::Plugin::_gotSoundsError (83) Error: Unable to cache Sounds & Effects menu from SN: Connect timed out: Connection timed out

    BUT:

    telnet bpa-code.github.io 443
    Trying 185.199.109.153...
    Connected to bpa-code.github.io.
    Escape character is '^]'.

    Could this point to a perl ssl issue? How do I check my perl modules?
    Last edited by Learnincurve; 2019-11-13 at 12:07.

  9. #19
    Senior Member
    Join Date
    May 2010
    Location
    London, UK
    Posts
    411
    Quote Originally Posted by Learnincurve View Post
    Thanks.

    Trying that:
    [19-11-13 20:02:06.2725] Slim::Networking::Repositories::__ANON__ (146) Failed to fetch https://bpa-code.github.io/bpaplugins/files/betarelease-repo.xml: 404 Not Found
    Try https://bpa-code.github.io/bpaplugins/betarelease-repo.xml
    instead of https://bpa-code.github.io/bpaplugins/files/betarelease-repo.xml

  10. #20
    Senior Member
    Join Date
    Feb 2011
    Location
    Cheshire, UK
    Posts
    4,360
    i think the traceroutes are indicating a routing failure. Iĺd suggest running some further longer term jobs and then referring the results to your ISP.
    VB2.4 storage QNAP TS419p (NFS)
    Living Room - Joggler & SB3 -> Onkyo TS606 -> Celestion F20s
    Office - Pi3+Sreen -> Sony TAFE320 -> Celestion F10s / Pi2+DAC & SB3 -> Onkyo CRN755 -> Wharfedale Modus Cubes
    Dining Room -> SB Boom
    Kitchen -> UE Radio (upgraded to SB Radio)
    Bedroom (Bedside) - Pi2+DAC ->ToppingTP21 ->AKG Headphones
    Bedroom (TV) - SB Touch ->Sherwood AVR ->Mordaunt Short M10s
    Everything controlled by iPeng

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •