Home of the Squeezebox™ & Transporter® network music players.
Page 6 of 6 FirstFirst ... 456
Results 51 to 52 of 52
  1. #51
    Senior Member
    Join Date
    May 2010
    Location
    London, UK
    Posts
    402
    Quote Originally Posted by Ron F. View Post
    I have been very bad.
    Well, yes, somewhat disgraceful behaviour. And it seems that you are being punished for it.

    I've never attempted to build or install OpenSSL, and have no idea how one configures it. So not much help available from these parts.

    I see that "/usr/bin/openssl version -a" also returns (on my Debian system) how the compiler was configured at build time:
    compiler: gcc -DDSO_DLFCN -DHAVE_DLFCN_H -DNDEBUG -DOPENSSL_THREADS -DOPENSSL_NO_STATIC_ENGINE -DOPENSSL_PIC -DOPENSSL_BN_ASM_MONT -DOPENSSL_BN_ASM_GF2m -DSHA1_ASM -DSHA256_ASM -DSHA512_ASM -DAES_ASM -DBSAES_ASM -DGHASH_ASM -DECP_NISTZ256_ASM -DPOLY1305_ASM -DOPENSSLDIR=""/usr/lib/ssl"" -DENGINESDIR=""/usr/lib/arm-linux-gnueabi/engines-1.1""
    OPENSSLDIR: "/usr/lib/ssl"
    Spot the -DOPENSSLDIR=""/usr/lib/ssl"". Does yours look like that ? I would imagine that the version from the Ubuntu repository would. Although I don't know that.

  2. #52
    Senior Member
    Join Date
    May 2006
    Location
    Silicon Valley
    Posts
    434
    Quote Originally Posted by mrw View Post
    Well, yes, somewhat disgraceful behaviour. And it seems that you are being punished for it.

    I've never attempted to build or install OpenSSL, and have no idea how one configures it. So not much help available from these parts.

    I see that "/usr/bin/openssl version -a" also returns (on my Debian system) how the compiler was configured at build time:

    Spot the -DOPENSSLDIR=""/usr/lib/ssl"". Does yours look like that ? I would imagine that the version from the Ubuntu repository would. Although I don't know that.
    My output looks a lot like this, with exception that I have got: OPENSSLDIR=""/usr/local/ssl"" and I have not been able to stop it from doing that.

    Actually, I might just install the alternate version, openssl-1.1.1d, back into /usr/local/ssl, as I think it was working fine at the time, since now I am stuck with OPENSSLDIR pointing to that folder! I can create the symbolic links for certs and private to point back to /etc/ssl/... .
    Living Room: SB Touch + DIY PSU > CI Audio VDA.2 DAC + VAC.1 PSU > VRX.1 cables > Emotiva XSP-1 Gen 2 preamp + XPA-DR2 amp > Blue Jeans cables > B&W 804 speakers
    Laptop: System76 Galago + Ubuntu 16.04 + Squeezelite + Material Skin > Emotiva Little Ego DAC > Senn IE 80 earbuds
    Bedroom: Pixel 3a Phone + BubbleUPnP + Material/mobile > Bose SoundLink Revolve
    Server: Puget Systems Serenity + Ubuntu 18.04 + LMS 7.9.2
    Music: Personal FLAC, Radio Paradise FLAC, Qobuz, Spotify

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •