Home of the Squeezebox™ & Transporter® network music players.
Page 1 of 2 12 LastLast
Results 1 to 10 of 12

Thread: update

  1. #1
    Senior Member
    Join Date
    May 2009
    Posts
    700

    update

    hello
    i'm on 7.9.1 on raspberry picoreplayer and i would like to update to newer versions (cos i'm having a lot of issues), how is it possible to update on that raspberry?

    i notice many plugins don't work anymore (spotty, youtube, bandcamo, and also scrfeen saver); it's like raspb does'nt access to internet; i channged provider should i set something in router?
    Last edited by nervoteso; 2019-10-29 at 11:59.
    Touchx2,radiox4, Squeezebox Server 7.9 (Raspberrypi 3 and qnap ts-269)

  2. #2
    Senior Member paul-'s Avatar
    Join Date
    Jan 2013
    Posts
    2,495
    Its more than likely that alot of streams are moving to https, which 7.9.1 doesn't support. If you upgrade to pCP 5.0.0 or 6.0.0-beta. The LMS install is default to a 7.9.2 version. Otherwise, you can follow this.

    https://www.picoreplayer.org/how_to_upgrade_lms.shtml
    piCorePlayer a small player for the Raspberry Pi in RAM.
    Homepage: https://www.picoreplayer.org

    Please donate if you like the piCorePlayer

  3. #3
    Senior Member
    Join Date
    May 2009
    Posts
    700
    Quote Originally Posted by paul- View Post
    Its more than likely that alot of streams are moving to https, which 7.9.1 doesn't support. If you upgrade to pCP 5.0.0 or 6.0.0-beta. The LMS install is default to a 7.9.2 version. Otherwise, you can follow this.

    https://www.picoreplayer.org/how_to_upgrade_lms.shtml
    how can i update pcp? iím on 2.06. is it easier and safe?
    Touchx2,radiox4, Squeezebox Server 7.9 (Raspberrypi 3 and qnap ts-269)

  4. #4
    Senior Member paul-'s Avatar
    Join Date
    Jan 2013
    Posts
    2,495
    To be honest, Iíve not looked at a pCP version that old in a while. Doing the manual upgrade should be harmless enough. But the openssl version on that version of pCP is very old.....you will continue to have https problems.

    Get a new microSD and start with a new image.
    piCorePlayer a small player for the Raspberry Pi in RAM.
    Homepage: https://www.picoreplayer.org

    Please donate if you like the piCorePlayer

  5. #5
    Senior Member
    Join Date
    May 2009
    Posts
    700
    Quote Originally Posted by paul- View Post
    To be honest, I’ve not looked at a pCP version that old in a while. Doing the manual upgrade should be harmless enough. But the openssl version on that version of pCP is very old.....you will continue to have https problems.

    Get a new microSD and start with a new image.
    could you post a link where i can read some info to update with a new image?

    wuold it bettere if i install picoreplayer and lmp on a raspberry ip 4?
    Last edited by nervoteso; 2019-10-30 at 03:57.
    Touchx2,radiox4, Squeezebox Server 7.9 (Raspberrypi 3 and qnap ts-269)

  6. #6

  7. #7
    Senior Member paul-'s Avatar
    Join Date
    Jan 2013
    Posts
    2,495
    The RPi 3B+ or a 4 make a rather nice lms server.

    If you go the route of the 4, you will need to use the 6.0.0 beta. The beta is pretty stable, Iím just making changes more often as Rpi does lots of kernel/firmware changes on the 4.
    piCorePlayer a small player for the Raspberry Pi in RAM.
    Homepage: https://www.picoreplayer.org

    Please donate if you like the piCorePlayer

  8. #8
    Senior Member
    Join Date
    May 2009
    Posts
    700
    Quote Originally Posted by paul- View Post
    The RPi 3B+ or a 4 make a rather nice lms server.

    If you go the route of the 4, you will need to use the 6.0.0 beta. The beta is pretty stable, Iím just making changes more often as Rpi does lots of kernel/firmware changes on the 4.
    ok thanks. i'm going to buy a pi 4; is lmp 7.9.2 the default installation on beta 6.0.0?
    Touchx2,radiox4, Squeezebox Server 7.9 (Raspberrypi 3 and qnap ts-269)

  9. #9
    Senior Member
    Join Date
    May 2009
    Posts
    700
    thanks
    Touchx2,radiox4, Squeezebox Server 7.9 (Raspberrypi 3 and qnap ts-269)

  10. #10
    Senior Member paul-'s Avatar
    Join Date
    Jan 2013
    Posts
    2,495
    yes, it is 7.9.2. You might want to update it to the latest nightly.
    piCorePlayer a small player for the Raspberry Pi in RAM.
    Homepage: https://www.picoreplayer.org

    Please donate if you like the piCorePlayer

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •