Home of the Squeezebox™ & Transporter® network music players.
Results 1 to 8 of 8
  1. #1
    Senior Member
    Join Date
    Dec 2011
    Posts
    119

    Composers in All Artist List

    I'm in the process of trying to sort my artist tags and being confused (very easy to do!) as composers also appear in the all artist list.

    I can't find anywhere to stop this behaviour - is it possible to prevent composers being shown?

    I suspect that I may be missing something obvious but maybe not.

    Thanks

  2. #2
    Senior Member SpiderJon's Avatar
    Join Date
    Dec 2008
    Location
    Cardiff, Wales, UK
    Posts
    119
    Quote Originally Posted by steve-g View Post
    I'm in the process of trying to sort my artist tags and being confused (very easy to do!) as composers also appear in the all artist list.

    I can't find anywhere to stop this behaviour - is it possible to prevent composers being shown?

    I suspect that I may be missing something obvious but maybe not.

    Thanks

    In Settings > My Music, check whether the Composers box is ticked in the "Composer, Band and Orchestra in Artists" section.


    Name:  chrome_2019-10-26_12-41-16.jpg
Views: 67
Size:  39.1 KB

  3. #3
    Senior Member
    Join Date
    Jan 2009
    Posts
    155
    Quote Originally Posted by SpiderJon View Post
    In Settings > My Music, check whether the Composers box is ticked in the "Composer, Band and Orchestra in Artists" section.


    Name:  chrome_2019-10-26_12-41-16.jpg
Views: 67
Size:  39.1 KB
    In my setup, Composers box is not ticked.

    Assume Johannes Brahms is the Composer, and Radu Lupu is performing Piano Sonata No. 3.

    Composer tag = Brahms, Johannes
    Album tag = Piano Sonata No. 3 in F minor, Op. 5
    Artist tag = ?

    Is Artist tag = Radu Lupu, the Composer's name appears nowhere in the Now Playing screen of LMS or Orange Squeeze (or any other apps I've used).
    If Artist tag is left blank, "No Artist" appears on the Now Playing screen.

    Is there a solution?

  4. #4
    Senior Member
    Join Date
    Dec 2011
    Posts
    119
    I Don't see that option - this is what I get:
    Attached Images Attached Images  

  5. #5
    Senior Member
    Join Date
    Dec 2011
    Posts
    119
    Ah OK I see how to get it - and on that option composer is not ticked.

    Have tried with that option selected and it hasn't made any difference - still getting composers in the all artist list.

  6. #6
    Senior Member
    Join Date
    Jan 2010
    Location
    Hertfordshire
    Posts
    3,214
    Quote Originally Posted by steve-g View Post
    I'm in the process of trying to sort my artist tags and being confused (very easy to do!) as composers also appear in the all artist list.

    I can't find anywhere to stop this behaviour - is it possible to prevent composers being shown?

    I suspect that I may be missing something obvious but maybe not.

    Thanks
    Are you using two lists or a single configurable list of artists?

    Sent from my SM-G900F using Tapatalk

  7. #7
    Senior Member
    Join Date
    Dec 2011
    Posts
    119
    I was using two seperate lists - just trying single configurable list - while this does not include composers in the list it only seems to have Album artists.

    I have lots of compilation albums so have a lot of artists that don't have albums so a large number of artist don't appear in the single album list

    Would probably get used to a single list IF it showed all the artists.

  8. #8
    Senior Member
    Join Date
    Dec 2011
    Posts
    119
    Um - if I tick the "List compilation albums under each artist" option then the artist list shows all artists - not sure what effect this will have elsewhere though.

    I'll use it like this for a bit and see how I go..

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •