Home of the Squeezebox™ & Transporter® network music players.
Results 1 to 2 of 2
  1. #1
    Senior Member mr-b's Avatar
    Join Date
    Feb 2007
    Location
    UK
    Posts
    355

    LMS thinks audio files are deleted if remote library has been offline

    My system comprises a PCP and LMS running on a RPi with my library files stored on a Windows share.

    PCP was playing fine and then later a certain track wouldn't play. I saw that my PCP couldn't connect to the LMS (also running on the RPi) and so I rebooted it. I noted it flagged it couldn't mount the music library on my Windows server so I checked and it was offline for some reason. I restarted the server and it came back fine.

    Music files still wouldn't play so I checked the server.log:

    [19-10-13 20:52:51.7539] Slim::Formats::readTags (171) File missing: /mnt/music/In Crowd, The/The In Crowd - 2005 - His Majesty Is Coming/Disc 1/03 - Marcus Garvey's Back In Town (12' mix).flac
    [19-10-13 20:52:51.7723] Slim::Player::Protocols::File:pen (92) Warning: [file:///mnt/music/In%20Crowd,%20The/The%20In%20Crowd%20-%202005%20-%20His%20Majesty%20Is%20Coming/Disc%201/03%20-%20Marcus%20Garvey%27s%20Back%20In%20Town%20(12%27 %20mix).flac] not bothering opening file with zero size or duration
    [19-10-13 20:52:51.7748] Slim::Player::Song:pen (472) Warning: stream failed to open [file:///mnt/music/In%20Crowd,%20The/The%20In%20Crowd%20-%202005%20-%20His%20Majesty%20Is%20Coming/Disc%201/03%20-%20Marcus%20Garvey%27s%20Back%20In%20Town%20(12%27 %20mix).flac].

    Then I tried a Look for New media scan and saw that it was deleting a load of files!

    Server.log:

    [19-10-13 20:57:48.8751] main::main (205) Starting Logitech Media Server scanner (v7.9.2, 1558382969, Tue May 21 06:27:23 CEST 2019) perl 5.028000
    [19-10-13 20:57:49.2854] Slim::Schema::forceCommit (2147) Warning: Trying to commit transactions before DB is initialized!
    [19-10-13 20:57:49.5522] Slim::Music::Import::runImporter (511) Starting Slim::Media::MediaFolderScan scan
    [19-10-13 20:57:49.5530] Slim::Utils::Scanner::Local::rescan (181) Discovering audio files in /mnt/music
    [19-10-13 20:57:51.6163] Slim::Utils::Scanner::Local::__ANON__ (193) Start processing found tracks
    [19-10-13 20:57:51.6168] Slim::Utils::Scanner::Local::__ANON__ (201) Connect do DB
    [19-10-13 20:57:51.6173] Slim::Utils::Scanner::Local::__ANON__ (204) Get latest ID
    [19-10-13 20:57:51.6182] Slim::Utils::Scanner::Local::__ANON__ (226) Delete temporary table if exists
    [19-10-13 20:57:51.6186] Slim::Utils::Scanner::Local::__ANON__ (229) Re-build temporary table
    [19-10-13 20:57:52.8675] Slim::Utils::Scanner::Local::__ANON__ (278) Get deleted tracks count
    [19-10-13 20:57:53.6961] Slim::Utils::Scanner::Local::__ANON__ (285) Get new tracks count
    [19-10-13 20:57:53.6969] Slim::Utils::Scanner::Local::__ANON__ (290) Get changed tracks count
    [19-10-13 20:57:53.8942] Slim::Utils::Scanner::Local::__ANON__ (296) Removing deleted audio files (98730)
    [19-10-13 20:58:09.3557] Slim::Utils::Scanner::Local::deleted (703) Handling deleted cue sheet file:///mnt/music/808%20State/808/808%20State%20-%20Lift%20,%20Open%20Your%20Mind.cue
    [19-10-13 20:58:09.5079] Slim::Utils::Scanner::Local::deleted (828) Handling deleted file file:///mnt/music/808%20State/808/808%20State%20-%20Lift%20,%20Open%20Your%20Mind.flac
    [19-10-13 20:58:14.5663] Slim::Utils::Scanner::Local::deleted (703) Handling deleted cue sheet file:///mnt/music/A%20Place%20To%20Bury%20Strangers/A%20Place%20To%20Bury%20Strangers/2007%20-%20A%20Place%20To%20Bury%20Strangers%20[2008%20UK%20Edition]/A%20Place%20To%20Bury%20Strangers%20[UK%20Edition].cue
    [19-10-13 20:58:17.1031] Slim::Utils::Scanner::Local::deleted (703) Handling deleted cue sheet file:///mnt/music/A%20Place%20To%20Bury%20Strangers/A%20Place%20To%20Bury%20Strangers/2009%20-%20Exploding%20Head%20[2010%20Japan%20Release]/Exploding%20Head%20[2010%20Japan%20Release].cue

    So why does it think that all my audio files are deleted after the library has returned?
    Does the fact that it's gone offline once mean they are flagged for subsequent deletion, even if they subsequently come back?

  2. #2
    Senior Member mr-b's Avatar
    Join Date
    Feb 2007
    Location
    UK
    Posts
    355
    I've just noticed in the PCP LMS web ui that the network mount point is no longer ticked under Enabled.

    If I try to Set Mount it says:
    Disk Mount Error. Try to Reboot
    but a reboot still can't mount the drive, even though the share is visible.

    Hmm, Ok off I go to the PCP thread! ;-)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •