Home of the Squeezebox™ & Transporter® network music players.
Results 1 to 8 of 8
  1. #1
    Junior Member
    Join Date
    Sep 2019
    Posts
    9

    Problem is streaming m3u8 file from Logitech Squeezebox touch

    I listen to internet radio stations worldwide everyday on my Logitech Squeezebox touch (firmware 7.8.0-R16754) connected to LMS 7.9.2 on i-Mac OS10.5. I enter all radio stations URL in my favourite. All works perfectly except this URL https://aifmmobile.secureswiftconten...020-96000.m3u8. This is a radio station from Malaysia. I keep getting error -"No items found in playlist" after fetching track details...this URL works in VLC player.
    The LMS has HLS(v1.1) plugin installed and file type -ffmpeg selected. Can someone help please. Thank you.

  2. #2
    Senior Member
    Join Date
    Jan 2010
    Location
    Hertfordshire
    Posts
    3,120
    Quote Originally Posted by tongkhor View Post
    I listen to internet radio stations worldwide everyday on my Logitech Squeezebox touch (firmware 7.8.0-R16754) connected to LMS 7.9.2 on i-Mac OS10.5. I enter all radio stations URL in my favourite. All works perfectly except this URL https://aifmmobile.secureswiftconten...020-96000.m3u8. This is a radio station from Malaysia. I keep getting error -"No items found in playlist" after fetching track details...this URL works in VLC player.
    The LMS has HLS(v1.1) plugin installed and file type -ffmpeg selected. Can someone help please. Thank you.
    You asked the the same question already. Did you act on the previous answers?

    Sent from my SM-G900F using Tapatalk

  3. #3
    Junior Member
    Join Date
    Sep 2019
    Posts
    9
    I have installed PlayHLSv2.2 beta with the file type attached.
    Name:  Screen Shot 2019-10-14 at 5.14.01 PM.png
Views: 77
Size:  82.0 KB
    The LMS IO::Socket screen shot
    Name:  Screen Shot 2019-10-14 at 6.05.10 PM.jpg
Views: 79
Size:  61.0 KB

  4. #4
    Junior Member
    Join Date
    Sep 2019
    Posts
    9
    I have got the URL radio station working after months of trying and searching. Thank you very much for your help!

  5. #5
    Senior Member
    Join Date
    Oct 2005
    Location
    Ireland
    Posts
    17,816
    Quote Originally Posted by tongkhor View Post
    I have got the URL radio station working after months of trying and searching. Thank you very much for your help!
    I assume this measn the URL now plays OK.

    On a general note - you should update IO::Socket::SSL as version 1.966 was released in 2014 and is very out of date and does not support latest SSL/TLS security.

    PlayHLS 2.2 include some of the updated https stuff separate from LMS which may be part of the answer why the stream plays OK.

  6. #6
    Junior Member
    Join Date
    Sep 2019
    Posts
    9
    Quote Originally Posted by bpa View Post
    I assume this measn the URL now plays OK.

    On a general note - you should update IO::Socket::SSL as version 1.966 was released in 2014 and is very out of date and does not support latest SSL/TLS security.

    PlayHLS 2.2 include some of the updated https stuff separate from LMS which may be part of the answer why the stream plays OK.
    I think I have installed the IO-socket-ssl-2.066 in the I-Mac Terminal but do not know how to install it into LMS. The LMS still not updated. Computer and LMS were both re-started. This is a section of terminal screen.I am not sure if the upgrade is complete.

    cpan[3]> install IO::Socket::SSL
    Running install for module 'IO::Socket::SSL'
    Running make for S/SU/SULLR/IO-Socket-SSL-2.066.tar.gz
    Fetching with LWP:
    http://mirror.optusnet.com.au/CPAN/a...L-2.066.tar.gz
    Fetching with LWP:
    http://mirror.optusnet.com.au/CPAN/a...ULLR/CHECKSUMS
    Checksum for /Users/tongkhor-imac/.cpan/sources/authors/id/S/SU/SULLR/IO-Socket-SSL-2.066.tar.gz ok

    CPAN.pm: Building S/SU/SULLR/IO-Socket-SSL-2.066.tar.gz
    Appending installation info to /Users/tongkhor-imac/perl5/lib/perl5/darwin-thread-multi-2level/perllocal.pod
    SULLR/IO-Socket-SSL-2.066.tar.gz
    /usr/bin/make install -- OK

  7. #7
    Senior Member
    Join Date
    Oct 2005
    Location
    Ireland
    Posts
    17,816
    Quote Originally Posted by tongkhor View Post
    I think I have installed the IO-socket-ssl-2.066 in the I-Mac Terminal but do not know how to install it into LMS. The LMS still not updated. Computer and LMS were both re-started. This is a section of terminal screen.I am not sure if the upgrade is complete.
    I don't know for Mac system. The io::Sockets:SSL is a standard Perl module. Has the module been installed as local to a single user rather than as a system.

    On a Linux system - it usually means running CPAN under "root" to install the module for all users.

  8. #8
    Junior Member
    Join Date
    Sep 2019
    Posts
    9
    Quote Originally Posted by bpa View Post
    I don't know for Mac system. The io::Sockets:SSL is a standard Perl module. Has the module been installed as local to a single user rather than as a system.

    On a Linux system - it usually means running CPAN under "root" to install the module for all users.
    Hi bpa, I just upgraded the LMS which also upgraded IO-socket-ssl to 2.066. Thank you for pointing this.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •