Home of the Squeezebox™ & Transporter® network music players.
Page 5 of 9 FirstFirst ... 34567 ... LastLast
Results 41 to 50 of 86
  1. #41
    Junior Member
    Join Date
    Mar 2006
    Location
    Ireland
    Posts
    25
    After a few initial glitches mine is BAU, no problems running under Catalina.

    I deleted lots of applications that would no longer run under Catalina but I wasnĺt actually using them, apart from occasionally using MS Word, which I donĺt really miss.

    Nick

    Quote Originally Posted by Heliocentric View Post
    Catalina is by far my worst experience with Mac OS. This issue alone has resulted in my moving LMS over to a Raspberry Pi solution running the Max2Play software(LMS and Squeezelite in one box). Even after that, Disk Utility in Catalina destroyed a perfectly good micro SD Card on format and I've now regressed to Mojave just to have full functionality of my iMac. Ridiculous. On the other hand, The Raspberry Pi solution is pretty decent. Theres some latency issues while a hard drive spins up before an initial selection plays but other than that it's doable. The biggest issue is running two libraries and getting new music onto the LMS installation via network. It'll do for now. The Max2Play software(free) is new to me and I much prefer it to DietPi. Once you find the IP address you can log in and set it up remotely(super nice).
    --
    Hobby Electronicist
    Unix Fiddler
    Biker

  2. #42
    Junior Member
    Join Date
    Jul 2008
    Location
    Not Canada
    Posts
    11
    My situation:

    - Have just upgraded to Catalina
    - Source music library is on a NAS
    - Library scans fail, and after a "Clear library and rescan everything" I am left with an empty LMS library
    - LMS itself seems to be operating normally, eg able to play internet radio, and LMS UI if fine, just no music in the LMS library
    - From scanner log:
    [9-10-31 18:59:41.4219] Slim::Music::Import::runImporter (511) Starting Slim::Media::MediaFolderScan scan
    [19-10-31 18:59:41.4225] Slim::Utils::Scanner::Local::rescan (181) Discovering audio files in /Volumes/XXXXXXX/iTunes Media
    [19-10-31 18:59:41.4756] Slim::Utils::Scanner::Local::Async::__ANON__ (71) Error scanning file or folder: /Volumes/XXXXXXX/iTunes Media: Operation not permitted

    The error scanning the NAS volume would seem to be, based on the conversation in this thread, a permissions issue. Posts in the thread indicate it is resolved by allowing perl to have "Full Disk Access". Furthermore, a post indicates that "Applications will dynamically appear in the Full Disk Access pane as LMS goes through its processes."

    BUT: I have not been able to get perl to "dynamically appear" in the Full Disk Access pane, or find any other way to assign perl Full Disk Access. (For example I have tried having System Preference open to that pane, with the pane unlocked, and running a rescan in the web UI, but no sign of perl dynamically appearing.)

    Can anyone inform me how to give perl Full Disk Access based on my situation.

    Thanks in advance.
    Andy
    Mac Mini -> Duet -> Mojo -> Nait XS -> LS50s

  3. #43
    Senior Member
    Join Date
    May 2005
    Location
    In a house
    Posts
    1,771
    Quote Originally Posted by adm View Post
    My situation:

    - Have just upgraded to Catalina
    - Source music library is on a NAS
    - Library scans fail, and after a "Clear library and rescan everything" I am left with an empty LMS library

    ...

    The error scanning the NAS volume would seem to be, based on the conversation in this thread, a permissions issue. Posts in the thread indicate it is resolved by allowing perl to have "Full Disk Access". Furthermore, a post indicates that "Applications will dynamically appear in the Full Disk Access pane as LMS goes through its processes."

    BUT: I have not been able to get perl to "dynamically appear" in the Full Disk Access pane, or find any other way to assign perl Full Disk Access. (For example I have tried having System Preference open to that pane, with the pane unlocked, and running a rescan in the web UI, but no sign of perl dynamically appearing.)

    Can anyone inform me how to give perl Full Disk Access based on my situation.

    Thanks in advance.
    When you go to the web interface, Settings, and on the first page, for your Media Folders, click the Browse button, you should see various expandable file system locations. If you cannot expand one of them (because there's no + character), this shows you that you don't have full disk access for the given area. This is a quick way for you to test as you're working to get permissions to work.

    Go to System Preferences > Security & Privacy > Full Disk Access, and unlock the settings. Click the + button. Now type Cmd+Shift+G. This will open a dialog where you can type a path. Enter /usr/bin and then select perl to add it. Do likewise for /bin and select bash.

    I don't recall if I had to start/stop the server after this, but certain need to hard refresh that LMS server Settings page. After I configured the settings, I was able to then assign my paths and LMS worked.

  4. #44
    Junior Member
    Join Date
    Jul 2008
    Location
    Not Canada
    Posts
    11
    MrC, that did it. The tip on how to get to the locations for bash and perl was what I was missing. Many thanks!
    Andy
    Mac Mini -> Duet -> Mojo -> Nait XS -> LS50s

  5. #45
    Senior Member dborod's Avatar
    Join Date
    Nov 2008
    Location
    Canada
    Posts
    147
    Hi, not to refute or detract from anyone's experiences or issues, but I just upgraded my Mac to from 10.14.6 to 10.15.1 and my LMS 7.9.2 seems to be working fine. I have all my music on an external drive connected to my Mac.

  6. #46
    Senior Member
    Join Date
    Dec 2006
    Posts
    671
    Quote Originally Posted by MrC View Post
    When you go to the web interface, Settings, and on the first page, for your Media Folders, click the Browse button, you should see various expandable file system locations. If you cannot expand one of them (because there's no + character), this shows you that you don't have full disk access for the given area. This is a quick way for you to test as you're working to get permissions to work.

    Go to System Preferences > Security & Privacy > Full Disk Access, and unlock the settings. Click the + button. Now type Cmd+Shift+G. This will open a dialog where you can type a path. Enter /usr/bin and then select perl to add it. Do likewise for /bin and select bash.

    I don't recall if I had to start/stop the server after this, but certain need to hard refresh that LMS server Settings page. After I configured the settings, I was able to then assign my paths and LMS worked.
    Thank you!! Just had to pop in here (very frustrated) to see if there was a resolution. Thanks man, you saved the day

  7. #47
    Babelfish's Best Boy mherger's Avatar
    Join Date
    Apr 2005
    Location
    Switzerland
    Posts
    20,355

    LMS on MacOS 10.15 "Catalina"?

    > Go to System Preferences > Security & Privacy > Full Disk Access, and
    > unlock the settings. Click the + button. Now type Cmd+Shift+G. This
    > will open a dialog where you can type a path. Enter /usr/bin and then
    > select perl to add it. Do likewise for /bin and select bash.

    I still can't reproduce this... I don't remember ever having seen this
    prompt. And even checking above settings I don't see neither Perl nor
    bash. What comes closest is terminal. I removed all rights from
    Terminal. Alas, LMS is still working, no questions asked...

    Would anybody know how I can trigger this prompt from a shell command or
    the terminal?

    --
    --

    Michael

  8. #48
    Senior Member
    Join Date
    Dec 2006
    Posts
    671
    Quote Originally Posted by mherger View Post

    Would anybody know how I can trigger this prompt from a shell command or
    the terminal?

    --
    --

    Michael
    To be clear: you want to reproduce the "no library" situation that we're experiencing? Basically, LMS can't access external volumes in order to scan the library. It can see the drive, but can't access any folders. Even if you manually type the path to your music or playlists folder (e.g. /Volumes/ExternalDrive/Music), the scan picks up nothing.

  9. #49
    Babelfish's Best Boy mherger's Avatar
    Join Date
    Apr 2005
    Location
    Switzerland
    Posts
    20,355

    LMS on MacOS 10.15 "Catalina"?

    > To be clear: you want to reproduce the "no library" situation that we're
    > experiencing?


    Yes. I'd like to figure out whether there was a way to make macOS bring
    up the "allow access?" prompt programmatically. I was wondering whether
    I don't see it because I had been running early betas already.

    > Basically, LMS can't access external volumes in order to
    > scan the library. It can see the drive, but can't access any folders.


    What about standard folders like Music, Documents etc.? Would you see
    the same behaviour there?

    --

    Michael

  10. #50
    Babelfish's Best Boy mherger's Avatar
    Join Date
    Apr 2005
    Location
    Switzerland
    Posts
    20,355

    LMS on MacOS 10.15 "Catalina"?

    > Yes. I'd like to figure out whether there was a way to make macOS bring
    > up the "allow access?" prompt programmatically. I was wondering whether
    > I don't see it because I had been running early betas already.


    Ok, I got something. Found a command to reset all those settings. But
    things are complicated... depending on how LMS got started, the
    application requesting permissions would vary - if it asked at all.

    - when asked right after installation, the prompt would ask whether
    you'd like to give the installer permission to access a network drive or
    whatever. But as soon as you restarted LMS that would no longer work, as
    the installer would no longer be the "owner" of the process.

    - when started from the control panel, the owner would be bash (or sh in
    older versions of LMS). Alas, these tools seem to not ask for permission.

    - when started automatically at system startup, the launch item would
    launch slimserver.pl directly, rather than the helper script used by the
    control panel. That's why you'll need to give the perl executable full
    access. But like bash it's not asking for it...

    - I'm mostly running LMS from the terminal, as I'm only developing on
    Mac. That's why I never was asked for permissions: the first time I
    launched the terminal I was asked for full disk access. LMS would
    inherit these, as it's owned by the terminal.

    Which means I'll have to find a way how to trigger the prompt from a
    running LMS, no matter how it's been started... Wish me luck with that!
    --

    Michael

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •