Home of the Squeezebox™ & Transporter® network music players.
Page 12 of 13 FirstFirst ... 210111213 LastLast
Results 111 to 120 of 124
  1. #111
    Junior Member
    Join Date
    Sep 2020
    Posts
    4

    Post #107 solved

    Thank you, following the steps below (for perl5.28) solved my problem described in post #107.
    After reboot, everything continues to be fine.
    Thank you!



    Quote Originally Posted by sgmlaw View Post
    I had been hobbling along with an old build for about two months, because of the multiple perl permissions issues. The old build was running fine, so I just ignored it.

    But D&D perl5.18 into Full Disk Access solved this for me as well.

    The trick is you have to do it from Finder, and not from the System Pref pane, as the latter does not allow you to access system/protected files for some reason.

    Those protected files can be accessed via a standard Finder pane, by using the (Cmd + Shift + . (dot)) command.

    Then it's a simple D&D into Full Disk Access and a system restart.

    ...

    I must say, running LMS on a Mac in 2020 is increasingly a labor of love. Like running a steeplechase race.

    Once Big Sur hits, I'm sure we'll have a new thread and new set of obstacles and closed doors to navigate.

  2. #112
    Junior Member
    Join Date
    Oct 2011
    Posts
    10

    Has the missing iTunes .XML file issue been resolved?

    Hi there,

    Having just upgraded my OS to Catalina, I now am facing the same problem that LMS can no longer read my music library. I see this message in the log:

    Error: Failed when running main scan: [Couldn't open /Volumes/External SSD/iTunes/iTunes Library.xml

    I was so hoping when I granted Full Disk Access to perl my problems would be resolved. The file does exist so is this the problem of LMS not recognizing the external drive and the need for the symbolic link? I did download the Symbolic Linker app, created the symbolic link pointing to the iTunes folder on the external drive (/Volumes/External SSD/iTunes). Next question is, where do I put the link? I put under /Mac HD/users/smrowat and tried to point LMS to that. Here's what's in the log:

    [20-11-28 12:12:26.4295] Slim::Utils::Scanner::Local::rescan (179) Discovering audio files in /Volumes/Macintosh HD/Users/smrowat/iTunes symlink
    [20-11-28 12:12:26.4325] Slim::Utils::Scanner::Local::Async::__ANON__ (70) Error scanning file or folder: /Volumes/Macintosh HD/Users/smrowat/iTunes symlink: Operation not permitted
    and later:

    [20-11-28 12:12:26.4408] Slim::Utils::Scanner::Local::rescan (179) Discovering audio files in /Volumes/External SSD/iTunes/iTunes Media/Music
    [20-11-28 12:12:26.4420] Slim::Utils::Scanner::Local::Async::__ANON__ (70) Error scanning file or folder: /Volumes/External SSD/iTunes/iTunes Media/Music: Operation not permitted

    I'm running Logitech Media Server Version: 8.0.0.

    Thanks,

    sr
    Last edited by catosmr; 2020-11-28 at 10:15.

  3. #113
    I'm also on 10.15.7 mac os and while my LMS sees all my music from the new music app location it fails to find my playlists although they appear in the Music application. I was running LMS 7.9 and tried to follow the steps others have taken; I gave perl and bash full disk access along with 5.18 but same results. Everything is ok except the playlists. I tried disabling the iTunes plugin but that made no difference. I got a couple of fatal errors in LMS about two instances of LMS running in the system but that seems to have cleared up. I created a library export from the Music app which creates an xml file which I placed in the Music folder, rescanned but no change other than the scan say there are over 2 thousand playlists (when in fact there are 196) but still shows no playlists. So I'm at a loss. I feel like an english major in a crowd of pre med students, expected to know more than I reasonably could. Been a user since my first classic squeezbox in the early 2000's, which died only a couple of months ago and was replaced a Touch. If anyone has any insight or clarification to my issue please don't hesitate to respond.

  4. #114
    Senior Member
    Join Date
    Apr 2005
    Location
    UK/London
    Posts
    3,336
    The scanner.log showing it processing the "iTunes" export file could be useful.
    Many here do not have MACs so relies heavily on guesswork.
    Paul Webster
    http://dabdig.blogspot.com
    Author of "Now Playing" plugins covering Radio France (FIP etc), KCRW, Supla Finland, ABC Australia, CBC/Radio-Canada and RTE Ireland

  5. #115
    Quote Originally Posted by Paul Webster View Post
    The scanner.log showing it processing the "iTunes" export file could be useful.
    Many here do not have MACs so relies heavily on guesswork.
    I placed the newly created xml fie in the music library and ran a scan. Here is what the results were.
    Discovering files/directories: /Users/leotracy/Music (9138 of 9138) Complete 00:00:01

    Scanning new music files: /Users/leotracy/Music (6840 of 6840) Complete 00:00:15

    Discovering playlists: /Users/leotracy/Music (2298 of 2298) Complete 00:00:00

    Building full text index (7 of 7) Complete 00:00:02

    Pre-caching Artwork (1247 of 1247) Complete 00:00:22

    Database Optimize (2 of 2) Complete 00:00:00

    The server has finished scanning your media library.
    Total Time: 00:00:40 (Sunday, November 29, 2020 / 1:05 PM)

    There are no playlists when i use the web interface, ipeng, or on the touch. I moved the xml file to the playlist folder under music, re ran scan and got this.
    Media Scan Details
    Discovering files/directories: /Users/leotracy/Music (9138 of 9138) Complete 00:00:01

    Discovering playlists: /Users/leotracy/Music/Playlists (1 of 1) Complete 00:00:00

    Building full text index (7 of 7) Complete 00:00:02

    Find updated coverart files (210 of 210) Complete 00:00:00

    Pre-caching Artwork (33 of 33) Complete 00:00:01

    Database Optimize (2 of 2) Complete 00:00:00

    The server has finished scanning your media library.
    Total Time: 00:00:04 (Sunday, November 29, 2020 / 1:09 PM)

    note the 1 playlist.LMS seems to not be able to find or interpret the playlists. I have an original setup running lms 7.9 and el capitan. When i hit remote music library from the web interface i find my original library on the other machine and it loads the playlist successfully.
    When i try the same from the older machine I find the new library with empty playlist. I'm currently playing music from the old set up so I'm open to any ideas on my new imac running catalina.

    here is part of the scanner log
    [20-11-29 13:09:22.8407] Slim::Music::Import::endImporter (709) Completed Slim::Media::MediaFolderScan Scan in 0 seconds.
    [20-11-29 13:09:22.8411] Slim::Music::Import::runImporter (577) Starting Slim::Music::PlaylistFolderScan scan
    [20-11-29 13:09:22.8412] Slim::Utils::Scanner::Local::rescan (179) Discovering audio files in /Users/leotracy/Music/Playlists
    [20-11-29 13:09:22.8482] Slim::Utils::Scanner::Local::__ANON__ (191) Start processing found tracks
    [20-11-29 13:09:22.8483] Slim::Utils::Scanner::Local::__ANON__ (199) Connect do DB
    [20-11-29 13:09:22.8484] Slim::Utils::Scanner::Local::__ANON__ (202) Get latest ID
    [20-11-29 13:09:22.8485] Slim::Utils::Scanner::Local::__ANON__ (224) Delete temporary table if exists
    [20-11-29 13:09:22.8487] Slim::Utils::Scanner::Local::__ANON__ (227) Re-build temporary table
    [20-11-29 13:09:22.8607] Slim::Utils::Scanner::Local::__ANON__ (276) Get deleted tracks count
    [20-11-29 13:09:22.8790] Slim::Utils::Scanner::Local::__ANON__ (283) Get new tracks count
    [20-11-29 13:09:22.8792] Slim::Utils::Scanner::Local::__ANON__ (288) Get changed tracks count
    [20-11-29 13:09:22.8794] Slim::Utils::Scanner::Local::deleteTracks (519) Removing deleted audio files (0)
    [20-11-29 13:09:22.8794] Slim::Utils::Scanner::Local::__ANON__ (301) Scanning new audio files (0)
    Last edited by leeper; 2020-11-29 at 11:29. Reason: additional info

  6. #116
    Senior Member
    Join Date
    Apr 2005
    Location
    UK/London
    Posts
    3,336
    I don't use iTunes - but I have just installed the iTunes Importer plugin and can see that there are a number of settings - including one that tells LMS where the exported iTunes XMl file is located.


    iTunes Music Library.xml Location
    iTunes Media Folder
    iTunes Playlist Format - Prefix/Suffix

    Plus an enabled/disabled setting at the top of the page (Use Itunes).

    How are they set in your system and do they look correct?
    Paul Webster
    http://dabdig.blogspot.com
    Author of "Now Playing" plugins covering Radio France (FIP etc), KCRW, Supla Finland, ABC Australia, CBC/Radio-Canada and RTE Ireland

  7. #117
    [QUOTE=Paul Webster;996929]I don't use iTunes - but I have just installed the iTunes Importer plugin and can see that there are a number of settings - including one that tells LMS where the exported iTunes XMl file is located.


    iTunes Music Library.xml Location
    iTunes Media Folder
    iTunes Playlist Format - Prefix/Suffix

    Plus an enabled/disabled setting at the top of the page (Use Itunes).

    How are they set in your system and do they look correct?[/QUOTE

    They were blank when I disabled iTunes and after reenabling I entered the Music Library location as the home for the XML file. That didn't fix the issue. Thanks Paul though, you made me look harder at the browse button and I see that I can enter the XML file itself which I had placed in the playlist folder and low and behold all the playlists are now appearing. The only issue is that each time I change an existing playlist I will have to recreate the xml file and rescan. Not terrible, but not great. But thank you Paul, I was feeling a bit abandoned. I really appreciate you taking the time.

  8. #118
    Senior Member
    Join Date
    Apr 2005
    Location
    UK/London
    Posts
    3,336
    Good news.

    I remember looking into automating the export a while back and ai think I found a way to do it and I wrote about it in the forum ... not sure where though.
    I expect it would have been around the time that iTunes was replaced by Music.
    Paul Webster
    http://dabdig.blogspot.com
    Author of "Now Playing" plugins covering Radio France (FIP etc), KCRW, Supla Finland, ABC Australia, CBC/Radio-Canada and RTE Ireland

  9. #119
    Quote Originally Posted by Paul Webster View Post
    Good news.

    I remember looking into automating the export a while back and ai think I found a way to do it and I wrote about it in the forum ... not sure where though.
    I expect it would have been around the time that iTunes was replaced by Music.
    I will look for it but shouldn't LMS be able to extract the xml file and update during a scan? In any event, thanks again. L

  10. #120
    Senior Member
    Join Date
    Apr 2005
    Location
    UK/London
    Posts
    3,336
    There is no XML file until Music exports it.

    What I saw before was related to scripting things ... so I had another look and found this
    https://macscripter.net/viewtopic.php?pid=201433

    My guess is that a Mac specialist (probably in a Mac forum) would be able to help tweak/simplify things since if it can be made to export in the iTunes XML format then it will still work with LMS.
    Paul Webster
    http://dabdig.blogspot.com
    Author of "Now Playing" plugins covering Radio France (FIP etc), KCRW, Supla Finland, ABC Australia, CBC/Radio-Canada and RTE Ireland

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •