Home of the Squeezebox™ & Transporter® network music players.
Page 96 of 98 FirstFirst ... 46869495969798 LastLast
Results 951 to 960 of 980
  1. #951
    Senior Member philchillbill's Avatar
    Join Date
    Jan 2019
    Location
    The Netherlands
    Posts
    728
    Some recent changes I made under the hood to the matching of player names are so successful that I've taken out the warnings about weird player names. Basically, you can now use any player names you like

  2. #952
    Senior Member
    Join Date
    Apr 2005
    Location
    UK/London
    Posts
    4,430
    Now there is a challenge
    Paul Webster
    http://dabdig.blogspot.com
    Author of "Now Playing" plugins covering Radio France (FIP etc), PlanetRadio (Bauer - Kiss, Absolute, Scala, JazzFM etc), KCRW, Supla Finland, ABC Australia, CBC/Radio-Canada and RTE Ireland

  3. #953
    Senior Member philchillbill's Avatar
    Join Date
    Jan 2019
    Location
    The Netherlands
    Posts
    728
    I noticed in the logs that somebody yesterday afternoon was having issues with playing a V.A. called 'Rip it Up' due to a mismatch of the album/compilation/single concept when asked if you want to play an alternative to the not-found spec.

    That's now fixed.

    BTW, I've also added a check in the handler for AMAZON.FallbackIntent (this triggers when you say something that makes no sense at all to the skill) to see if your Echo has a screen - if it does then the Example Commands screen is automatically shown as an aid.

  4. #954
    Senior Member
    Join Date
    Aug 2006
    Posts
    243

    No audio from FLAC streams on echo stereo pair

    Has anyone successfully direct streamed FLAC URL's (e.g. Radio Paradise) to 2 echoes plus a bass unit paired for stereo play back? The echoes announce that they are direct streaming, but no audio ensues. FLAC streams work fine on a variety of other echo devices (Thanks, Phil!) and MP3 streams also proceed normally on the stereo echoes. Any thoughts?...

  5. #955
    Senior Member philchillbill's Avatar
    Join Date
    Jan 2019
    Location
    The Netherlands
    Posts
    728
    Quote Originally Posted by raglencross View Post
    Has anyone successfully direct streamed FLAC URL's (e.g. Radio Paradise) to 2 echoes plus a bass unit paired for stereo play back? The echoes announce that they are direct streaming, but no audio ensues. FLAC streams work fine on a variety of other echo devices (Thanks, Phil!) and MP3 streams also proceed normally on the stereo echoes. Any thoughts?...
    Does any other audio from MediaServer (e.g. from LMS or a lossy stream) play on that setup? My guess is that the combo-Echo has a different deviceID to where I'm directing the stream.

  6. #956
    Senior Member philchillbill's Avatar
    Join Date
    Jan 2019
    Location
    The Netherlands
    Posts
    728
    I've been playing around in my beta with more relaxed intents where you can (initially) leave out some parameters that are currently always required.

    Take PlayAlbum as an example. Currently, you must always specify both the {Album} name and the desired {Artist}. If you leave out the artist and just mention the album name, Alexa will always ask for the artist. That makes sense for 'Greatest Hits' because you probably have many of those and the artist name is needed to filter down. But what of an album like 'Phaedra' or 'Dark side of the Moon', where it's very likely the artist is TD or Pink Floyd? You might have several versions of DSOTM but they are all by Floyd.

    What I've toyed with is checking for a match when you only specify {Album} on its own:

    * If there is just one hit, it plays and you are told who the matched artist was.
    * If there are several hits and they are all by the same artist, the best fuzzy match (usually shortest) of the album name plays and you are told who the artist is. If you had wanted one of the other variants such as e.g. Vinyl / Live / Remastered, you could have specified that along with the album name originally - e.g. 'DSOTM Vinyl' - and then that would play instead of plain DSOTM.
    * If there are several hits and also several artists the query matches, you are asked "... By what artist is that?" and the command re-runs with the included artist name in the search.

    This needs a voice-model change and thus recertification, so I may as well include a few other community desires before submitting and get it all done in one whack.

    Where else is this type of relaxation desirable? PlaySong, I guess? What else?
    Last edited by philchillbill; 2021-06-02 at 11:10.

  7. #957
    Senior Member
    Join Date
    Aug 2006
    Posts
    243
    Quote Originally Posted by philchillbill View Post
    Does any other audio from MediaServer (e.g. from LMS or a lossy stream) play on that setup? My guess is that the combo-Echo has a different deviceID to where I'm directing the stream.
    The stereo pair stream everything except lossless streams.

  8. #958
    Senior Member philchillbill's Avatar
    Join Date
    Jan 2019
    Location
    The Netherlands
    Posts
    728
    Quote Originally Posted by raglencross View Post
    The stereo pair stream everything except lossless streams.
    There are no errors or other clues in the logs so it must just be an Amazon quirk.

  9. #959
    Senior Member
    Join Date
    Aug 2006
    Posts
    243
    Yeah, like about a year or so ago only a few of the big services would stream in stereo then without anyone doing anything apps like yours, Plex and Mymedia started to work in stereo. Perhaps we will be as lucky with lossless streams in due course...

  10. #960
    Senior Member philchillbill's Avatar
    Join Date
    Jan 2019
    Location
    The Netherlands
    Posts
    728
    Under the hood, matching against tags with diacritics has been improved - some stuff was being filtered away that should not have been

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •