Home of the Squeezebox™ & Transporter® network music players.
Page 14 of 48 FirstFirst ... 4121314151624 ... LastLast
Results 131 to 140 of 473
  1. #131
    Senior Member
    Join Date
    Feb 2008
    Posts
    4,776
    Quote Originally Posted by Paul Webster View Post
    Great.
    I must have a go at this as well (I found the solution to your problem by searching as I don't have ngrok here yet).
    Not sure how useful it is for dummy users like me! I tried it just to see what it does.

    philchillbill's instructions for ngrok are very useful - the disown command is very useful as you can logout from the terminal..

    I was confused about the LMS user and password required on the linking page in Alexa until I discovered from an earlier post that this is where you enter your ngrok login data (not LMS info).
    LMS server: Pi Zero

    Amp: Denon PMA-50

    Players/Speakers: Touch, Logitech Radios, Sonos Play 1s & Beam, Libratone Zipp, GGMM E2 & E3, Yamaha WXAD-010, Loewe Airspeaker, Google Chromecast Audio, Home Mini & Nest Hub, Amazon Echo 2,3 and Show5, Pioneer WX-SMA1, Roberts S1, O2 Joggler, Cisco Joggler, Avantree Priva BT transmitter

    Brexit = ∞ stupidity


    ------------------------------------------------------------------------------------

  2. #132
    Senior Member
    Join Date
    Apr 2005
    Location
    UK/London
    Posts
    2,014
    Correct ... because if you do not set ngrok password then anyone who happens to discover your public IP address could mess around with your LMS.
    Paul Webster
    http://dabdig.blogspot.com
    Author Radio France (FIP etc) plugin

  3. #133
    Senior Member
    Join Date
    Feb 2008
    Posts
    4,776
    Quote Originally Posted by Paul Webster View Post
    Correct ... because if you do not set ngrok password then anyone who happens to discover your public IP address could mess around with your LMS.
    I assume that ngrok is pretty secure. I started out with serveo - I noticed there some weird connections from an address which seemed to be a bot ... not long after I had a total crash on my linux PC which came out of the blue. Had to reinstall the whole system again to get back up and running.

    I dragged out an older unused pi and installed rabian lite and ngrok - so far so good with ngrok pointing at LMS on a pi zero.
    LMS server: Pi Zero

    Amp: Denon PMA-50

    Players/Speakers: Touch, Logitech Radios, Sonos Play 1s & Beam, Libratone Zipp, GGMM E2 & E3, Yamaha WXAD-010, Loewe Airspeaker, Google Chromecast Audio, Home Mini & Nest Hub, Amazon Echo 2,3 and Show5, Pioneer WX-SMA1, Roberts S1, O2 Joggler, Cisco Joggler, Avantree Priva BT transmitter

    Brexit = ∞ stupidity


    ------------------------------------------------------------------------------------

  4. #134
    Senior Member philchillbill's Avatar
    Join Date
    Jan 2019
    Location
    The Netherlands
    Posts
    246

    [Announce] 'MediaServer' *certified* Alexa skill for LMS

    Quote Originally Posted by castalla;
    I was confused about the LMS user and password required on the linking page in Alexa until I discovered from an earlier post that this is where you enter your ngrok login data (not LMS info).
    Yes, if you use ngrok then you enter your ngrok auth details there. But if you use a roll your own proxy then whatever basic auth you’re using would be entered in those same fields. They’re not ngrok specific which is why they are not labeled that way. I used LMS in the text placeholder so people would not think they had to enter some account-creation details in there to create an account with smartskills.tech. You’d be surprised what I’ve seen in the logs so far, including people trying a local IP address and just changing http to https to pass form validation. Doesn’t work, of course, but it shows how some people simply don’t read instructions.
    Last edited by philchillbill; 2019-10-13 at 02:13.

  5. #135
    Senior Member
    Join Date
    Feb 2008
    Posts
    4,776
    Quote Originally Posted by philchillbill View Post
    Yes, if you use ngrok then you enter your ngrok auth details there. But if you use a roll your own proxy then whatever basic auth you’re using would be entered in those same fields. They’re not ngrok specific which is why they are not labeled that way. I used LMS in the text placeholder so people would not think they had to enter some account-creation details in there to create an account with smartskills.tech. You’d be surprised what I’ve seen in the logs so far, including people trying a local IP address and just changing http to https to pass form validation. Doesn’t work, of course, but it shows how some people simply don’t read instructions.
    Thanks.

    Maybe a note in your ngrok instructions could point out this?
    LMS server: Pi Zero

    Amp: Denon PMA-50

    Players/Speakers: Touch, Logitech Radios, Sonos Play 1s & Beam, Libratone Zipp, GGMM E2 & E3, Yamaha WXAD-010, Loewe Airspeaker, Google Chromecast Audio, Home Mini & Nest Hub, Amazon Echo 2,3 and Show5, Pioneer WX-SMA1, Roberts S1, O2 Joggler, Cisco Joggler, Avantree Priva BT transmitter

    Brexit = ∞ stupidity


    ------------------------------------------------------------------------------------

  6. #136
    Senior Member philchillbill's Avatar
    Join Date
    Jan 2019
    Location
    The Netherlands
    Posts
    246
    It’s already there:

    ... Fill in the username and password you specified for the -auth switch.

  7. #137
    Senior Member
    Join Date
    Feb 2008
    Posts
    4,776
    Quote Originally Posted by philchillbill View Post
    It’s already there:

    ... Fill in the username and password you specified for the -auth switch.
    Ooops.

    Oh dear - what was that you said about people not reading the instructions?!
    LMS server: Pi Zero

    Amp: Denon PMA-50

    Players/Speakers: Touch, Logitech Radios, Sonos Play 1s & Beam, Libratone Zipp, GGMM E2 & E3, Yamaha WXAD-010, Loewe Airspeaker, Google Chromecast Audio, Home Mini & Nest Hub, Amazon Echo 2,3 and Show5, Pioneer WX-SMA1, Roberts S1, O2 Joggler, Cisco Joggler, Avantree Priva BT transmitter

    Brexit = ∞ stupidity


    ------------------------------------------------------------------------------------

  8. #138
    Senior Member philchillbill's Avatar
    Join Date
    Jan 2019
    Location
    The Netherlands
    Posts
    246
    If you want to autostart ngrok when your system boots, this will explain the steps involved. It's been added to the online help too.

    Sign in to your (free) ngrok account from a browser and note the authtoken that appears on your dashboard. Next, at a command prompt on your ngrok host machine, type:

    ngrok authtoken YOUR_AUTHTOKEN

    This will have created a file called ngrok.yml in a hidden folder .ngrok2 in your home directory (e.g. /home/pi if on raspbian). Edit that file using e.g. nano ~/.ngrok2/ngrok.yml so that it looks as follows (note the indentation is required):

    Code:
    authtoken: 6hR173iJMYTfypshaexbe_8xgopkz39Cx2aqkz4Z7OT  <-- your authtoken
    web_addr: 0.0.0.0:4040
    inspect: false
    region: eu
    tunnels:
      mediaserver:
        proto: http
        addr: 192.168.1.10:9000
        auth: "username:password"
    Explanation: 'web_addr' allows you to use a browser to check the configuration from any machine in your local network, not just from localhost; 'inspect' when set to false reduces logging and increases responsiveness once you're all set up; 'region' defaults to 'us' if you don't override it to e.g. eu. The 'tunnels' command allows us to pre-define the parameters for a tunnel so that it can then be started using the start command — the addr and auth should match your particular setup.

    Now, we need to create the config file needed to start ngrok as a service. Type the command sudo nano /etc/systemd/system/ngrok.service and give it the following content:

    Code:
    [Unit]
      Description=ngrok autostart 
      Wants=network.target 
      After=network.target
    
    [Service]
      Type=simple 
      WorkingDirectory=/tmp 
      ExecStart=/usr/local/bin/ngrok start -config=/home/pi/.ngrok2/ngrok.yml mediaserver
      RestartSec=30
      StandardOutput=syslog
      StandardError=syslog
      SyslogIdentifier=ngrok
    
    [Install]
      WantedBy=multi-user.target
    With that file successfully created, type:

    sudo systemctl daemon-reload
    sudo systemctl enable ngrok
    sudo systemctl start ngrok


    If all is well, ngrok is now running as a service. You can check its status using sudo systemctl status ngrok and — more importantly — from any machine in your local network, you can watch what ngrok is doing by browsing to the IP address of the ngrok host machine on port 4040, e.g. http://192.168.1.1:4040. The status tab there will show you the ngrok subdomain you were assigned and which you will use in linking the skill. If you reboot the ngrok pi, just revisit that web page to see the newly-assigned subdomain for re-linking the skill.

  9. #139
    Senior Member
    Join Date
    Jan 2010
    Location
    Hertfordshire
    Posts
    3,529
    Apparently using skills in routines will be available soon (at last). I am looking forward to being able to stop playback and turn off my amplifier at the same time.

    Sent from my SM-G900F using Tapatalk

  10. #140
    Senior Member
    Join Date
    Feb 2008
    Posts
    4,776
    Quote Originally Posted by philchillbill View Post
    If you want to autostart ngrok when your system boots, this will explain the steps involved. It's been added to the online help too.

    Sign in to your (free) ngrok account from a browser and note the authtoken that appears on your dashboard. Next, at a command prompt on your ngrok host machine, type:

    ngrok authtoken YOUR_AUTHTOKEN

    This will have created a file called ngrok.yml in a hidden folder .ngrok2 in your home directory (e.g. /home/pi if on raspbian). Edit that file using e.g. nano ~/.ngrok2/ngrok.yml so that it looks as follows (note the indentation is required):

    Code:
    authtoken: 6hR173iJMYTfypshaexbe_8xgopkz39Cx2aqkz4Z7OT  <-- your authtoken
    web_addr: 0.0.0.0:4040
    inspect: false
    region: eu
    tunnels:
      mediaserver:
        proto: http
        addr: 192.168.1.10:9000
        auth: "username:password"
    Explanation: 'web_addr' allows you to use a browser to check the configuration from any machine in your local network, not just from localhost; 'inspect' when set to false reduces logging and increases responsiveness once you're all set up; 'region' defaults to 'us' if you don't override it to e.g. eu. The 'tunnels' command allows us to pre-define the parameters for a tunnel so that it can then be started using the start command — the addr and auth should match your particular setup.
    l.
    Before setting up the service, I wanted to try the changed config. What command should I use to start ngrok using the new config. I tried the command line in your instructions but this went into a display page in the terminal which I couldn't disown.
    LMS server: Pi Zero

    Amp: Denon PMA-50

    Players/Speakers: Touch, Logitech Radios, Sonos Play 1s & Beam, Libratone Zipp, GGMM E2 & E3, Yamaha WXAD-010, Loewe Airspeaker, Google Chromecast Audio, Home Mini & Nest Hub, Amazon Echo 2,3 and Show5, Pioneer WX-SMA1, Roberts S1, O2 Joggler, Cisco Joggler, Avantree Priva BT transmitter

    Brexit = ∞ stupidity


    ------------------------------------------------------------------------------------

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •