Home of the Squeezebox™ & Transporter® network music players.
Page 32 of 90 FirstFirst ... 2230313233344282 ... LastLast
Results 311 to 320 of 891
  1. #311
    Senior Member
    Join Date
    Feb 2011
    Location
    Cheshire, UK
    Posts
    5,510
    Quote Originally Posted by philchillbill View Post
    In the logs, I'm not seeing a lot of people trying the Spotty commands for playing Spotty playlists and Spotty podcasts. Did the sub-announcement get lost in more mundane posts in this thread? Sigh...
    Probably due to the fact that many Spotty users use it for its Spotify Connect capability as opposed to its LMS integration.
    Personally I use Spotty with LMS but as an input to DSTM/LastMix and rarely use any Spotify playlist and never a podcast.
    One of the problems (advantages) with this ecosystem is that itĺs use case is so wide
    VB2.4 storage QNAP TS419p (NFS)
    Living Room Joggler & Pi4/Khadas -> Onkyo TXNR686 -> Celestion F20s
    Office Joggler & Pi3 -> Denon RCD N8 -> Celestion F10s
    Dining Room SB Boom
    Kitchen UE Radio (upgraded to SB Radio)
    Bedroom (Bedside) Pi Zero+DAC ->ToppingTP21 ->AKG Headphones
    Bedroom (TV) & Bathroom SB Touch ->Denon AVR ->Mordaunt Short M10s + Kef ceiling speakers
    Guest Room Joggler > Topping Amp -> Wharfedale Modus Cubes
    Everything controlled by iPeng & Material on iOS

  2. #312
    Senior Member
    Join Date
    Feb 2011
    Location
    Cheshire, UK
    Posts
    5,510
    I reported the other day that Alexa in player mode (if we can call it that) would not play Tidal as Alexa was not recognised as a registered player at mySB.com.
    I have now tried with Qobuz and it won't play that either, just skips anything from there that you add to the queue. This is with a Qobuz HiFI (FLAC) account and the plugin configured accordingly.
    I think it is because there is no mechanism inside the Qobuz plugin to convert the FLAC stream to MP3 that Alexa is expecting.
    Spotty works but the log clearly shows that it is converting to MP3 to send to Alexa which is correct as the current implementation uses stream.mp3.
    VB2.4 storage QNAP TS419p (NFS)
    Living Room Joggler & Pi4/Khadas -> Onkyo TXNR686 -> Celestion F20s
    Office Joggler & Pi3 -> Denon RCD N8 -> Celestion F10s
    Dining Room SB Boom
    Kitchen UE Radio (upgraded to SB Radio)
    Bedroom (Bedside) Pi Zero+DAC ->ToppingTP21 ->AKG Headphones
    Bedroom (TV) & Bathroom SB Touch ->Denon AVR ->Mordaunt Short M10s + Kef ceiling speakers
    Guest Room Joggler > Topping Amp -> Wharfedale Modus Cubes
    Everything controlled by iPeng & Material on iOS

  3. #313
    Senior Member philchillbill's Avatar
    Join Date
    Jan 2019
    Location
    The Netherlands
    Posts
    581
    Quote Originally Posted by d6jg View Post
    I reported the other day that Alexa in player mode (if we can call it that) would not play Tidal as Alexa was not recognised as a registered player at mySB.com.
    I have now tried with Qobuz and it won't play that either, just skips anything from there that you add to the queue. This is with a Qobuz HiFI (FLAC) account and the plugin configured accordingly.
    I think it is because there is no mechanism inside the Qobuz plugin to convert the FLAC stream to MP3 that Alexa is expecting.
    Spotty works but the log clearly shows that it is converting to MP3 to send to Alexa which is correct as the current implementation uses stream.mp3.
    Good to know. I still have no response from Amazon regarding streaming FLAC to Echo devices. My feeling is that they will be tight-lipped but as soon as there's a workable interface I'll be all over it.

    Does Qobuz show up in the list of installed apps in e.g. Material? If so, then at least voice control of playing Qobuz on a proper Squeezebox will be possible.

  4. #314
    Senior Member
    Join Date
    Feb 2011
    Location
    Cheshire, UK
    Posts
    5,510
    Quote Originally Posted by philchillbill View Post
    Good to know. I still have no response from Amazon regarding streaming FLAC to Echo devices. My feeling is that they will be tight-lipped but as soon as there's a workable interface I'll be all over it.

    Does Qobuz show up in the list of installed apps in e.g. Material? If so, then at least voice control of playing Qobuz on a proper Squeezebox will be possible.
    Voice control is fine.
    VB2.4 storage QNAP TS419p (NFS)
    Living Room Joggler & Pi4/Khadas -> Onkyo TXNR686 -> Celestion F20s
    Office Joggler & Pi3 -> Denon RCD N8 -> Celestion F10s
    Dining Room SB Boom
    Kitchen UE Radio (upgraded to SB Radio)
    Bedroom (Bedside) Pi Zero+DAC ->ToppingTP21 ->AKG Headphones
    Bedroom (TV) & Bathroom SB Touch ->Denon AVR ->Mordaunt Short M10s + Kef ceiling speakers
    Guest Room Joggler > Topping Amp -> Wharfedale Modus Cubes
    Everything controlled by iPeng & Material on iOS

  5. #315
    Senior Member
    Join Date
    Feb 2008
    Posts
    5,126
    Deary me ... encountering utter chaos with re-subscription.

    Last week, the list ffavourites worked fine on my LMS running on a Joggler.

    Today, I resub'ed and everything has gone awol! Can't list favourites ... and attempting to stream produced a working stream to some podcast in Russian (or other Slavic language) to something called T2 !!!

    Bizarre.
    LMS server: O2 Joggler with Jivelite, Pi Zero W with PcP 6.0

    Amp: Denon PMA-50

    Players/Speakers: Touch, Logitech Radios, Sonos Play 1s & Beam, Libratone Zipp, GGMM E2 & E3, Yamaha WXAD-010, Loewe Airspeaker, Google Chromecast Audio, Home Mini & Nest Hub, Amazon Echo 2,3 and Show5, Pioneer WX-SMA1, Roberts S1, O2 Joggler, Cisco Joggler, Fiio M6, Avantree Priva BT transmitter



    ------------------------------------------------------------------------------------

  6. #316
    Senior Member
    Join Date
    Feb 2008
    Posts
    5,126
    And now - the text display on Show for 'discover setup' fails to show the on-screen text ... just a voice reply
    LMS server: O2 Joggler with Jivelite, Pi Zero W with PcP 6.0

    Amp: Denon PMA-50

    Players/Speakers: Touch, Logitech Radios, Sonos Play 1s & Beam, Libratone Zipp, GGMM E2 & E3, Yamaha WXAD-010, Loewe Airspeaker, Google Chromecast Audio, Home Mini & Nest Hub, Amazon Echo 2,3 and Show5, Pioneer WX-SMA1, Roberts S1, O2 Joggler, Cisco Joggler, Fiio M6, Avantree Priva BT transmitter



    ------------------------------------------------------------------------------------

  7. #317
    Senior Member philchillbill's Avatar
    Join Date
    Jan 2019
    Location
    The Netherlands
    Posts
    581
    Quote Originally Posted by castalla View Post
    And now - the text display on Show for 'discover setup' fails to show the on-screen text ... just a voice reply
    This is the (correct) response that's sent back to you:

    Code:
    {
        "version": "1.0",
        "response": {
            "outputSpeech": {
                "type": "SSML",
                "ssml": "<speak>Discovery found the following 5 players. Black,Nestdisplay,Priva1,Priva2, and Touch.</speak>"
            },
            "directives": [
                {
                    "type": "Dialog.UpdateDynamicEntities",
                    "updateBehavior": "REPLACE",
                    "types": [
                        {
                            "name": "AMAZON.Room",
                            "values": [
                                {
                                    "name": {
                                        "value": "black"
                                    }
                                },
                                {
                                    "name": {
                                        "value": "priva 1"
                                    }
                                },
                                {
                                    "name": {
                                        "value": "priva 2"
                                    }
                                },
                                {
                                    "name": {
                                        "value": "nest display"
                                    }
                                },
                                {
                                    "name": {
                                        "value": "touch"
                                    }
                                }
                            ]
                        }
                    ]
                }
            ],
            "shouldEndSession": true,
            "card": {
                "type": "Simple",
                "title": "Discover:",
                "content": "Discovery found 5 players: Black, Priva1, Priva2, Nestdisplay, Touch. "
            }
        },
        "userAgent": "ask-node/2.7.0 Node/v12.13.0",
        "sessionAttributes": {}
    }

    The 'card' at the end is what shows on your screen and it is correct (I changed nothing recently in the code that produces that outcome). I just did a test discovery myself and got the card no problem here.

    Are you still on the pi zero? If on the Joggler, is that a performant platform (I have no experience) ?
    Last edited by philchillbill; 2019-12-13 at 01:29.

  8. #318
    Senior Member
    Join Date
    Feb 2008
    Posts
    5,126
    Quote Originally Posted by philchillbill View Post


    The 'card' at the end is what shows on your screen and it is correct (I changed nothing recently in the code that produces that outcome). I just did a test discovery myself and got the card no problem here.

    Are you still on the pi zero? If on the Joggler, is that a performant platform (I have no experience) ?
    Went back to pi zero and screen displayed okay.

    The Joggler is Operating system: Debian - EN - utf8
    Platform Architecture: i686-linux

    ... but only 1 gb memory

    Strange that it worked last week (with just 2 favourites in list) but yesterday the list had over 15 items and it choked.

    Looks like I'll have to get a better pi to use the favourites feature.
    LMS server: O2 Joggler with Jivelite, Pi Zero W with PcP 6.0

    Amp: Denon PMA-50

    Players/Speakers: Touch, Logitech Radios, Sonos Play 1s & Beam, Libratone Zipp, GGMM E2 & E3, Yamaha WXAD-010, Loewe Airspeaker, Google Chromecast Audio, Home Mini & Nest Hub, Amazon Echo 2,3 and Show5, Pioneer WX-SMA1, Roberts S1, O2 Joggler, Cisco Joggler, Fiio M6, Avantree Priva BT transmitter



    ------------------------------------------------------------------------------------

  9. #319
    Senior Member
    Join Date
    Feb 2008
    Posts
    5,126
    Hmm - tried again with Joggler. I reduced the favourites to 'On mysqueezebox.com' and one Tunein stream.

    List favourites works.

    Stream favourite number 2 (tunein) works.

    So, looks like a long list of favourites screws up access.

    Could there be another way to load the favouries list? Seems a pity that favourites is flaky on lower power LMS devices, even though all other features seem to work okay.
    LMS server: O2 Joggler with Jivelite, Pi Zero W with PcP 6.0

    Amp: Denon PMA-50

    Players/Speakers: Touch, Logitech Radios, Sonos Play 1s & Beam, Libratone Zipp, GGMM E2 & E3, Yamaha WXAD-010, Loewe Airspeaker, Google Chromecast Audio, Home Mini & Nest Hub, Amazon Echo 2,3 and Show5, Pioneer WX-SMA1, Roberts S1, O2 Joggler, Cisco Joggler, Fiio M6, Avantree Priva BT transmitter



    ------------------------------------------------------------------------------------

  10. #320
    Senior Member philchillbill's Avatar
    Join Date
    Jan 2019
    Location
    The Netherlands
    Posts
    581
    Quote Originally Posted by castalla View Post
    Hmm - tried again with Joggler. I reduced the favourites to 'On mysqueezebox.com' and one Tunein stream.

    List favourites works.

    Stream favourite number 2 (tunein) works.

    So, looks like a long list of favourites screws up access.

    Could there be another way to load the favouries list? Seems a pity that favourites is flaky on lower power LMS devices, even though all other features seem to work okay.
    Unfortunately, the only way to handle nested favorites is to make several JSON trips out and back - there's simply no other way with the LMS API. Having just one level with no folders will be quicker and may save the day for you. Even if your desired favorite is at the top level, the command will still fetch your entire hierarchy (that includes the on mysqueezebox.com folder). Keep it flat for speed.

    Don't forget also that your ISP upload speed is a factor in responding to the skill. It's more than just the LMS platform speed. The issue you're having with the display on the Echo Show 5 not updating is not related to the pi vs Joggler - that's much more likely related to your internet. Might just be a fluke that it worked when you swapped. If you're rural, you may also have droppy internet. You'll not really notice that when browsing and such but a skill is the worst test of that because it's 8 seconds or die...

    Not to brag, but I have 250Mbit internet and LMS on a Synology DS916+ with 8GB. The speed of response always makes Alexa a little dizzy, or so she tells me

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •