Home of the Squeezebox™ & Transporter® network music players.
Results 1 to 9 of 9
  1. #1
    Member
    Join Date
    Jun 2017
    Location
    Belgium
    Posts
    47

    SOLVED: How to connect PiZero to another AP?

    Hi all

    I installed another AP with same wifi settings as the old one.
    The RPi B with USB wifi dongle connects without any intervention.
    The RPi Zero W on the other hand doesn't connect, even after multiple reboots.

    Am I missing something?

    TIA
    R.
    Last edited by Rnee; 2019-10-07 at 13:23. Reason: Solved
    pCP v5.0.0 on all players
    RPi 3B+ with Hifiberry AMP2 and official 7" touchscreen (Squeezelite, LMS and Jivelite), +24k titles on SMB share
    RPi B as dedicated player, connected over wifi with USB dongle
    RPi 2B as dedicated player, connected over powerline
    RPi Zero W as dedicated player
    Squeezer on Android to control

  2. #2
    Senior Member paul-'s Avatar
    Join Date
    Jan 2013
    Posts
    2,280
    The only thing that comes to mind is channel.

    What version of pCP?
    piCorePlayer a small player for the Raspberry Pi in RAM.
    Homepage: https://www.picoreplayer.org

    Please donate if you like the piCorePlayer

  3. #3
    Member
    Join Date
    Jun 2017
    Location
    Belgium
    Posts
    47
    Hi Paul, thank you for stepping in.

    The channel was set to auto on both AP's, on the new one that was 13 on 2.4Ghz
    Setting it to manual on 1,6 and 11 didn't make any difference.
    Using pcp5.0 on all systems.

    I just noticed something different on both wireless players: on the rpi zero, the configuration is manually maintained by user, on the other one there are more options in the wifi settings tab.
    Could this be the cause, even though it still works on the old AP?

    TIA
    R
    pCP v5.0.0 on all players
    RPi 3B+ with Hifiberry AMP2 and official 7" touchscreen (Squeezelite, LMS and Jivelite), +24k titles on SMB share
    RPi B as dedicated player, connected over wifi with USB dongle
    RPi 2B as dedicated player, connected over powerline
    RPi Zero W as dedicated player
    Squeezer on Android to control

  4. #4
    Senior Member paul-'s Avatar
    Join Date
    Jan 2013
    Posts
    2,280
    Do you have the country code defined? The RPI chipsets require it to properly configure the onboard radio.
    Last edited by paul-; 2019-09-22 at 18:51.
    piCorePlayer a small player for the Raspberry Pi in RAM.
    Homepage: https://www.picoreplayer.org

    Please donate if you like the piCorePlayer

  5. #5
    Member
    Join Date
    Jun 2017
    Location
    Belgium
    Posts
    47
    I've switched the ZeroW to configuration through the pCP interface; it did have the proper country code whereas the other wireless player doesn't have it but works fine.

    The AP is a ubnt Loco M2, these are the wireless settings:
    Code:
    Channel/Frequency: 8  /  2447 MHz 
    Channel Width: 40 MHz  (Upper)
    Frequency Band: 2437  -  2477 MHz 
    Distance: 0.6 miles (0.9 km) 
    TX/RX Chains: 2X2
    TX Power: 12 dBm 
    Antenna:  Built in - 8 dBi
    On the working device, I have a TP-link USB wifi adapter.

    Other ideas?
    pCP v5.0.0 on all players
    RPi 3B+ with Hifiberry AMP2 and official 7" touchscreen (Squeezelite, LMS and Jivelite), +24k titles on SMB share
    RPi B as dedicated player, connected over wifi with USB dongle
    RPi 2B as dedicated player, connected over powerline
    RPi Zero W as dedicated player
    Squeezer on Android to control

  6. #6
    Senior Member paul-'s Avatar
    Join Date
    Jan 2013
    Posts
    2,280
    Letĺs try to update wpa_supplicant. Can you connect to the old AP, and open up a ssh session, then run the following

    pcp-update wpa_supplicant.tcz

    Then reboot and try to connect to new AP
    piCorePlayer a small player for the Raspberry Pi in RAM.
    Homepage: https://www.picoreplayer.org

    Please donate if you like the piCorePlayer

  7. #7
    Member
    Join Date
    Jun 2017
    Location
    Belgium
    Posts
    47
    Thanks Paul, the reason was that the AP had a default channel width of 40Mhz and apparently the ZeroW cannot handle this whereas the other RPi with a USB wifi dongle was working fine.
    pCP v5.0.0 on all players
    RPi 3B+ with Hifiberry AMP2 and official 7" touchscreen (Squeezelite, LMS and Jivelite), +24k titles on SMB share
    RPi B as dedicated player, connected over wifi with USB dongle
    RPi 2B as dedicated player, connected over powerline
    RPi Zero W as dedicated player
    Squeezer on Android to control

  8. #8
    Senior Member paul-'s Avatar
    Join Date
    Jan 2013
    Posts
    2,280
    Interesting the AP doesnĺt fall back to 20... but thanks for the update.
    piCorePlayer a small player for the Raspberry Pi in RAM.
    Homepage: https://www.picoreplayer.org

    Please donate if you like the piCorePlayer

  9. #9
    Member
    Join Date
    Jun 2017
    Location
    Belgium
    Posts
    47
    The AP was configured with a fix 40Mhz channel width and now I experienced that apple devices also have a problem to connect over wifi with this 40Mhz channel width.
    pCP v5.0.0 on all players
    RPi 3B+ with Hifiberry AMP2 and official 7" touchscreen (Squeezelite, LMS and Jivelite), +24k titles on SMB share
    RPi B as dedicated player, connected over wifi with USB dongle
    RPi 2B as dedicated player, connected over powerline
    RPi Zero W as dedicated player
    Squeezer on Android to control

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •