Home of the Squeezebox™ & Transporter® network music players.
Results 1 to 4 of 4
  1. #1

    PCM2704 Dac goes to "sleep mode"

    Hello,

    I have this usb dac connected to my pi zero (PCM2704): https://www.aliexpress.com/item/3303...chweb201603_55

    With this usb hub: https://www.aliexpress.com/item/3289...chweb201603_55

    Everything is working okay but when I have not used the player for a while and start a song, the music will start playing through my speakers only when I turn the volume up to around 70% or reconnect the aux cable to the dac. After that I can lower the volume and hear the music normally.

    It feels like the usb dac is going to "sleep mode" and doesn't react to the audio signal below 70% volume.

    Is this normal behaviour and can it be fixed?

    Thank you guys!
    Last edited by Jursi; 2019-09-08 at 13:19.

  2. #2
    Senior Member
    Join Date
    Jan 2011
    Location
    Staffordshire. UK
    Posts
    2,909
    Well this is a bit of a guess.

    First off, make sure you are giving the zero its required power supply, and not overloading the usb requirements.

    Try and connect the usb dac diectly to the Zero with something like this

    https://thepihut.com/products/usb-to...SABEgKS2fD_BwE

    and look in Alsamixer.

    When you have music playing, SSH into the Zero, type
    Code:
    Alsamixer
    press Enter > F6 on the keyboard and select the dac.

    If you can adjust the playback volume, do so.

    Hit Esc on the keyboard and type
    Code:
    sudo alsactl store
    then pres Enter.

    You can also adjust the audio output frm LMS gui, Settings > Player > Audio > Volume Control > Apply.

    ronnie

  3. #3
    Quote Originally Posted by Man in a van View Post
    Well this is a bit of a guess.

    First off, make sure you are giving the zero its required power supply, and not overloading the usb requirements.

    Try and connect the usb dac diectly to the Zero with something like this

    https://thepihut.com/products/usb-to...SABEgKS2fD_BwE

    and look in Alsamixer.

    When you have music playing, SSH into the Zero, type
    Code:
    Alsamixer
    press Enter > F6 on the keyboard and select the dac.

    If you can adjust the playback volume, do so.

    Hit Esc on the keyboard and type
    Code:
    sudo alsactl store
    then pres Enter.

    You can also adjust the audio output frm LMS gui, Settings > Player > Audio > Volume Control > Apply.

    ronnie
    Thank you for your answer.

    The power supply should be good enough for the pi, dac and usb wifi (2amps).

    If I connect the dac to pi with usb to micro-usb otg converter, I loose the wifi connection and can't SSH into the Zero. The wifi dongle is also connected to the hub.

    I have already set the volume from alsamixer to 80-90 with the dac connected to the usb hub.

    I could try to connect the USB Dac to another player (pi 3) and see how it behaves.

    Thanks!
    Last edited by Jursi; 2019-09-09 at 01:38.

  4. #4
    Hello,

    I still have this problem with 2 dacs (both are pcm2704)

    Does anybody have any suggestion how to fix the problem.

    Br. Jursi

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •