Home of the Squeezebox™ & Transporter® network music players.
Results 1 to 10 of 10

Threaded View

  1. #1

    Player doesn't reconnect after restarting LMS

    Hello,
    I have a player that fails to connect after an LMS restart.

    I recently built a Linux Mint 19.2 PC and installed LMS 7.9.2 - 1565967976 using the Debian package. There's also this infomation that may be relevant, though it doesn't seem so to me.
    - I'm running Mullvad VPN client with local browse enabled.
    - I've been wrestling with sound since the git-go, and still am. This works for me for now, reliably: After a reboot, force-reload alsa and then start sound-dependent apps.

    I have a minimal setup at the moment; a squeezelite player running as a daemon, and a Boom. Here's the problem.

    I get LMS running and the two players playing. A situation occurs where I need to stop and restart LMS. When I do this, the Boom disappears from the player list. On the Boom there is a message "can't connect", and repeated attempts fail to connect it to LMS. There are no relevant messages in the server log. The Squeezctl app on my phone won't connect either. Disabling VPN on the host has no effect.

    Now the really weird part, to me, is this problem persists through a reboot. Problem occurs, reboot and login, force-reload alsa and start the squeezelite player, and Boom still fails to connect.

    The only thing that has worked is to restore from the last snapshot when this was all working. When I do that the Boom connects and all is well. (I've learned to take frequent snapshots.)

    Edit:
    To be clear, this problem only happens when I run 'sudo service logitechmediaserver stop' and then 'start'. If I add/remove a plugin and let LMS run the restart this probem doesn't happen.

    Any ideas and suggestions would be most welcome.
    Thanks,
    ~dean~
    Last edited by dbinfl; 2019-09-05 at 19:13. Reason: Clarification

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •