Home of the Squeezebox™ & Transporter® network music players.
Results 1 to 5 of 5
  1. #1
    Senior Member left channel's Avatar
    Join Date
    Mar 2018
    Location
    Silicon Valley
    Posts
    371

    Music "doesn't exist on disk - skipping!"

    Today my music has been pausing and restarting over and over again. In my log I see "doesn't exist on disk - skipping!" This happens with music stored on the same server as LMS, and with two internet radio apps (Radio Paradise and SomaFM), using SLX or a Touch as clients.

    It's not my ISP, LAN, or server disc, because a non-LMS client (MusicBee) can play internet radio and can also access music files on the same server just fine.

    Is there anything I can clear or reset from within LMS Settings? I've been running LMS 7.9.2 for many months, on Sonicorbiter OS which limits how much I can do on the command line.

    Code:
    [19-09-03 08:32:17.9837] Plugins::MusicArtistInfo::Common::__ANON__ (119) Failed to call https://www.last.fm/music/Budapest%20String%20Quartet%2C%20Juilliard%20String%20Quartet%2C%20Mieczys%C5%82aw%20Horszowski/+images: 404 Not Found
    [19-09-03 08:32:18.8335] Plugins::MusicArtistInfo::Common::__ANON__ (119) Failed to call https://www.last.fm/music/BUDAPEST%20STRING%20QUARTET%20JUILLIARD%20STRING%20QUARTET%20MIECZYSLAW%20HORSZOWSKI/+images: 404 Not Found
    [19-09-03 09:44:11.8697] main::init (387) Starting Logitech Media Server (v7.9.2, 0.9.20181207git1543258616, Fri Dec 7 12:03:59 EST 2018) perl 5.024003 - x86_64-linux-thread-multi
    [19-09-03 09:44:20.5748] Slim::Formats::Playlists::Base::playlistEntryIsValid (125) Warning: radioparadise://4-1.flac found in playlist:
    	file:///var/lib/squeezeboxserver/prefs/clientplaylist_02007254cd3a.m3u doesn't exist on disk - skipping!
    [19-09-03 09:44:20.6040] Slim::Formats::Playlists::Base::playlistEntryIsValid (125) Warning: file:///storage/music/flac/radioparadise:/4-1.flac found in playlist:
    	file:///var/lib/squeezeboxserver/prefs/clientplaylist_02007254cd3a.m3u doesn't exist on disk - skipping!
    [19-09-03 09:44:20.6671] Slim::Formats::Playlists::Base::playlistEntryIsValid (125) Warning: radioparadise://4.flac found in playlist:
    	file:///var/lib/squeezeboxserver/prefs/clientplaylist_02002f434878.m3u doesn't exist on disk - skipping!
    [19-09-03 09:44:20.6724] Slim::Formats::Playlists::Base::playlistEntryIsValid (125) Warning: file:///storage/music/flac/radioparadise:/4.flac found in playlist:
    	file:///var/lib/squeezeboxserver/prefs/clientplaylist_02002f434878.m3u doesn't exist on disk - skipping!
    [19-09-03 09:44:42.6558] Slim::Control::Request::renderAsArray (2233) Error: request should set useIxHashes in Slim::Control::Request->new()
    [19-09-03 09:44:42.6589] Slim::Control::Request::renderAsArray (2233) Backtrace:
    
       frame 0: Slim::Utils::Log::logBacktrace (/usr/lib64/perl5/vendor_perl/Slim/Control/Request.pm line 2233)
       frame 1: Slim::Control::Request::renderAsArray (/usr/lib64/perl5/vendor_perl/Slim/Plugin/CLI/Plugin.pm line 697)
       frame 2: Slim::Plugin::CLI::Plugin::cli_request_write (/usr/lib64/perl5/vendor_perl/Slim/Plugin/CLI/Plugin.pm line 1010)
       frame 3: Slim::Plugin::CLI::Plugin::cli_subscribe_notification (/usr/lib64/perl5/vendor_perl/Slim/Control/Request.pm line 2058)
       frame 4: (eval) (/usr/lib64/perl5/vendor_perl/Slim/Control/Request.pm line 2058)
       frame 5: Slim::Control::Request::notify (/usr/lib64/perl5/vendor_perl/Slim/Control/Request.pm line 859)
       frame 6: Slim::Control::Request::checkNotifications (/usr/libexec/squeezeboxserver line 711)
       frame 7: main::idle (/usr/libexec/squeezeboxserver line 680)
       frame 8: main::main (/usr/libexec/squeezeboxserver line 1216)
    LMS: SGC microJukebox running Sonicorbiter OS
    Control apps: Squeezelite-X on Win 10; Squeezer or Material web app on Android
    Players: Duet, Touch (two), Mac SqueezePlay, Win Squeezelite-X on laptop and HTPC

  2. #2
    Senior Member left channel's Avatar
    Join Date
    Mar 2018
    Location
    Silicon Valley
    Posts
    371
    Forgot to mention above that I restarted the server. That did not help. Unable to play anything more than 30 seconds.
    LMS: SGC microJukebox running Sonicorbiter OS
    Control apps: Squeezelite-X on Win 10; Squeezer or Material web app on Android
    Players: Duet, Touch (two), Mac SqueezePlay, Win Squeezelite-X on laptop and HTPC

  3. #3
    Senior Member left channel's Avatar
    Join Date
    Mar 2018
    Location
    Silicon Valley
    Posts
    371
    Also didn't work:
    * updating to a slightly newer version of 7.9.2 (0.10 something)
    * clearing the database and re-scanning (and now it will take forever to download artwork and icons again)

    Every track still dies at around 30 seconds.
    LMS: SGC microJukebox running Sonicorbiter OS
    Control apps: Squeezelite-X on Win 10; Squeezer or Material web app on Android
    Players: Duet, Touch (two), Mac SqueezePlay, Win Squeezelite-X on laptop and HTPC

  4. #4
    Senior Member left channel's Avatar
    Join Date
    Mar 2018
    Location
    Silicon Valley
    Posts
    371
    Fixed! Except I don't know what I did or why this happened.

    I just used SLX on another PC here. That PC and app had been left running all this time, but with the DAC off. When I went back and used it just now with the DAC on, music played correctly in that room. I then tested the SLX on my main PC as well as my Touch and Duet boxen, and all are working OK now.

    That SLX on the other PC was not grouped or synced as far as I could tell, but perhaps some malfunction of Groups still had it linked, and it then influenced all the others when it could not fine a DAC locally. Or at least that's my theory. Things have been strange here in other ways since I last used my "All" group, which includes both SLX apps and all the boxen here.
    LMS: SGC microJukebox running Sonicorbiter OS
    Control apps: Squeezelite-X on Win 10; Squeezer or Material web app on Android
    Players: Duet, Touch (two), Mac SqueezePlay, Win Squeezelite-X on laptop and HTPC

  5. #5
    Senior Member left channel's Avatar
    Join Date
    Mar 2018
    Location
    Silicon Valley
    Posts
    371
    Turns out the Squeezelite-X with the disabled DAC *was* synchronized with all other players. Could this have caused the "skipping" error on the other players? Still seems odd.

    In that instance of SLX/Material, when I opened "Synchronize" at the bottom of the players list, I found all other players listed. I did not put them there Ś I've never synchronized that player, and have only used my "All" Group once (and Groups are not the same thing) Ś but perhaps they were selected during the Material update that added that feature, or during a related SLX update. Or could it have been done by the Group plugin when I used the "All" group (not likely)?

    That synchronization appears to have been the cause, though the way it was reflected in the log still mystifies me.
    LMS: SGC microJukebox running Sonicorbiter OS
    Control apps: Squeezelite-X on Win 10; Squeezer or Material web app on Android
    Players: Duet, Touch (two), Mac SqueezePlay, Win Squeezelite-X on laptop and HTPC

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •