Home of the Squeezebox™ & Transporter® network music players.
Page 1 of 8 123 ... LastLast
Results 1 to 10 of 78
  1. #1
    Junior Member
    Join Date
    Apr 2018
    Posts
    8

    Setting up Bluetooth Speaker with piCorePlayer v3.5.0 optimized for audio

    So I set up Squeezelite Settings>Audio output device settings> and select Bluetooth Audio. Then >save, Then reboot. For some reason Squeezelite stops working. When I click on >Card control, everything is red in Bluetooth control. I am also connected via ethernet becuse I understand that the Wifi does not work when using BT. Does anyone know why this is happening? Thanks.

  2. #2
    Senior Member paul-'s Avatar
    Join Date
    Jan 2013
    Posts
    2,353
    Yup, make sure you are in beta mode, then finish the install

    Squeezelite won’t run until a speaker is fully setup, paired and connected. And don’t run the audio kernel. It provides Zero value when using Bluetooth.
    piCorePlayer a small player for the Raspberry Pi in RAM.
    Homepage: https://www.picoreplayer.org

    Please donate if you like the piCorePlayer

  3. #3
    Junior Member
    Join Date
    Apr 2018
    Posts
    8

    The key item here is Beta mode

    Quote Originally Posted by paul- View Post
    Yup, make sure you are in beta mode, then finish the install

    Squeezelite won’t run until a speaker is fully setup, paired and connected. And don’t run the audio kernel. It provides Zero value when using Bluetooth.
    Yes, it now works. I am streaming to my Bang and Olufsen A2 Speaker. Sounds like it is supposed to; Fantastic. The part that I missed is to be in "Beta Mode". I am using the Audio Optimised pCP but no harm.

    Thanks

  4. #4
    Junior Member
    Join Date
    Apr 2018
    Posts
    8

    It also works with WiFi on!

    Just wanted to add that built-in Wifi works just fine with built-in Bluetooth playing on bluetooth speaker.

    PiCorePlayer v 3.5.0
    RPI 3 B+

  5. #5
    Senior Member paul-'s Avatar
    Join Date
    Jan 2013
    Posts
    2,353
    The 3B+ works well with WiFi and Bluetooth, especially on a 5G WiFi band. For the reat, there has been a recent change to the Rpi WiFi firmware that allows 2.4g WiFi coexist with Bluetooth. This change will be in 4.0.0 soon.
    piCorePlayer a small player for the Raspberry Pi in RAM.
    Homepage: https://www.picoreplayer.org

    Please donate if you like the piCorePlayer

  6. #6
    Senior Member
    Join Date
    Apr 2005
    Location
    UK/London
    Posts
    1,887
    Just for fun, I thought I would give this a try and now have pCP 4.0 on a PiZeroWH running on 2.4GHz WiFi and using a Bluetooth speaker.
    Took a few times for the connection to be made but it is working.
    Will now leave it playing for a few hours to see if it runs OK.
    Paul Webster
    http://dabdig.blogspot.com
    Author Radio France (FIP etc) plugin

  7. #7
    Senior Member
    Join Date
    Apr 2005
    Location
    UK/London
    Posts
    1,887
    Worked flawlessly for just over 3 hours now.
    Passed!
    Paul Webster
    http://dabdig.blogspot.com
    Author Radio France (FIP etc) plugin

  8. #8
    I've just set up a piZeroW with pCP 4.1.0. It is connected via wifi to a WD hard drive running LMS.
    I can pair my Bowers & Wilkins BT headphones, but cannot start Squeezelite after that. Squeezelite runs when an output other than Bluetooth is selected
    I'm reasonably familiar with piCorePlayer, but can't see any obvious reason why Squeezelite won't start when Bluetooth has been selected.

    Any suggestions?

    Robert
    Home: Raspberry Pi 3/piCoreplayer/LMS7.9.2 with files on QNAP TS-251A
    Touch > DacMagic 100 > Naim Audio Nait 3 > Mission 752 (plus Rega Planar 3 > Rega Fono Mini; Naim CD3)
    2 x Squeezebox Radios, 1 X Squeezebox 3 (retired), spare Pi2/piCorePlayer
    Office: LMS7.9.2 running on WiFi MyPassport drive > Raspberry Pi 3 with touchscreen/piCorePlayer/IQaudIO DAC and Amp
    SqueezePad, iPeng as controllers

    last.fm/user/GrumpyBob

  9. #9
    Senior Member paul-'s Avatar
    Join Date
    Jan 2013
    Posts
    2,353
    When running bluetooth, squeezelite will not start until a valid speaker is paired and connected. Once it is connected, pCP will automatically restart squeezelite if needed.
    piCorePlayer a small player for the Raspberry Pi in RAM.
    Homepage: https://www.picoreplayer.org

    Please donate if you like the piCorePlayer

  10. #10
    Quote Originally Posted by Grumpy Bob View Post
    I've just set up a piZeroW with pCP 4.1.0. It is connected via wifi to a WD hard drive running LMS.
    I can pair my Bowers & Wilkins BT headphones, but cannot start Squeezelite after that. Squeezelite runs when an output other than Bluetooth is selected
    I'm reasonably familiar with piCorePlayer, but can't see any obvious reason why Squeezelite won't start when Bluetooth has been selected.

    Any suggestions?

    Robert
    I reflashed the SD card with piCorePlayer 4.0.0 and everything was pretty straightforward - just took a couple of tries to pair the headphones. Just as Paul did, I'll leave this playing for a while to check its resilience.

    Robert
    Home: Raspberry Pi 3/piCoreplayer/LMS7.9.2 with files on QNAP TS-251A
    Touch > DacMagic 100 > Naim Audio Nait 3 > Mission 752 (plus Rega Planar 3 > Rega Fono Mini; Naim CD3)
    2 x Squeezebox Radios, 1 X Squeezebox 3 (retired), spare Pi2/piCorePlayer
    Office: LMS7.9.2 running on WiFi MyPassport drive > Raspberry Pi 3 with touchscreen/piCorePlayer/IQaudIO DAC and Amp
    SqueezePad, iPeng as controllers

    last.fm/user/GrumpyBob

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •