Home of the Squeezebox™ & Transporter® network music players.
Page 1 of 2 12 LastLast
Results 1 to 10 of 19

Thread: Alarm toggle

  1. #1
    Junior Member
    Join Date
    Nov 2013
    Location
    Sydney, Australia
    Posts
    19

    Alarm toggle

    Silly question: Ive got three squeezeboxes running off LMS 7.9.2. Have had them for years but one thing thats always bugged me is the alarm. I have only got one alarm set for the week, on the sb radio next to my bed. to make it work I always need to toggle the alarm off then back on the night before. I dont need to change anything, just turn it off and on again. Ive kind of gotten used to this over many years but sometimes I forget, and the alarm doesnt go off.

    Before I toggle the alarm status the little bell symbol doesnt show up, but as soon as I toggle it back on it appears. Before toggling the alarm is on in the settings but it doesnt work without the toggle.

    As this has happened over years its been on many versions of the LMS software, and with different sounds, and with both a boom and radio.

    Any ideas?

  2. #2
    Senior Member
    Join Date
    Jan 2010
    Location
    Hertfordshire
    Posts
    3,028
    Quote Originally Posted by liquefry View Post
    Silly question: Ive got three squeezeboxes running off LMS 7.9.2. Have had them for years but one thing thats always bugged me is the alarm. I have only got one alarm set for the week, on the sb radio next to my bed. to make it work I always need to toggle the alarm off then back on the night before. I dont need to change anything, just turn it off and on again. Ive kind of gotten used to this over many years but sometimes I forget, and the alarm doesnt go off.

    Before I toggle the alarm status the little bell symbol doesnt show up, but as soon as I toggle it back on it appears. Before toggling the alarm is on in the settings but it doesnt work without the toggle.

    As this has happened over years its been on many versions of the LMS software, and with different sounds, and with both a boom and radio.

    Any ideas?
    Sounds like you need to set the alarm to repeat rather than a one time alarm. You can then choose the days when you want the alarm to go off.

    Sent from my SM-G900F using Tapatalk

  3. #3
    Junior Member
    Join Date
    Nov 2013
    Location
    Sydney, Australia
    Posts
    19
    Yeah it's already repeat. Check out these settings:

    Name:  alarm.png
Views: 122
Size:  18.1 KB

    Every Tuesday night I need to toggle the "all alarms" from on to off and then back on again. Otherwise none of them work. Weird right?
    Last edited by liquefry; 2019-08-27 at 18:59. Reason: clarification

  4. #4
    Junior Member
    Join Date
    Nov 2013
    Location
    Sydney, Australia
    Posts
    19
    I wonder if it's something to do with the way I turn the alarm off? I use the power button to turn off the radio when the alarm comes on. There are options to use the buttons beside the display but when I use those I somehow in my drowsiness always end up snoozing the alarm rather than turning it off, which means it goes off again while I'm in the shower. Maybe using the power button somehow disables the alarm in a way that's not showing up in the settings UI?

  5. #5
    Junior Member
    Join Date
    May 2015
    Posts
    8
    You need to select (check) all of the days that you want the alarm to go off. For example if you want it go off each week day morning you would need to check Mon thru Fri. Be sure to click "apply" to save settings.

  6. #6
    Senior Member
    Join Date
    Jun 2010
    Location
    California, USA
    Posts
    201
    Quote Originally Posted by liquefry View Post
    I wonder if it's something to do with the way I turn the alarm off? I use the power button to turn off the radio when the alarm comes on. There are options to use the buttons beside the display but when I use those I somehow in my drowsiness always end up snoozing the alarm rather than turning it off, which means it goes off again while I'm in the shower. Maybe using the power button somehow disables the alarm in a way that's not showing up in the settings UI?
    I always use the power button to turn off the the alarm as well but do not have alarm problem like your.

  7. #7
    Babelfish's Best Boy mherger's Avatar
    Join Date
    Apr 2005
    Location
    Switzerland
    Posts
    20,295

    Alarm toggle

    > Before I toggle the alarm status the little bell symbol doesn’t show up,
    > but as soon as I toggle it back on it appears. Before toggling the alarm
    > is “on” in the settings but it doesn’t work without the toggle.


    Is it a visual issue only, or would the alarm indeed not fire if you
    didn't do this?

    --

    Michael

  8. #8
    Senior Member KeBul's Avatar
    Join Date
    Sep 2009
    Location
    London
    Posts
    145
    Hi,

    I've used the alarm function for many years and not seen the issue you are having, but if I'm understanding your use case it's slightly different to mine.

    We tend to use two alarm configs, one for weekday, MTWTF and a second for weekend SS, sometimes the second is used for an earlier alarm time on a weekday as well, I also play a radio station, but from your screenshot you have one alarm day a week, Wednesday and play an alarm sound.

    I've configured another one of my radios to alarm just on Friday, using Brainfluid sound, (can't use Wednesday because I'm away for the next two Wednesdays) and If no progress has been made here I'll report back on the behaviour I see.

    The alarm bell symbol on the player display seems to come on about 23 hours 53 minutes before the next alarm event.

    I also switch off the alarm using the power button, so that shouldn't be the issue.

    Just for further troubleshooting information, you mention you've used many versions of LMS, how have you upgraded over the years?
    Have you had any fresh builds and setup/configured from scratch?
    What platform?

    Cheers

    Kev

  9. #9
    Senior Member Julf's Avatar
    Join Date
    Dec 2010
    Posts
    2,499
    Hmm. My wife uses the alarm on the Radio in the mornings. She used to turn it off with the power button, but the alarm would turn off for the rest of the days in the week and had to be reactivated every evening. After I instructed her to turn off the alarm by using the tuning button (first selecting "off" and then pushing) the alarms have stayed set.
    "To try to judge the real from the false will always be hard. In this fast-growing art of 'high fidelity' the quackery will bear a solid gilt edge that will fool many people" - Paul W Klipsch, 1953

  10. #10
    Junior Member
    Join Date
    Nov 2013
    Location
    Sydney, Australia
    Posts
    19
    Quote Originally Posted by mherger View Post
    > Before I toggle the alarm status the little bell symbol doesn’t show up,
    > but as soon as I toggle it back on it appears. Before toggling the alarm
    > is “on” in the settings but it doesn’t work without the toggle.


    Is it a visual issue only, or would the alarm indeed not fire if you
    didn't do this?
    The alarm does not fire if I dont do this so its not just visual.

    To answer the other questions - all the days I want the alarm to go off (wednesday only) are already selected. I use a fedora based server (running amahi), I generally update the lms using the rpm update link you get from the server settings page when an update is ready. At least thats how Ive done it for a long time.

    Julf your problem sounds the same. You turn it off using the tuning button. Will give that a go.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •