Home of the Squeezebox™ & Transporter® network music players.
Page 3 of 3 FirstFirst 123
Results 21 to 26 of 26
  1. #21
    Senior Member
    Join Date
    Oct 2005
    Location
    Ireland
    Posts
    17,835
    Quote Originally Posted by chill View Post
    10 reboots on the trot with no errors.

    I reloaded the two BBC plugins, and have rebooted 5 times without error.

    Not conclusive of course, because the error was only 'occasional', but I think 10 reboots would have caught at least one instance.
    There could be a timing issue. With rapid rebooting, higher chance of info being cached somewhere (e.g. by router, DNS server) - using cached info would change timing.

  2. #22
    Senior Member chill's Avatar
    Join Date
    Mar 2007
    Posts
    1,329
    Yeah, I know this isn't a fair test - a 'pass' won't necessarily mean the plugin is innocent, but a 'fail' might be more conclusive.

    The BBC plugins didn't provoke the error after 10 reboots. So I added Shairtunes as well, and have rebooted 4 times without error. I'm going to remove those plugins again, then add Spotty and listen to some music while I get on with other things.

  3. #23
    Babelfish's Best Boy mherger's Avatar
    Join Date
    Apr 2005
    Location
    Switzerland
    Posts
    20,312
    Hey Chill - what happened to this issue? Today I started playing with a custom Perl build on macOS, as Apple has announced to remove Perl from future macOS versions. And I'm running into exactly this issue. It's intermittent. At first the server did start fine, but the scanner failed. Then the scanner succeeded, but the server started to fail...

    And about twice I saw the warning about $ipn without the actual crash. I have no clue what's going on there. But I could certainly patch the file to not hit the $ipn issue.

    This is with Perl 5.28 - less recent than what Paul is using for pCP, isn't it?
    Michael

    http://www.herger.net/slim-plugins - Spotty, MusicArtistInfo

  4. #24
    Senior Member chill's Avatar
    Join Date
    Mar 2007
    Posts
    1,329
    I haven't encountered this error again since that post in August. I've re-enabled all the plugins that I had disabled, but LMS has been perfectly behaved. I have no idea what the cause was, or why it's gone away.

    I'm currently using piCorePlayer v6.0.0-b1, and 'perl -v' gives this:

    Code:
    This is perl 5, version 28, subversion 0 (v5.28.0) built for arm-linux-gnueabihf-thread-multi-64int

  5. #25
    Senior Member paul-'s Avatar
    Join Date
    Jan 2013
    Posts
    2,284
    I've been running 5.28 on my intel NUC running Ubuntu for many months.
    piCorePlayer a small player for the Raspberry Pi in RAM.
    Homepage: https://www.picoreplayer.org

    Please donate if you like the piCorePlayer

  6. #26
    Babelfish's Best Boy mherger's Avatar
    Join Date
    Apr 2005
    Location
    Switzerland
    Posts
    20,312

    Perl compilation error: $ipn

    > I've been running 5.28 on my intel NUC running Ubuntu for many months.

    Well, I've been using it with my pCP based system for months, too!
    That's why I'm puzzled to only see it now (or yesterday) on my Mac.
    There's a lot more to do there if Apple really is to pull out scripting
    languages :-(.

    --

    Michael

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •