Home of the Squeezebox™ & Transporter® network music players.
Page 2 of 2 FirstFirst 12
Results 11 to 17 of 17
  1. #11
    Senior Member
    Join Date
    Apr 2005
    Location
    UK/London
    Posts
    1,720
    I don't usually have X-Windows on RPi systems ... but now I have one so I thought I would try to reproduce the issue ... but ... where did you get your Jivelite from?
    I can see various Squeezeplay builds from Ralphy at https://sourceforge.net/projects/lms...ezeplay/linux/ but the ARMHF ones appear to be Frame Buffer (fb) not X11.
    Paul Webster
    http://dabdig.blogspot.com
    Author Radio France (FIP etc) plugin

  2. #12
    Senior Member
    Join Date
    Jan 2011
    Location
    Staffordshire. UK
    Posts
    2,837
    Hi Paul

    I build it on the pi, using the instructions I have previously used for the Joggler

    https://forums.slimdevices.com/showt...l=1#post931584


    I don't know if that is frame buffer or X11.

    Most likely fb, but in truth I don't really know the difference. I guess that fb works when I run the start instruction from another computer and it loads the full screen version of Jivelite and x11 runs Jivelite as a window within the desktop.

    I seem to remember that ralphy posted a link for a squeezeplay with x11 which I did play with once.

    Here is the link

    https://forums.slimdevices.com/showt...l=1#post891854

    please don't wast too much time on this.

    The addition of the ampersand to the start up script means I can remove the lx terminal any way. One extra click is not worth using up you valuable time

    Thanks a lot

    ronnie

  3. #13
    Senior Member
    Join Date
    Apr 2005
    Location
    UK/London
    Posts
    1,720
    Here is what I have just done ...

    sudo vi /etc/xdg/lxsession/LXDE-pi/autostart

    add
    @/home/pi/jivelite/bin/jivelite

    to the end of the pre-existing file ...
    logout / login ... (perhaps reboot).

    So now on boot I have a Jivelite automatically starting up in a window on the desktop ... and in my case ... connecting to LMS on a different system.
    This might not be great for you since LMS will not yet be running when JiveLite starts up ... but my guess is that you could get it to work by having it launch a script instead and put a delay (or a real test for the LMS ports being responsive) before the script launches Jivelite.
    Paul Webster
    http://dabdig.blogspot.com
    Author Radio France (FIP etc) plugin

  4. #14
    Senior Member
    Join Date
    Jan 2011
    Location
    Staffordshire. UK
    Posts
    2,837
    Well thanks Paul.

    As I said in my post replying to Jeff, I had tried this before and I always had both the terminal and Jivelite windows open on the desktop.

    I now realise I was adding the wrong command.

    I thought it need the lxterminal prefix, so was adding

    @lxterminal /home/pi/jivelite/bin/jivelite


    Thanks very much, you're my new best friend Name:  smiley-bounce.gif
Views: 79
Size:  2.7 KB

    ronnie

    I have LMS installed on the same pi, so just need to select fip in Jivelite.

    I'm using Gerrelt's scripts for Squeezelite so should be ableto make fip play on start-up.
    Last edited by Man in a van; 2019-08-08 at 08:15.

  5. #15
    Senior Member Jeff07971's Avatar
    Join Date
    Aug 2011
    Location
    London, England
    Posts
    1,378
    Hi Ronnie,

    Did you download jivelite or compile from git ?

    I get errors when compiling from git

    Jeff
    Players: SliMP3,Squeezebox3 x3,Receiver,SqueezeLite-X,PiCorePlayer x3
    Server: LMS Version: Latest Nightly on Centos 7.6 VM on ESXi 6.5.0U3 on Dell T320
    Plugins: AutoRescan/BBCiPlayer/PowerSave/PowerSwitchIII/Squeezecloud/Spotty/Player Groups
    Remotes: iPeng9/Orangesqueeze/PC/Jivelite/SqueezeLite-X
    Music: 522GB,1.5K albums with 25K songs by 5K artists mostly FLACs

    Want a webapp ? See http://forums.slimdevices.com/showth...Webapp-for-LMS

  6. #16
    Senior Member
    Join Date
    Jan 2011
    Location
    Staffordshire. UK
    Posts
    2,837
    Hi Jeff

    Just cloned into git after building luajit 2.0. see post #12

  7. #17
    Senior Member Jeff07971's Avatar
    Join Date
    Aug 2011
    Location
    London, England
    Posts
    1,378
    Quote Originally Posted by Man in a van View Post
    Hi Jeff

    Just cloned into git after building luajit 2.0. see post #12
    Thanks Ronnie,

    lua is what I was missing !

    Jeff
    Players: SliMP3,Squeezebox3 x3,Receiver,SqueezeLite-X,PiCorePlayer x3
    Server: LMS Version: Latest Nightly on Centos 7.6 VM on ESXi 6.5.0U3 on Dell T320
    Plugins: AutoRescan/BBCiPlayer/PowerSave/PowerSwitchIII/Squeezecloud/Spotty/Player Groups
    Remotes: iPeng9/Orangesqueeze/PC/Jivelite/SqueezeLite-X
    Music: 522GB,1.5K albums with 25K songs by 5K artists mostly FLACs

    Want a webapp ? See http://forums.slimdevices.com/showth...Webapp-for-LMS

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •