Home of the Squeezebox™ & Transporter® network music players.
Results 1 to 7 of 7
  1. #1
    Junior Member
    Join Date
    Jan 2007
    Location
    Germany
    Posts
    21

    Picoreplayer auf Raspberry Pi Zero W Wlan geht nicht

    Hallo in die Runde,
    ich versuche, bisher vergeblich, den Picoreplayer auf meinem Zero W zum Laufen zu bringen.
    Es scheitert am Wlan. Der Player verbindet sich nicht oder das Wlan ist deaktiviert?
    Habe keine Vermutung, woran es liegen k÷nnte. Meine wpa_supplicant.conf sieht so aus:

    # Maintained by user
    ctrl_interface=/var/run/wpa_supplicant
    ctrl_interface_group=staff
    # Two Character Country Code
    country="DE"
    update_config=1

    network={
    ssid="Meine SSID"
    psk="mein Wlan-Key"
    key_mgmt=WPA-PSK
    auth_alg=OPEN
    }
    Sieht jemand einen Fehler?
    freue mich Řber einen Tip.
    Recht sch÷nen Dank.

  2. #2
    Senior Member paul-'s Avatar
    Join Date
    Jan 2013
    Posts
    2,283
    How are you creating the file. With windows? Which editor. Make sure this is saved with Unix line endings.
    piCorePlayer a small player for the Raspberry Pi in RAM.
    Homepage: https://www.picoreplayer.org

    Please donate if you like the piCorePlayer

  3. #3
    Junior Member
    Join Date
    Jan 2007
    Location
    Germany
    Posts
    21
    Yes, i used notepad++ under windows 10.
    The EOL Conversion for the file was Unix(LF).
    So should be fine?

  4. #4
    Senior Member paul-'s Avatar
    Join Date
    Jan 2013
    Posts
    2,283
    Yes. Then take a look at your SSID and password fields. I'm sure you changed them when posting, but make sure they are correct.

    What is your AP setup. What channel are you using? Make sure it is really valid for DE.
    piCorePlayer a small player for the Raspberry Pi in RAM.
    Homepage: https://www.picoreplayer.org

    Please donate if you like the piCorePlayer

  5. #5
    Junior Member
    Join Date
    Jan 2007
    Location
    Germany
    Posts
    21
    First of all, Paul, thankyou for helping me.
    My AP is a AVM Fritzbox 7590. The Wifi-Channel
    is 6. And of course i have been inserted my correct
    SSID and key several times.
    Any further ideas?
    One remark, the wifi works.
    Had no problems with Max2play on my
    Raspberry Zero W.

  6. #6
    Senior Member sbp's Avatar
    Join Date
    Apr 2010
    Location
    Denmark
    Posts
    1,165
    Hi did you enable wifi on pCP?
    See our help page:
    http://picoreplayer.org/how_to_setup...ethernet.shtml

    /Steen
    piCorePlayer a small player for the Raspberry Pi in RAM.
    Homepage: https://www.picoreplayer.org

    Please donate if you like piCorePlayer

  7. #7
    Junior Member
    Join Date
    Jan 2007
    Location
    Germany
    Posts
    21
    I configured the wpa-supplicant.conf, because the raspi zero W does not have ethernet.
    And i have no usb to ethernet adapter.
    But i found now a solution. Not really elegant, but it works.
    Put the SD Card into Raspberry 3. Connected over ethernet i could configure the wifi.
    Then back in to my raspberry zero and wifi worked.
    I am shure that the problem was the wrong naming/format of the wpa_supplicant.conf.
    I was not able to change wifi Settings with my modified wpa_supplicant.conf.
    I was forced to burn a untouched 5.0 picoreplayer image again.
    Now i could save the wifi settings.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •