Home of the Squeezebox™ & Transporter® network music players.
Page 61 of 81 FirstFirst ... 1151596061626371 ... LastLast
Results 601 to 610 of 803
  1. #601
    Senior Member Jeff07971's Avatar
    Join Date
    Aug 2011
    Location
    London, England
    Posts
    1,415
    Quote Originally Posted by paul- View Post
    Jeff,

    I'll dump the entire site cache, but if that doesn't get it you can switch to our mirror. Its the sourceforge site, so it might be a bit slower.

    Attachment 28677
    That did the trick !

    Thanks Paul

    Sorry I keep forgetting the mirror repo ! (Though I did not change to it this time)

    Jeff
    Players: SliMP3,Squeezebox3 x3,Receiver,SqueezeLite-X,PiCorePlayer x3
    Server: LMS Version: Latest Nightly on Centos 8.0 VM on ESXi 6.5.0U3 on Dell T320
    Plugins: AutoRescan/BBCiPlayer/PowerSave/PowerSwitchIII/Squeezecloud/Spotty/Player Groups
    Remotes: iPeng9/Orangesqueeze/PC/Jivelite/SqueezeLite-X
    Music: 522GB,1.5K albums with 25K songs by 5K artists mostly FLACs

    Want a webapp ? See http://forums.slimdevices.com/showth...Webapp-for-LMS

  2. #602
    Junior Member
    Join Date
    Dec 2019
    Posts
    6
    Quote Originally Posted by paul- View Post
    Because your not using the proper device. The device format changed in recent versions of bluealsa. Take a look here https://github.com/Arkq/bluez-alsa.

    If you are just trying to play from your phone.
    1) Install pCP Streamer
    2) Pair Phone
    3) Connect Phone
    4) Start playing from your phone
    5) Connect to stream (You need to make sure that you start playing the stream after your phone is connected, since the device name is not known until the phone connects.)
    Thanks for the link that's a bit closer so the correct device is:

    bluealsa:SRV=org.bluealsa,DEV=xx:xx:xx:xx:xx:xx,PR OFILE=a2dp

    I can record audio and wavin works for me now but I can't seem to get the streaming working
    if I leave the device blank or if I put the above in I still don't get any audio
    I presume I can just use the url in the example http://<address>:9100/S16_LE/44100/2/F

    I do get an error when saving the streaming settings either when it's blank or when I use the above device name:

    [ ERROR ] Unable to determine Card Number to setup pCP Streamer

    Also I was wondering if we could just the alsa dmix facility to have both the player and a bluetooth without the streamer?

  3. #603
    At bit more on being unable to map GPIO 20 via gpio-key:

    I get this in the kernel log:

    Code:
    [   23.481474] input: button@14 as /devices/platform/button@14/input/input0
    [   23.657371] input: button@10 as /devices/platform/button@10/input/input1
    [   23.690642] input: button@6 as /devices/platform/button@6/input/input2
    [   23.691525] input: button@5 as /devices/platform/button@5/input/input3
    [   24.499870] pinctrl-bcm2835 20200000.gpio: pin gpio20 already requested by button@14; cannot claim for 20203000.i2s
    [   24.499887] pinctrl-bcm2835 20200000.gpio: pin-20 (20203000.i2s) status -22
    [   24.499898] pinctrl-bcm2835 20200000.gpio: could not request pin 20 (gpio20) from group gpio20  on device pinctrl-bcm2835
    [   24.499906] bcm2835-i2s 20203000.i2s: Error applying setting, reverse things back
    I'm using a Pi Zero W, by the way.

  4. #604
    Senior Member
    Join Date
    Apr 2005
    Location
    UK/London
    Posts
    1,970
    Quote Originally Posted by JQW View Post
    At bit more on being unable to map GPIO 20 via gpio-key:
    Did you get that 4th button to work with the official software set-up from Pimoroni - while sound was playing?
    I ask because I didn't think that sharing the I2S pin with input GPIO 20 would work.
    Paul Webster
    http://dabdig.blogspot.com
    Author Radio France (FIP etc) plugin

  5. #605
    The Pimoroni software install worked - that button was mapped to Volume Up.

  6. #606
    Senior Member chill's Avatar
    Join Date
    Mar 2007
    Location
    Nottingham, UK
    Posts
    1,373
    I have the four buttons working well under pCP6-b7, using sbpd. Buttons A and B (GPIO 5 and 6) control volume, and X and Y (GPIO 16 and 20) control 'fwd' and 'rew' (I've also programmed 'long press' commands as well). None of the buttons interferes with playback.

    Looking forward to JQW's consolidated instructions for getting the screen to work under pCP/Jivelite. I can't even get it to display the boot up messages yet, so if the steps to achieve that could be detailed here I'd be grateful.

  7. #607
    Senior Member
    Join Date
    Apr 2005
    Location
    UK/London
    Posts
    1,970
    Iĺve learned something new.
    So between you it is done!
    Just need to combine efforts and document it now.
    Paul Webster
    http://dabdig.blogspot.com
    Author Radio France (FIP etc) plugin

  8. #608
    Member
    Join Date
    Jan 2007
    Location
    Denmark
    Posts
    70

    USB3 Audio output

    Hi

    Just a short Question.
    Does the Picoreplayer 6.0 support Audio out on the Pi4 USB3 port?

    Br
    Caad

  9. #609
    Senior Member paul-'s Avatar
    Join Date
    Jan 2013
    Posts
    2,488
    Quote Originally Posted by Caad View Post
    Hi

    Just a short Question.
    Does the Picoreplayer 6.0 support Audio out on the Pi4 USB3 port?

    Br
    Caad
    What DAC do you wish to use? Connecting a USB dac to the USB3 port should work just fine. Most should work, but I'm sure there are some problems, and I have not seen a good list of compatible DAC's.
    piCorePlayer a small player for the Raspberry Pi in RAM.
    Homepage: https://www.picoreplayer.org

    Please donate if you like the piCorePlayer

  10. #610
    Senior Member paul-'s Avatar
    Join Date
    Jan 2013
    Posts
    2,488
    Quote Originally Posted by msillence View Post

    I can record audio and wavin works for me now but I can't seem to get the streaming working
    if I leave the device blank or if I put the above in I still don't get any audio
    I presume I can just use the url in the example http://<address>:9100/S16_LE/44100/2/F

    I do get an error when saving the streaming settings either when it's blank or when I use the above device name:

    [ ERROR ] Unable to determine Card Number to setup pCP Streamer

    Also I was wondering if we could just the alsa dmix facility to have both the player and a bluetooth without the streamer?

    On my system, I leave the streamer output setting blank. On the bluetooth page, can you look at the logs after you connect your phone. We need to make sure its connecting properly. It should look very similar to this.....https://forums.slimdevices.com/showt...l=1#post956416 Note the last line that says that it is writing the device string for pCP streamer.

    Yes, you are correct on the URL......note that bluetooth may only work with /S16_LE/44100 or possibly /S16_LE/48000
    piCorePlayer a small player for the Raspberry Pi in RAM.
    Homepage: https://www.picoreplayer.org

    Please donate if you like the piCorePlayer

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •