Home of the Squeezebox™ & Transporter® network music players.
Page 49 of 87 FirstFirst ... 39474849505159 ... LastLast
Results 481 to 490 of 862
  1. #481
    Junior Member
    Join Date
    Nov 2019
    Posts
    1

    Selective USB shutdown

    Hello Paul,

    Is there a chance that you will implement a tweak option in a pCP Tweaks to selectively shutdown unused USB ports?

    This could be useful as potentially it could increase sound quality.

    Thanks in advance!

  2. #482
    Senior Member paul-'s Avatar
    Join Date
    Jan 2013
    Posts
    2,549
    Quote Originally Posted by camel View Post
    Hello Paul,

    Is there a chance that you will implement a tweak option in a pCP Tweaks to selectively shutdown unused USB ports?

    This could be useful as potentially it could increase sound quality.

    Thanks in advance!
    The biggest issue with this is that the procedure is different between all pi devices (I'm not even sure how to do it on all pi boards). And most won't know which situations you can do this safely. You can easily run a script during boot, that would be the best way to handle this.
    piCorePlayer a small player for the Raspberry Pi in RAM.
    Homepage: https://www.picoreplayer.org

    Please donate if you like the piCorePlayer

  3. #483
    Senior Member paul-'s Avatar
    Join Date
    Jan 2013
    Posts
    2,549
    Quote Originally Posted by DomieMic65 View Post
    piCorePlayer v6.0.0-b6
    Squeezelite v1.9.6-1194-pCP
    The DSD/DOP option will show up as long as the squeezelite binary that you are using has the DSD build option.

    With pCP6.0.0-b6, you need at v1.9.6-1198-pCP (Which comes with the image). Seems you got downgraded as I didn't update the main repos. You should be able to run an update again and get back to 1198.
    Last edited by paul-; 2019-11-05 at 20:22.
    piCorePlayer a small player for the Raspberry Pi in RAM.
    Homepage: https://www.picoreplayer.org

    Please donate if you like the piCorePlayer

  4. #484
    Senior Member ralphy's Avatar
    Join Date
    Jan 2006
    Location
    Canada
    Posts
    2,287
    Quote Originally Posted by kidstypike View Post
    Album flow is an Applet you can install on the Touch & Radio. (pic from Squeezeplay below). However, it doesn't appear in the applet list on pCP/Jivelite > Settings > Advanced > Applet Installer.

    Attachment 28478
    Quote Originally Posted by paul- View Post
    Might want to ask that in the jivelite thread. It might have to be manually installed. (Like Custom Clock)
    Erland's repo.xml file needs to have minTarget="0.1" instead of 7.4 for the Album flow applet to be available for jivelite to install.

    Alternately you could host the attached modified xml locally and add it to the lms plugins url list.

    You also need to be running a jivelite version that uses lua 5.1 (like pcp), not the default luajit version and you'll need to make the following change after install.
    Code:
    --- .jivelite/userpath/applets/AlbumFlow/AlbumFlowApplet.lua.orig	2019-11-06 09:47:45.000000000 -0500
    +++ .jivelite/userpath/applets/AlbumFlow/AlbumFlowApplet.lua	2019-11-06 09:58:29.000000000 -0500
    @@ -48,7 +48,7 @@
     
     local SocketHttp       = require("jive.net.SocketHttp")
     local RequestHttp      = require("jive.net.RequestHttp")
    -local json             = require("json")
    +local json             = require("cjson")
     
     local appletManager    = appletManager
     local jiveMain         = jiveMain
    Name:  aflow.jpg
Views: 273
Size:  49.0 KB
    Attached Files Attached Files
    Last edited by ralphy; 2019-11-07 at 07:05. Reason: Added missing aflow.xml
    Ralphy

    1-Touch, 5-Classics, 3-Booms, 1-UE Radio
    Squeezebox client builds donations always appreciated.

  5. #485
    Senior Member DomieMic65's Avatar
    Join Date
    Jul 2019
    Location
    Athens Greece
    Posts
    145
    Quote Originally Posted by paul- View Post
    The DSD/DOP option will show up as long as the squeezelite binary that you are using has the DSD build option.

    With pCP6.0.0-b6, you need at v1.9.6-1198-pCP (Which comes with the image). Seems you got downgraded as I didn't update the main repos. You should be able to run an update again and get back to 1198.
    Thank you... how can I do it?
    From the pCp menu I have no updates shown...
    Main system: Synology DS115j/RPi3b(LMS)/RPi3B+[LnrPS](piCore)/M2Tech EvoDAC Two+[LnrPS]/Densen DM20&30/Spendor SP2/3E
    Head-Fi: Schiit Vali2/Sennheiser HD600 & HD25Alum/Audeze Sine.
    Aditional HW: Allo DigiOne, iFi iDefender, iPurifier, iPower

  6. #486
    Senior Member
    Join Date
    Apr 2005
    Location
    UK/London
    Posts
    2,000
    The XML file that Ralphy referred to does not seem to be attached.
    Basically ... you need a web server where you can host an edited version of Erland's XML file.
    I expect that someone will do it for you soon.
    Paul Webster
    http://dabdig.blogspot.com
    Author Radio France (FIP etc) plugin

  7. #487
    Senior Member DomieMic65's Avatar
    Join Date
    Jul 2019
    Location
    Athens Greece
    Posts
    145
    Quote Originally Posted by Paul Webster View Post
    The XML file that Ralphy referred to does not seem to be attached.
    Basically ... you need a web server where you can host an edited version of Erland's XML file.
    I expect that someone will do it for you soon.
    Can't wait!!!!
    Thank you!!!
    Main system: Synology DS115j/RPi3b(LMS)/RPi3B+[LnrPS](piCore)/M2Tech EvoDAC Two+[LnrPS]/Densen DM20&30/Spendor SP2/3E
    Head-Fi: Schiit Vali2/Sennheiser HD600 & HD25Alum/Audeze Sine.
    Aditional HW: Allo DigiOne, iFi iDefender, iPurifier, iPower

  8. #488
    Senior Member
    Join Date
    Apr 2005
    Location
    UK/London
    Posts
    2,000
    ... I tried but could not get the applet to appear in pCP Jivelite.
    I created my own repo xml - made the change to the .lua file ... made a new zip file ... sha value calculated and put in repo xml
    Added repo xml to my local LMS

    Restarted LMS and JiveLite just in case ... but am not being prompted to install it.
    I have not posted the link to my test repo xml because I don't want people to try it if things not working.

    I'll see if I can work out the problem - but maybe someone else will do it before me.
    Paul Webster
    http://dabdig.blogspot.com
    Author Radio France (FIP etc) plugin

  9. #489
    Senior Member
    Join Date
    Apr 2005
    Location
    UK/London
    Posts
    2,000
    Try this ... it worked for me ... add it to your list of Repos in LMS/Settings/Plugins
    Then go back to your pCP JiveLite and Settings/Avanced/Install Applets (or similar)

    http://www.dabdig.co.uk/slimserver-r...owpcp-repo.xml

    If it does not work I suggest starting a new thread since it is not really related to pCP 6 Beta
    Last edited by Paul Webster; 2019-11-06 at 14:27. Reason: Added some more info
    Paul Webster
    http://dabdig.blogspot.com
    Author Radio France (FIP etc) plugin

  10. #490
    Senior Member DomieMic65's Avatar
    Join Date
    Jul 2019
    Location
    Athens Greece
    Posts
    145
    Well .... I don't know if something has changed from yesterday but after I did an update today (not a full update i did the other day) Squeezelite updated to 1.9.6-1198-pCP
    And DSDs play fine now...
    Excuse my "newbieness"!!

    thank you
    Main system: Synology DS115j/RPi3b(LMS)/RPi3B+[LnrPS](piCore)/M2Tech EvoDAC Two+[LnrPS]/Densen DM20&30/Spendor SP2/3E
    Head-Fi: Schiit Vali2/Sennheiser HD600 & HD25Alum/Audeze Sine.
    Aditional HW: Allo DigiOne, iFi iDefender, iPurifier, iPower

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •