Home of the Squeezebox™ & Transporter® network music players.
Page 52 of 63 FirstFirst ... 242505152535462 ... LastLast
Results 511 to 520 of 629
  1. #511
    Senior Member paul-'s Avatar
    Join Date
    Jan 2013
    Posts
    2,337
    Pretty sure that was fixed in this version......,
    piCorePlayer a small player for the Raspberry Pi in RAM.
    Homepage: https://www.picoreplayer.org

    Please donate if you like the piCorePlayer

  2. #512
    Senior Member kidstypike's Avatar
    Join Date
    Feb 2007
    Location
    Brindle
    Posts
    3,283
    Quote Originally Posted by paul- View Post
    Pretty sure that was fixed in this version......,
    So . . . it probably showed before the b7 update took effect?
    Server - LMS 7.9.2 Pi4B 4GB/pCP 6.0.0-b7 18K library, playlists & LMS cache on SSD (ntfs)
    Study - Pi3B+/pCP 5.0.0/pi screen/HiFiBerry DAC+/jivelite,
    Lounge - Pi2/pCP 5.0.0 > HiFiBerry DIGI+ > AudioEngine DAC1 > AVI DM5
    Dining Room - Squeezebox Boom
    Garage - Pi3B/Pi screen/HiFiBerry DAC+/pCP 5.0.0 > Edifier R980T

    Spares - 2xTouch, 1xSB3, 1xRadio, 6xRPi

  3. #513
    Senior Member paul-'s Avatar
    Join Date
    Jan 2013
    Posts
    2,337
    Update would not be totally effective until after the reboot. That was the first page that appears when you press "Update pCP" Correct?
    piCorePlayer a small player for the Raspberry Pi in RAM.
    Homepage: https://www.picoreplayer.org

    Please donate if you like the piCorePlayer

  4. #514
    Senior Member kidstypike's Avatar
    Join Date
    Feb 2007
    Location
    Brindle
    Posts
    3,283
    Quote Originally Posted by paul- View Post
    Update would not be totally effective until after the reboot. That was the first page that appears when you press "Update pCP" Correct?
    Yes, exactly!

    But I didn't know when I posted, that you'd already fixed it.
    Server - LMS 7.9.2 Pi4B 4GB/pCP 6.0.0-b7 18K library, playlists & LMS cache on SSD (ntfs)
    Study - Pi3B+/pCP 5.0.0/pi screen/HiFiBerry DAC+/jivelite,
    Lounge - Pi2/pCP 5.0.0 > HiFiBerry DIGI+ > AudioEngine DAC1 > AVI DM5
    Dining Room - Squeezebox Boom
    Garage - Pi3B/Pi screen/HiFiBerry DAC+/pCP 5.0.0 > Edifier R980T

    Spares - 2xTouch, 1xSB3, 1xRadio, 6xRPi

  5. #515
    Senior Member
    Join Date
    Jan 2011
    Location
    Staffordshire. UK
    Posts
    2,916
    Tried to update a rpi4b (32bit kernel) this Sunday morning.

    The update failed:

    Code:
    [ INFO ] You are currently using piCorePlayer6.0.0-b6
    [ INFO ] Boot partition size required: 62000. Boot partition size is: 131072
    [ INFO ] Space required for update and extensions: 12000k
    [  OK  ] Free space: 35732k - Required space: 12000k
    [ INFO ] You are downloading piCorePlayer6.0.0-b7
    [ INFO ] PCP_DL=/10.x/armv7/tcz
    [  OK  ] Free space: 35732k - Required space: 12472k
    [ INFO ] Step 3A. Downloading new kernel modules: alsa-modules net-usb wireless
    [ INFO ] Downloading: alsa-modules-4.19.80-pcpCore_v8.tcz
    [ INFO ] Checking MD5 of: alsa-modules-4.19.80-pcpCore_v8.tcz.....FAIL
    [ ERROR ] There was a error downloading alsa-modules-4.19.80-pcpCore_v8.tcz.
    [ INFO ] Retrying extension alsa-modules-4.19.80-pcpCore_v8.tcz...in 5 seconds.
    [ INFO ] Downloading: alsa-modules-4.19.80-pcpCore_v8.tcz
    [ INFO ] Checking MD5 of: alsa-modules-4.19.80-pcpCore_v8.tcz.....FAIL
    [ ERROR ] There was a error downloading alsa-modules-4.19.80-pcpCore_v8.tcz.
    [ INFO ] Retrying extension alsa-modules-4.19.80-pcpCore_v8.tcz...in 5 seconds.
    [ INFO ] Downloading: alsa-modules-4.19.80-pcpCore_v8.tcz
    [ INFO ] Checking MD5 of: alsa-modules-4.19.80-pcpCore_v8.tcz.....FAIL
    [ ERROR ] There was a error downloading alsa-modules-4.19.80-pcpCore_v8.tcz.
    [ ERROR ] Max retries reached.
    [ INFO ] Downloading: net-usb-4.19.80-pcpCore_v8.tcz
    [ INFO ] Checking MD5 of: net-usb-4.19.80-pcpCore_v8.tcz.....FAIL
    [ ERROR ] There was a error downloading net-usb-4.19.80-pcpCore_v8.tcz.
    [ INFO ] Retrying extension net-usb-4.19.80-pcpCore_v8.tcz...in 5 seconds.
    [ INFO ] Downloading: net-usb-4.19.80-pcpCore_v8.tcz
    [ INFO ] Checking MD5 of: net-usb-4.19.80-pcpCore_v8.tcz.....FAIL
    [ ERROR ] There was a error downloading net-usb-4.19.80-pcpCore_v8.tcz.
    [ INFO ] Retrying extension net-usb-4.19.80-pcpCore_v8.tcz...in 5 seconds.
    [ INFO ] Downloading: net-usb-4.19.80-pcpCore_v8.tcz
    [ INFO ] Checking MD5 of: net-usb-4.19.80-pcpCore_v8.tcz.....FAIL
    [ ERROR ] There was a error downloading net-usb-4.19.80-pcpCore_v8.tcz.
    [ ERROR ] Max retries reached.
    [ INFO ] Downloading: wireless-4.19.80-pcpCore_v8.tcz
    [ INFO ] Checking MD5 of: wireless-4.19.80-pcpCore_v8.tcz.....FAIL
    [ ERROR ] There was a error downloading wireless-4.19.80-pcpCore_v8.tcz.
    [ INFO ] Retrying extension wireless-4.19.80-pcpCore_v8.tcz...in 5 seconds.
    [ INFO ] Downloading: wireless-4.19.80-pcpCore_v8.tcz
    [ INFO ] Checking MD5 of: wireless-4.19.80-pcpCore_v8.tcz.....FAIL
    [ ERROR ] There was a error downloading wireless-4.19.80-pcpCore_v8.tcz.
    [ INFO ] Retrying extension wireless-4.19.80-pcpCore_v8.tcz...in 5 seconds.
    [ INFO ] Downloading: wireless-4.19.80-pcpCore_v8.tcz
    [ INFO ] Checking MD5 of: wireless-4.19.80-pcpCore_v8.tcz.....FAIL
    [ ERROR ] There was a error downloading wireless-4.19.80-pcpCore_v8.tcz.
    [ ERROR ] Max retries reached.
    I update the kernel on the card and the update suceeded but no sound card was found.

    Code:
    Log from Boot after insitu upgrade
    No sound card found
    
    Starting piCorePlayer v6.0.0-b7 startup...
    Checking for boot files on mmcblk0p1...
      Trying to mount /dev/mmcblk0p1.
      ssh file found on mmcblk0p1.
      newpcp.cfg not found on mmcblk0p1.
    Setting default piCorePlayer repository...
    Generating sound card drop-down list...
    Loading configuration file... Done.
    Loading pcp-lms-functions... Done.
    cat: can't open '/proc/asound/cards': No such file or directory
    Waiting for soundcard ALSA to populate.aplay: device_list:272: no soundcards found...
    .aplay: device_list:272: no soundcards found...
    .aplay: device_list:272: no soundcards found...
    .aplay: device_list:272: no soundcards found...
    .aplay: device_list:272: no soundcards found...
    .aplay: device_list:272: no soundcards found...
    .aplay: device_list:272: no soundcards found...
    .aplay: device_list:272: no soundcards found...
    .aplay: device_list:272: no soundcards found...
    .aplay: device_list:272: no soundcards found...
    .aplay: device_list:272: no soundcards found...
    .aplay: device_list:272: no soundcards found...
    .aplay: device_list:272: no soundcards found...
    .aplay: device_list:272: no soundcards found...
    .aplay: device_list:272: no soundcards found...
    .aplay: device_list:272: no soundcards found...
    .aplay: device_list:272: no soundcards found...
    .aplay: device_list:272: no soundcards found...
    .aplay: device_list:272: no soundcards found...
    .aplay: device_list:272: no soundcards found...
    .aplay: device_list:272: no soundcards found...
    .aplay: device_list:272: no soundcards found...
    .aplay: device_list:272: no soundcards found...
    .aplay: device_list:272: no soundcards found...
    .aplay: device_list:272: no soundcards found...
    .aplay: device_list:272: no soundcards found...
    .aplay: device_list:272: no soundcards found...
    .aplay: device_list:272: no soundcards found...
    .aplay: device_list:272: no soundcards found...
    .aplay: device_list:272: no soundcards found...
    .aplay: device_list:272: no soundcards found...
    .aplay: device_list:272: no soundcards found...
    .aplay: device_list:272: no soundcards found...
    .aplay: device_list:272: no soundcards found...
    .aplay: device_list:272: no soundcards found...
    .aplay: device_list:272: no soundcards found...
    .aplay: device_list:272: no soundcards found...
    .aplay: device_list:272: no soundcards found...
    .aplay: device_list:272: no soundcards found...
    .aplay: device_list:272: no soundcards found...
    .aplay: device_list:272: no soundcards found...
     Failed to find ALSA (42).
     Done (42).
    Waiting for network.................. Done (18).
    aplay: device_list:272: no soundcards found...
    aplay: device_list:272: no soundcards found...
    Checking for PCM input card... Done.
    Starting Openssh server... Done.
    Starting Squeezelite and/or Shairport-sync...
    [ INFO ] Starting Squeezelite player: Squeezelite...
     Done.
    Starting httpd web server... Done.
    Setting CPU scaling governor to ondemand... Done.
    Creating static footer... Done.
    
    Finished piCorePlayer v6.0.0-b7 startup.
    
    To setup piCorePlayer, use the web interface via a browser:
     - http://192.168.1.15
    
    Press [Enter] to access console.
    
    In the background, ntpd is syncing time between piCorePlayer and the internet.
    A large offset between 1970 and now is normal.
    I changed the output but the result was the same

    Name:  piCoreplayer audio settings.png
Views: 232
Size:  81.7 KB

    ronnie

    going for a fresh download

  6. #516
    Senior Member
    Join Date
    Jan 2011
    Location
    Staffordshire. UK
    Posts
    2,916
    Downloaded the new beta image and the install proceed without any problems.

    Sound card present on boot.

    Code:
    Starting piCorePlayer v6.0.0-b7 startup...
    Checking for boot files on mmcblk0p1...
      Trying to mount /dev/mmcblk0p1.
      ssh file found on mmcblk0p1.
      newpcp.cfg not found on mmcblk0p1.
    Setting default piCorePlayer repository...
    Generating sound card drop-down list...
    Loading configuration file... Done.
    Loading pcp-lms-functions... Done.
    Waiting for soundcard IQaudIODAC to populate. Done (1).
    Waiting for network................................................... No network found! Done (52).
    Checking for PCM input card... Done.
    Starting Openssh server... Done.
    Starting Squeezelite and/or Shairport-sync...
    [ INFO ] Starting Squeezelite player: Squeezelite...
     Done.
    Auto set timezone settings, can be updated on tweaks page...
    There was a problem reaching sites for automatic timezone, please set manually on tweaks page.
    Starting httpd web server... Done.
    Setting CPU scaling governor to ondemand... Done.
    Creating static footer... Done.
    
    Finished piCorePlayer v6.0.0-b7 startup.
    
    To setup piCorePlayer, use the web interface via a browser:
    
    Press [Enter] to access console.
    
    In the background, ntpd is syncing time between piCorePlayer and the internet.
    A large offset between 1970 and now is normal.
    Note:

    The IP address of the pi is often missing from the boot print out

    and I still needed to use the beta tab for the full list of sound cards.

    ronnie

  7. #517
    Senior Member paul-'s Avatar
    Join Date
    Jan 2013
    Posts
    2,337
    What pi are you using? Can you get me your revision code? It’s on the Diagnostics / Raspberry Pi page.

    As for the network address, you dhcp server is taking a long time to respond.....is that normal for you? The Wait for network is timing out

    Thanks for the update report, I’ll check it again.
    Last edited by paul-; 2019-11-17 at 06:12.
    piCorePlayer a small player for the Raspberry Pi in RAM.
    Homepage: https://www.picoreplayer.org

    Please donate if you like the piCorePlayer

  8. #518
    Senior Member
    Join Date
    Jan 2011
    Location
    Staffordshire. UK
    Posts
    2,916
    Quote Originally Posted by paul- View Post
    What pi are you using? Can you get me your revision code? It’s on the Diagnostics / Raspberry Pi page.

    As for the network address, you dhcp server is taking a long time to respond.....is that normal for you? The Wait for network is timing out

    Thanks for the update report, I’ll check it again.
    Hi Paul

    Re the Network address, yes, that's normal for me, sometimes it shows and sometimes it doesn't.

    Name:  arevisionnumberpcp.png
Views: 200
Size:  12.8 KB

    ronnie

    Edit:

    I just remembered that with this boot I did get an IP address The number at the end of the "waiting for network" line was 18
    Last edited by Man in a van; 2019-11-17 at 07:25. Reason: comma

  9. #519
    Senior Member
    Join Date
    Jan 2011
    Location
    Staffordshire. UK
    Posts
    2,916
    The previous post was from the SD card with the image that does not load ALSA.

    Here is the same pi, with the image made from a fresh download of the beta7. Squeezelite works fine on this.

    Here is the Boot log, with no IP address:

    Code:
    Starting piCorePlayer v6.0.0-b7 startup...
    Checking for boot files on mmcblk0p1...
      Trying to mount /dev/mmcblk0p1.
      ssh file found on mmcblk0p1.
      newpcp.cfg not found on mmcblk0p1.
    Setting default piCorePlayer repository...
    Generating sound card drop-down list...
    Loading configuration file... Done.
    Loading pcp-lms-functions... Done.
    Waiting for soundcard IQaudIODAC to populate. Done (1).
    Waiting for network................................................... No network found! Done (52).
    Checking for PCM input card... Done.
    Starting Openssh server... Done.
    Starting Squeezelite and/or Shairport-sync...
    [ INFO ] Starting Squeezelite player: Squeezelite...
     Done.
    Auto set timezone settings, can be updated on tweaks page...
    There was a problem reaching sites for automatic timezone, please set manually on tweaks page.
    Starting httpd web server... Done.
    Setting CPU scaling governor to ondemand... Done.
    Creating static footer... Done.
    
    Finished piCorePlayer v6.0.0-b7 startup.
    
    To setup piCorePlayer, use the web interface via a browser:
    
    Press [Enter] to access console.
    
    In the background, ntpd is syncing time between piCorePlayer and the internet.
    A large offset between 1970 and now is normal.
    Also note the timezone has not loaded (I have also seen this before).

    pCP v5 I don't recall seeing these differences

  10. #520
    Senior Member paul-'s Avatar
    Join Date
    Jan 2013
    Posts
    2,337
    Think I got it this time Ronnie. Missing an * globbing all of the 4B cards.

    As for the network, most of the time I get an address in about 3 or 4 seconds, but Occasionally when swapping SD cards in the same board, it causes the DHCP server to delay. Not having a network address does indeed cause problems. On the WIFI page, there is a setting to increase the wait for network delay. (It's on the wifi, since that's were we see the problem the most, but it will also set the wait delay for ethernet)

    Edit: The 32bit update issue should be fixed
    Last edited by paul-; 2019-11-17 at 09:53.
    piCorePlayer a small player for the Raspberry Pi in RAM.
    Homepage: https://www.picoreplayer.org

    Please donate if you like the piCorePlayer

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •