Home of the Squeezebox™ & Transporter® network music players.
Page 2 of 61 FirstFirst 12341252 ... LastLast
Results 11 to 20 of 609
  1. #11
    Senior Member
    Join Date
    Dec 2005
    Location
    Sutton Coldfield, UK
    Posts
    594
    Updated a Server/Player and two players today From 4.1 to 5.0 using the hotfix/update method.

    All seem to working fine. Took about 5 minutes each.

    Thanks pcp team.
    Music Store & VPN Server: Synology DS215J NAS
    Home Server/Study Player:
    LMS 7.9.2 on Pi 3B pCp 6.0 (beta) Server/IQ Audio DAC+
    Refurbished 1962 RCA Stereo Console Server/Player LMS 7.9.2 on Pi 4B pCp 6.0 (beta) Server/IQ Audio DAC+
    RF Headphone Player Squeezelite/Jivelite on Pi3B pCp 6.0 (beta) IQ Audio DAC+
    Homeplug/LAN Players: Squeezelite on 2x Windows 10 PC's,
    VPN Mobile & Car Player: SqueezeControl/SqueezePlayer on Android Phone

  2. #12
    Senior Member
    Join Date
    Jun 2012
    Posts
    250
    Quote Originally Posted by paul- View Post
    Probably a cache on our CDN, I thought I reset it, but I was having network problems this morning. I just reset it again, give it a shot.
    Yep. That fixed it. Thanks.

  3. #13
    Senior Member chill's Avatar
    Join Date
    Mar 2007
    Posts
    1,355
    Did the in-place upgrade on my main LMS server this morning. Worked without a hitch.

  4. #14
    Senior Member
    Join Date
    Sep 2009
    Location
    Norway
    Posts
    200
    Thank you for the new version and thank you for the added DAC support.

    /Claus

    EDIT 2:14 pm: I loaded the piCorePlayer web-interface and pushed the Update pCP on the main page and followed the instructions. Easy. I just wish to mention that my player updated to version 4.12 first (I was on 4.10) and a hotfix was required, etc.

    As the web interface was reloaded I could see it wasn't version 5.0.0, so I ran the update a second time. Four steps were required. The piCorePlayer rebooted twice. Again it was easy, no problems.
    Last edited by cfuttrup; 2019-06-10 at 05:16. Reason: Update successful

  5. #15

    Samba Issue

    Download & update ran well, however Samba is refusing to start. Have re-booted, provided a Sever Workgroup as it was removed/missing - still won't start.

    Have also tried 'updating' back to 4.1, but that process fails, so will have to manually re-install.

    Stuart

  6. #16
    Senior Member
    Join Date
    Mar 2010
    Posts
    119
    Quote Originally Posted by pputzer View Post
    I'll investigate more tomorrow, but for now I'm back on beta 9:
    With 5.0.0, WIFI was flaky - slow ssh, sometimes the player even dropped out from being listed in the LMS web interface. Issues disappeared when I rebooted into b9.
    Just to be sure, I re-installed the audio kernel image and only added the iperf3 package before running the diagnostics:

    Code:
    Test Complete. Summary Results:
    [ ID] Interval           Transfer     Bitrate         Jitter    Lost/Total Datagrams
    [  5]   0.00-21.21  sec   759 MBytes   300 Mbits/sec  0.000 ms  0/555748 (0%)  sender
    [  5]   0.00-21.00  sec   148 MBytes  59.2 Mbits/sec  0.174 ms  436688/544068 (80%)  receiver
    CPU Utilization: local/receiver 6.0% (0.7%u/5.3%s), remote/sender 0.8% (0.1%u/0.7%s)
    Where as with beta 9, I get the following results:
    Code:
    Test Complete. Summary Results:
    [ ID] Interval           Transfer     Bitrate         Jitter    Lost/Total Datagrams
    [  5]   0.00-21.12  sec   755 MBytes   300 Mbits/sec  0.000 ms  0/550827 (0%)  sender
    [  5]   0.00-21.00  sec   265 MBytes   106 Mbits/sec  0.084 ms  355604/547567 (65%)  receiver
    CPU Utilization: local/receiver 21.6% (2.7%u/18.9%s), remote/sender 0.7% (0.1%u/0.6%s)
    Both are with the default "download" setting. When running iperf3 from the command line using soundcheck's settings (i.e. non-reverse mode, CLI command "iperf3 -c 192.xxx.xxx.xx -V -i 1 -A 1 -u -b 0 -t 60"), I get the following results onon 5.0.0:
    Code:
    Test Complete. Summary Results:
    [ ID] Interval           Transfer     Bitrate         Jitter    Lost/Total Datagrams
    [  5]   0.00-60.00  sec   811 MBytes   113 Mbits/sec  0.000 ms  0/586940 (0%)  sender
    [  5]   0.00-60.08  sec   160 MBytes  22.3 Mbits/sec  0.378 ms  471148/586935 (80%)  receiver
    CPU Utilization: local/sender 6.8% (0.5%u/6.3%s), remote/receiver 0.3% (0.0%u/0.2%s)
    And on beta 9:
    Code:
    Test Complete. Summary Results:
    [ ID] Interval           Transfer     Bitrate         Jitter    Lost/Total Datagrams
    [  5]   0.00-60.00  sec   838 MBytes   117 Mbits/sec  0.000 ms  0/606790 (0%)  sender
    [  5]   0.00-60.05  sec   838 MBytes   117 Mbits/sec  0.219 ms  1/606779 (0.00016%)  receiver
    CPU Utilization: local/sender 21.0% (1.4%u/19.7%s), remote/receiver 1.1% (0.2%u/0.9%s)
    Edit: Doh! I forgot to change the WIFI country code. No wonder there were issues
    Last edited by pputzer; 2019-06-10 at 04:44. Reason: Found out what I did wrong

  7. #17
    Senior Member paul-'s Avatar
    Join Date
    Jan 2013
    Posts
    2,350
    Samba might need to be removed and reinstalled.
    piCorePlayer a small player for the Raspberry Pi in RAM.
    Homepage: https://www.picoreplayer.org

    Please donate if you like the piCorePlayer

  8. #18
    Senior Member
    Join Date
    Jan 2011
    Location
    Staffordshire. UK
    Posts
    2,919
    I have done the hotfix and updated to v5.0.0.

    Running LMS and a cirruslogic dac on a rpi 1B.

    I can't seem to perform a manual update of LMS.

    Code:
    tc@cirruslogic:~$ cd /tmp
    tc@cirruslogic:/tmp$ wget https://raw.githubusercontent.com/piCorePlayer/lms-upd
    ate-script/Master/lms-update.sh
    Connecting to raw.githubusercontent.com (151.101.0.133:443)
    lms-update.sh        100% |********************************| 13464  0:00:00 ETA
    tc@cirruslogic:/tmp$ chmod 755 lms-update.sh
    tc@cirruslogic:/tmp$ sudo ./lms-update.sh --mm 7.9.2 -s -r -u
    
    ###############################################################
    
      This script will update the Logitech Media Server extension
    
      usage: ./lms-update.sh [-u] [-d] [-m] [-r] [-s] [-t]
                -u Unattended Execution
                -d Debug, Temp files not erased
                -m Manual download Link Check for LMS update
                -r Reload LMS after Update
                -s Skip Update from GitHub
                -t Test building, but do not move extension to tce directory
                --mm <version> Force the version you want to update. (eg 7.9.1)
    
           Unattended Operation Enabled
           Manual Download Link Check Enabled Version:7.9.2
           Automatic Reload Enabled
           Skipping Update
    ###############################################################
    
    Press Enter to continue, or Ctrl-c to exit and change options
    Copying and Running script to tmp so we can automatically reload LMS later
    Performing manual check for update link, Current Version is: 7.9.2 r1558382969.
    Connecting to www.mysqueezebox.com (34.244.221.118:80)
    tmp.CfjPdb           100% |*********************************************************************************************************************************************|     2  0:00:00 ETA
    Revision 7.9.2 r1558382969 is the latest. No Update Needed.
    
    DONE.
    tc@cirruslogic:/tmp$
    Any ideas?

    Logitech Media Server Version: 7.9.2 - 1558382969 @ Tue May 21 06:27:23 CEST 2019
    Hostname: cirruslogic
    Server IP Address: 192.168.1.**
    Server HTTP Port Number: 9000
    Operating system: piCore - EN - utf8
    Platform Architecture: armv7l-linux
    Perl Version: 5.28.0 - arm-linux-gnueabihf-thread-multi-64int
    Audio::Scan: 1.02
    IO::Socket::SSL: 2.060
    Database Version: DBD::SQLite 1.58 (sqlite 3.22.0)
    Total Players Recognized: 1

    Thanks

    ronnie

  9. #19
    Senior Member
    Join Date
    Jun 2012
    Posts
    250
    I've just been working through updating some of mine with a few oddities

    1) There's something odd with USB devices and particularly sysdefault.... I updated one of my players which is USB and had sysdefault:CARD=DAC as the player - which is listed in the available list. Squeezelite won't start. However, switching to front:CARD=DAC,DEV=0 does work. Both are just picked from the available list.

    Code:
    Available output devices (click to use):
    
    null
    sysdefault:CARD=ALSA
    sysdefault:CARD=DAC
    front:CARD=DAC,DEV=0
    surround21:CARD=DAC,DEV=0
    surround40:CARD=DAC,DEV=0
    surround41:CARD=DAC,DEV=0
    surround50:CARD=DAC,DEV=0
    surround51:CARD=DAC,DEV=0
    surround71:CARD=DAC,DEV=0
    iec958:CARD=DAC,DEV=0
    Same problem on a different player

    Code:
    Available output devices (click to use):
    
    null
    sysdefault:CARD=ALSA
    sysdefault:CARD=XMC1
    front:CARD=XMC1,DEV=0
    surround21:CARD=XMC1,DEV=0
    surround40:CARD=XMC1,DEV=0
    surround41:CARD=XMC1,DEV=0
    surround50:CARD=XMC1,DEV=0
    surround51:CARD=XMC1,DEV=0
    surround71:CARD=XMC1,DEV=0
    iec958:CARD=XMC1,DEV=0
    Here, sysdefault:CARD=XMC1 doesn't work, but front:CARD=XMC1,DEV=0 does. The sysdefault devices worked fine with 4.x

    2) You need to deinstall and reinstall equaliser to get it to work. I saw a message on the upgrade that it had detected equal and was downloading, but when you go to configure equal on the tweaks page, it says it's not installed and to try rebooting, which didn't change it. You need to remove and readd it to be able to go into configure.

    3) One of my players uses an IR remote (an old microsoft USB device on lirc01). The last part of the download failed with

    Code:
    [ INFO ] Downloading: media-rc-4.14.81-pcpCore.tcz
    [ INFO ] Checking MD5 of: media-rc-4.14.81-pcpCore.tcz.....FAIL
    [ ERROR ] There was a error downloading pcp-irtools.tcz.
    [ INFO ] Retrying extension pcp-irtools.tcz...in 5 seconds.
    [ INFO ] Downloading: media-rc-4.14.81-pcpCore.tcz
    [ INFO ] Checking MD5 of: media-rc-4.14.81-pcpCore.tcz.....FAIL
    [ ERROR ] There was a error downloading pcp-irtools.tcz.
    [ INFO ] Retrying extension pcp-irtools.tcz...in 5 seconds.
    [ INFO ] Downloading: media-rc-4.14.81-pcpCore.tcz
    [ INFO ] Checking MD5 of: media-rc-4.14.81-pcpCore.tcz.....FAIL
    [ ERROR ] There was a error downloading pcp-irtools.tcz.
    [ INFO ] Retrying extension pcp-irtools.tcz...in 5 seconds.
    [ INFO ] Downloading: media-rc-4.14.81-pcpCore.tcz
    [ INFO ] Checking MD5 of: media-rc-4.14.81-pcpCore.tcz.....FAIL
    [ ERROR ] There was a error downloading pcp-irtools.tcz.
    Interesting that it's trying to download pcp-irtools.tcz but actually downloading pcpCore.tcz?

    pete S

  10. #20
    Senior Member wl1's Avatar
    Join Date
    Jan 2007
    Location
    UK
    Posts
    118
    For Info:
    I went from 4.1.0 to 5.0. I am using the same RPi for Squeezelite and LMS duties. Squeezelite seems OK.

    I could not get LMS to run....I would click "start" and it got the green tick. But a refresh saw that go back to the red cross.

    I have now uninstalled LMS, and re-installed....seems to be working OK. But obviously have to set LMS back up again.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •