Home of the Squeezebox™ & Transporter® network music players.
Page 10 of 82 FirstFirst ... 891011122060 ... LastLast
Results 91 to 100 of 813
  1. #91
    Senior Member paul-'s Avatar
    Join Date
    Jan 2013
    Posts
    2,780
    Quote Originally Posted by Paul Webster View Post
    Ok - I removed pcp-bt - rebooted - reinstalled and now Bluetooth is working and Squeezelite is happy.

    In the process I might have removed more than I should have done ... I clicked on delete again by mistake and it said it was deleting
    never_remove.tcz

    It has not caused an obvious problem yet but I guess things will go wrong during a future update attempt.
    never_remove is a with a number of dependencies.....it's never loaded, but it's intended to keep automatic removal routines from removing certain extensions. As you found you can of course remove. I added it to our repo, so you can re-add it......make sure to just load it, don't try to install it.

    pcp-load -w never_remove.tcz
    piCorePlayer a small player for the Raspberry Pi in RAM.
    Homepage: https://www.picoreplayer.org

    Please donate if you like the piCorePlayer

  2. #92
    Senior Member paul-'s Avatar
    Join Date
    Jan 2013
    Posts
    2,780
    Cut-Throat,

    What version of squeezelite are shown on the footers of your player pages? Also, are you sure your server isn't blocking the requests? Might check the LMS server log.
    piCorePlayer a small player for the Raspberry Pi in RAM.
    Homepage: https://www.picoreplayer.org

    Please donate if you like the piCorePlayer

  3. #93
    Senior Member
    Join Date
    Apr 2005
    Location
    UK/London
    Posts
    2,086
    Quote Originally Posted by paul- View Post
    never_remove is a with a number of dependencies.....it's never loaded, but it's intended to keep automatic removal routines from removing certain extensions. As you found you can of course remove. I added it to our repo, so you can re-add it......make sure to just load it, don't try to install it.

    pcp-load -w never_remove.tcz
    Thanks.
    Looks like the message I saw on screen about it being deleted was either incorrect or I misread it.

    Code:
     pcp-load -w never_remove.tcz
    [ INFO ] never_remove is already downloaded.
    [ INFO ] All files tested good.
    Paul Webster
    http://dabdig.blogspot.com
    Author Radio France (FIP etc) plugin

  4. #94
    Senior Member
    Join Date
    Apr 2005
    Location
    UK/London
    Posts
    2,086
    Another oddity ...
    BBC Radio 4 live via iPlayer plugin would not play.
    So I went hunting for what could be missing/broken and found in the pCP logs
    /usr/local/bin/lame: error while loading shared libraries: libncursesw.so.5: cannot open shared object file: No such file or directory

    so I deleted (rebooted) and reinstalled pcp-lame extension ...
    and BBC Radio 4 live started working

    When it is playing I now see
    sh -c "/usr/local/slimserver/Bin/armhf-linux/faad" -q -w -f 1 - | "/usr/local/bin/lame" --silent -q 3 --abr 256 - -

    Is there a checker script that will run through the extensions and compare version with the ones on pCP repository?
    Paul Webster
    http://dabdig.blogspot.com
    Author Radio France (FIP etc) plugin

  5. #95
    Senior Member Greg Erskine's Avatar
    Join Date
    Sep 2006
    Location
    Sydney, Australia
    Posts
    1,731
    Deleted.
    Last edited by Greg Erskine; 2019-06-15 at 03:43. Reason: Not sure

  6. #96
    Senior Member
    Join Date
    Jan 2011
    Location
    Minneapolis
    Posts
    584
    Quote Originally Posted by paul- View Post
    Cut-Throat,

    What version of squeezelite are shown on the footers of your player pages? Also, are you sure your server isn't blocking the requests? Might check the LMS server log.
    Here are my Player Screen Shots - running PcP 3.5, 4.0 and 5.0

    Name:  Pcp 3.5.jpg
Views: 441
Size:  208.0 KB

    Name:  Pcp 4.0.jpg
Views: 445
Size:  210.8 KB

    Name:  Pcp 5.0.jpg
Views: 442
Size:  212.5 KB

  7. #97
    Senior Member paul-'s Avatar
    Join Date
    Jan 2013
    Posts
    2,780
    Squeezelite needs to be at v1.9.0-1121-pCP to show up in player tabs

    You need to upgrade your squeezelite on the device running pCP 4.0.0... I donĺt believe 3.5 can be upgraded to that version, unless you do manually install a custom squeezelite binary.
    piCorePlayer a small player for the Raspberry Pi in RAM.
    Homepage: https://www.picoreplayer.org

    Please donate if you like the piCorePlayer

  8. #98
    Senior Member
    Join Date
    Jan 2011
    Location
    Minneapolis
    Posts
    584
    Quote Originally Posted by paul- View Post
    Squeezelite needs to be at v1.9.0-1121-pCP to show up in player tabs

    You need to upgrade your squeezelite on the device running pCP 4.0.0... I donĺt believe 3.5 can be upgraded to that version, unless you do manually install a custom squeezelite binary.
    OK, thanks.... So the PcP 4.0 Distro has an older squeezelite with the bug in it?

    I still don't understand why my 5.0 Player does not show in the Player Tabs?
    It doesn't even show itself? - Any Ideas?

  9. #99
    Senior Member paul-'s Avatar
    Join Date
    Jan 2013
    Posts
    2,780
    Nothing wrong with 4.0.0, I don't update old images.

    What changed in 4.0.0, is that we are now using the LMS http/json interface for lookups. Are you running your LMS web interface on a non-standard port? If so, you need to set it on the port number on the tweaks page.
    piCorePlayer a small player for the Raspberry Pi in RAM.
    Homepage: https://www.picoreplayer.org

    Please donate if you like the piCorePlayer

  10. #100
    Senior Member paul-'s Avatar
    Join Date
    Jan 2013
    Posts
    2,780
    A Hotfix has been pushed to correct the LMS autostart problem......use the Hotfix button on the main page. Updates to 5.0.1
    piCorePlayer a small player for the Raspberry Pi in RAM.
    Homepage: https://www.picoreplayer.org

    Please donate if you like the piCorePlayer

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •