Home of the Squeezebox™ & Transporter® network music players.
Page 22 of 73 FirstFirst ... 1220212223243272 ... LastLast
Results 211 to 220 of 722
  1. #211
    Senior Member
    Join Date
    Jan 2010
    Location
    Hertfordshire
    Posts
    4,325
    Quote Originally Posted by jistme View Post
    I feel embarrassed, being pretty sure I was right and clever.
    Thanks for clearing that up ;-)
    If I had seen that page without any prior knowledge I would have thought the same.

    Sent from my SM-G900F using Tapatalk

  2. #212
    Babelfish's Best Boy mherger's Avatar
    Join Date
    Apr 2005
    Location
    Switzerland
    Posts
    20,430

    [Announce] Spotty 2.8.x - SpotifyConnect for your Squeezebox

    > If I understand correctly older versions could output Spotify's ogg
    > stream in flac to the Squeezebox, but the most recent 2.8.x release can
    > stream ogg 'untouched' to the Squeezebox.


    The Ogg/FLAC/PCM choice is the transport from LMS to the player.

    > But trying to find the settings for this and navigating to 'Audio
    > Settings', I only have three options there:
    >
    > Normal (96kbps)
    > High (160kbps)
    > Extreme (320kbps)


    This is the data rate the plugin will download from Spotify. This
    corresponds to the setting in the official Spotify applications.

    The spotty helper application I'm using initially did automatically
    decode the Ogg to PCM. Thus LMS would only see PCM. But LMS can
    transcode this to FLAC or MP3 or whatever if needed. Only recently
    philippe_44 added Ogg streaming which takes out the transcoding.

    Please note that unless you'd transcode to MP3 (which you can't, lack of
    lame, I guess), this has no effect on the sound quality. What you play
    would always be the quality you got from Spotify.

    --

    Michael

  3. #213
    Junior Member
    Join Date
    May 2019
    Posts
    3

    Problem with skipping tracks

    Hi, I've finally found a reason to register, since no one else has posted this issue, from what I see.

    I've been experiencing skipping tracks recently when playing tracks from Spotify. A song plays for a few seconds, then it suddenly skips to the next song. On the next song it either goes full distance or skips to the next after another few seconds, and so on.

    I cannot find any pattern, tried going through logs (including debug output), but I cannot find any errors there. I've updated to the latest Spotty and the latest LMS, but still the same issue appears (on all my players).

    I'm on a x86 Synology NAS with default helper (0.20, x64).

    Any suggestions would be welcome.

  4. #214
    Junior Member
    Join Date
    Feb 2019
    Posts
    13
    Quote Originally Posted by air_ii View Post
    Hi, I've finally found a reason to register, since no one else has posted this issue, from what I see.

    I've been experiencing skipping tracks recently when playing tracks from Spotify. A song plays for a few seconds, then it suddenly skips to the next song. On the next song it either goes full distance or skips to the next after another few seconds, and so on.

    I cannot find any pattern, tried going through logs (including debug output), but I cannot find any errors there. I've updated to the latest Spotty and the latest LMS, but still the same issue appears (on all my players).

    I'm on a x86 Synology NAS with default helper (0.20, x64).

    Any suggestions would be welcome.

    I too have experienced this issue.

  5. #215
    Babelfish's Best Boy mherger's Avatar
    Join Date
    Apr 2005
    Location
    Switzerland
    Posts
    20,430

    [Announce] Spotty 2.8.x - SpotifyConnect for your Squeezebox

    > I've been experiencing skipping tracks recently when playing tracks from
    > Spotify. A song plays for a few seconds, then it suddenly skips to the
    > next song. On the next song it either goes full distance or skips to the
    > next after another few seconds, and so on.


    Is this when controlling playback using a Spotify app, or through
    LMS/Spotty?

    When this happens, would it audibly play for a few seconds? You could
    enable INFO logging for plugin.spotty to gather more information, then
    send me the server.log.zip when it happened:

    https://www.dropbox.com/request/T3RctyzGgNg0oFDubq6a



    --

    Michael

  6. #216
    Senior Member ralphy's Avatar
    Join Date
    Jan 2006
    Location
    Canada
    Posts
    2,497
    Quote Originally Posted by air_ii View Post
    Hi, I've finally found a reason to register, since no one else has posted this issue, from what I see.

    I've been experiencing skipping tracks recently when playing tracks from Spotify. A song plays for a few seconds, then it suddenly skips to the next song. On the next song it either goes full distance or skips to the next after another few seconds, and so on.

    I cannot find any pattern, tried going through logs (including debug output), but I cannot find any errors there. I've updated to the latest Spotty and the latest LMS, but still the same issue appears (on all my players).

    I'm on a x86 Synology NAS with default helper (0.20, x64).

    Any suggestions would be welcome.
    Quote Originally Posted by piguy View Post
    I too have experienced this issue.
    Yesterday, I tracked the spotty skipping issue with squeezelite to the buffer sizes used in the vorbis decoder.

    Are all the players that are skipping squeezelite based?

    If yes, and you'd like to help test the changes, please PM me the player details and I'll try to provide a build for you.
    Ralphy

    1-Touch, 5-Classics, 3-Booms, 1-UE Radio
    Squeezebox client builds donations always appreciated.

  7. #217
    Junior Member
    Join Date
    May 2019
    Posts
    3
    Quote Originally Posted by mherger View Post
    > I've been experiencing skipping tracks recently when playing tracks from
    > Spotify. A song plays for a few seconds, then it suddenly skips to the
    > next song. On the next song it either goes full distance or skips to the
    > next after another few seconds, and so on.


    Is this when controlling playback using a Spotify app, or through
    LMS/Spotty?

    When this happens, would it audibly play for a few seconds? You could
    enable INFO logging for plugin.spotty to gather more information, then
    send me the server.log.zip when it happened:

    https://www.dropbox.com/request/T3RctyzGgNg0oFDubq6a




    --

    Michael
    It's when using LMS/Spotty to control the playback. And yes, I can hear music playing for a few seconds. I've uploaded server.log.

    Thanks!


    Quote Originally Posted by ralphy View Post
    Yesterday, I tracked the spotty skipping issue with squeezelite to the buffer sizes used in the vorbis decoder.

    Are all the players that are skipping squeezelite based?

    If yes, and you'd like to help test the changes, please PM me the player details and I'll try to provide a build for you.
    Yes, indeed all the players are based on squeezelite. PM'ing right now.

  8. #218
    Junior Member
    Join Date
    May 2019
    Posts
    3
    Quote Originally Posted by ralphy View Post
    Yesterday, I tracked the spotty skipping issue with squeezelite to the buffer sizes used in the vorbis decoder.

    Are all the players that are skipping squeezelite based?

    If yes, and you'd like to help test the changes, please PM me the player details and I'll try to provide a build for you.
    I guess you are right on the money there. I've changed File type settings for Spotty and disabled Ogg. Everything seems to be working fine when using FLAC.

  9. #219
    Same problem here with dropouts/skipping when streaming OGG, No problems if I select FLAC. All clients are SqueezeLite (3x PcP, 1x Fedora) controlled through LMS/Spotty.

    Noticed if you skip forward in a song while streaming OGG, bitrate changes to "705kbps CBR, Ogg Vorbis (Spotify) (Converted to FLAC)" as displayed in web controller for duration of track. Same thing occurs on a Squeezebox Radio (standalone, no sync) . Here is a log snip:

    [19-05-24 07:31:53.0137] Plugins::Spotty::ProtocolHandler::getMetadataFor (169) Returning metadata cached in song object for spotify://track:6BoRTALoxglJoD5bFUE94G
    [19-05-24 07:31:53.0139] Plugins::Spotty::ProtocolHandler::getMetadataFor (170) {
    album => "Set Your Sails (FaltyDL Remix)",
    artist => "Morcheeba, FaltyDL",
    bitrate => "320k VBR",
    cover => "https://i.scdn.co/image/f2371c42ace6109a0b1fcc8b7bec80653d988618",
    duration => 240,
    icon => "/html/images/cover.png",
    originalType => "Ogg Vorbis (Spotify)",
    originaltype => "Ogg Vorbis (Spotify)",
    title => "Set Your Sails - FaltyDL remix",
    type => "Ogg Vorbis (Spotify)",
    url => "spotify://track:6BoRTALoxglJoD5bFUE94G",
    }
    [19-05-24 07:31:57.1309] Plugins::Spotty::Plugin:urgeAudioCacheAfterXTracks (449) Played 15 song(s) since last audio cache purge.
    [19-05-24 07:31:57.1401] Plugins::Spotty::ProtocolHandler::getMetadataFor (169) Returning metadata cached in song object for spotify://track:6BoRTALoxglJoD5bFUE94G
    [19-05-24 07:31:57.1408] Plugins::Spotty::ProtocolHandler::getMetadataFor (170) {
    album => "Set Your Sails (FaltyDL Remix)",
    artist => "Morcheeba, FaltyDL",
    bitrate => "705kbps CBR",
    cover => "https://i.scdn.co/image/f2371c42ace6109a0b1fcc8b7bec80653d988618",
    duration => 240,
    icon => "/html/images/cover.png",
    originalType => "Ogg Vorbis (Spotify)",
    originaltype => "Ogg Vorbis (Spotify)",
    title => "Set Your Sails - FaltyDL remix",
    type => "Ogg Vorbis (Spotify) (Converted to FLAC)",
    url => "spotify://track:6BoRTALoxglJoD5bFUE94G",
    }
    [19-05-24 07:31:57.1414] Plugins::Spotty::ProtocolHandler::getMetadataFor (169) Returning metadata cached in song object for spotify://track:6BoRTALoxglJoD5bFUE94G

  10. #220
    Babelfish's Best Boy mherger's Avatar
    Join Date
    Apr 2005
    Location
    Switzerland
    Posts
    20,430
    Quote Originally Posted by Czig View Post
    Noticed if you skip forward in a song while streaming OGG, bitrate changes to "705kbps CBR, Ogg Vorbis (Spotify) (Converted to FLAC)" as displayed in web controller for duration of track. Same thing occurs on a Squeezebox Radio (standalone, no sync) .
    That's correct: as we can't seek within an Ogg stream (yet?), it's falling back to streaming transcoding in the case of a seek.
    Michael

    "It doesn't work - what shall I do?" - "Please check your server.log and/or scanner.log file!"
    (LMS: Settings/Information)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •