Home of the Squeezebox™ & Transporter® network music players.
Page 19 of 73 FirstFirst ... 917181920212969 ... LastLast
Results 181 to 190 of 722
  1. #181
    Quote Originally Posted by mherger View Post
    >Are you using any kind of firewall on your computer? Could it be the Spotty daemon cannot talk to LMS? Are you using password protection for your LMS?
    No, actually Spotify Connect does not work from my iPhone, either. Also there, I do see the Touch and the Radio, but connection fails. The weird thing is that with 2.7.x this was working fine.
    I did not change my configuration. Only change I'm aware of, is that I was running an older version of 7.9.2 (dating from end 2018 - beginning 2019). When restarting LMS to update the Spotty plugin to 2.8.x, my QNAP downloaded the latest LMS nightly (early May). (QNAP OS and configuration remained unchanged).
    Last edited by scala; 2019-05-13 at 03:40. Reason: Corrected misspelling

  2. #182
    Babelfish's Best Boy mherger's Avatar
    Join Date
    Apr 2005
    Location
    Switzerland
    Posts
    20,430

    [Announce] Spotty 2.8.x - SpotifyConnect for your Squeezebox

    > I did not change my configuration. Only change I'm aware of, is that I
    > was running an older version on 7.9.2 (dating to end 2018 - beginning
    > 2019). When restarting LMS to update Spotty plugin to 2.8.x my QNAP
    > downloaded the latest nightly (early May). (QNAP OS and configuration
    > remained unchanged).


    Are you running LMS in a Docker container?

    --

    Michael

  3. #183
    Quote Originally Posted by mherger View Post
    >Are you running LMS in a Docker container?
    I'm using the direct install of QLogitechMediaServer

  4. #184
    Quote Originally Posted by scala View Post
    Perhaps tonight I will try to clear and re-install Spotty and attempt a new setup of the account via Connect with logging tuned to debug level for the plugin, if that may help.
    Dear Michael,
    Here is what I did. I uninstalled Spotty, removed the prefs file and spotty folder, and reinstalled Spotty, restarting LMS. At this point, I set Spotty log to debug, and restart LMS again with a new log file.
    Then:
    Open Spotty Plugin page in LMS web interface
    Open Spotify app on my PC. Start music playing and then clicking of Spotify Authorization in the devices list, as per instructions. Authorized. The LMS Spotty web page changes and I tick on my Touch.
    The Touch appears in the Spotify app on the PC. I attempt two times to connect on it, but it fails. Music continues to play on the PC.
    Then I go to LMS web home interface and via the Spotty icon I navigate to some song, which plays smoothly (converted to FLAC). At this point, I have two different songs playing form the same Spotify account, one on my PC and one on the Touch!
    From the LMS web interface, I switch to some music from my local collection to play on the Touch, then again from Spotify and finally again from my local collection.
    All this took only a few minutes, but the log file is almost 1 MB: is there any way I can privately send it to you (I suppose there are some confidential connection info in it)?
    Maybe it is just something trivial in the end, and I am sorry that I have to ask for your help. Many thanks for your kind assistance!

  5. #185
    Babelfish's Best Boy mherger's Avatar
    Join Date
    Apr 2005
    Location
    Switzerland
    Posts
    20,430

    [Announce] Spotty 2.8.x - SpotifyConnect for your Squeezebox

    > All this took only a few minutes, but the log file is almost 1 MB: is
    > there any way I can privately send it to you (I suppose there are some
    > confidential connection info in it)?


    https://www.dropbox.com/request/T3RctyzGgNg0oFDubq6a

    Yes, debug mode is very chatty...
    --

    Michael

  6. #186

  7. #187
    Babelfish's Best Boy mherger's Avatar
    Join Date
    Apr 2005
    Location
    Switzerland
    Posts
    20,430

    [Announce] Spotty 2.8.x - SpotifyConnect for your Squeezebox

    > Done!

    Your Spotty helper seems to be crashing or losing connection all the
    time. I see it being restarted about five times in the eight or ten
    minutes that log file covers.

    Can you try using the other helper available in Settings/Advanced/Spotty?

    --

    Michael

  8. #188
    Quote Originally Posted by mherger View Post
    Can you try using the other helper available in Settings/Advanced/Spotty?
    Actually I tried yesterday already (after sending the log). Default helper is 64 bit, selecting by hand the 32 bit makes the Touch disappear from the list of Spotify available devices. Re-selecting 64 bit the Touch re-appears, but connection is always impossible. (I did not restart LMS in-between, not sure if I should have had).
    Again, Spotty 2.7 did not have this behavior, I don't know if this might point you to some subtle differences between the two releases?

    Edit: I'm on a wireless connection for the Squeeze devices (as I have always been), but if you think it could be some network-related problem I can test wired, at least on a Radio.
    Last edited by scala; 2019-05-14 at 03:46.

  9. #189
    Babelfish's Best Boy mherger's Avatar
    Join Date
    Apr 2005
    Location
    Switzerland
    Posts
    20,430

    [Announce] Spotty 2.8.x - SpotifyConnect for your Squeezebox

    > Again, Spotty 2.7 did not have this behavior, I don't know if this might
    > point you to some subtle differences between the two releases?


    Hm... that's not good.

    You could download http://downloads.nixda.ch/Spotty-2.7.6.zip (the
    latest with the old helper), extract it, then copy the spotty-x86_64
    from that archive as spotty-custom somewhere in your server's search
    path. Would that work?

    --

    Michael

  10. #190
    Quote Originally Posted by mherger View Post
    You could download http://downloads.nixda.ch/Spotty-2.7.6.zip (the latest with the old helper), extract it, then copy the spotty-x86_64 from that archive as spotty-custom somewhere in your server's search path. Would that work?
    Sorry, yesterday I couldn't any testing (Lenny Kravitz at Geneva Arena...).
    I have now tried the old helper, but with no success (I see it in the drop-down menu, and I verified it is executable): Spotify Connect still does not work. I'm pretty much sure it worked fine in the past...
    It the must be something else wrong on my side, but I cannot identify what. I tried a wired connection to the router and it did not help. Apparently I'm the only QNAP/Spotty user having troubles, being the forum quiet on this.
    Things are not that bad, simply I cannot use the iPhone or my laptop as remote control. But Spotify from the LMS web interface, or from the Touch/Radio front panels works. It's an acceptable compromise.
    Last edited by scala; 2019-05-15 at 13:03.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •