Home of the Squeezebox™ & Transporter® network music players.
Page 1 of 69 1231151 ... LastLast
Results 1 to 10 of 683
  1. #1
    Babelfish's Best Boy mherger's Avatar
    Join Date
    Apr 2005
    Location
    Switzerland
    Posts
    20,312

    [Announce] Spotty 2.8.x - Spotify Connect for your Squeezebox

    I'm happy to announce Spotty 2.8.0 - which I call the philippe44 release! Thanks to philippe44's contribution, Spotty now can play without any transcoding involved. We can finally play the Spotify OGG stream directly on the Squeezebox. Transcoding options still are available, of course. Previously Spotify's OGG stream would have been transcoded to PCM, then in LMS from PCM to FLAC (by default), adding more CPU overhead than necessary on your LMS machine.

    Name:  Bildschirmfoto 2019-04-12 um 22.55.39.png
Views: 5556
Size:  34.8 KB

    In addition to this direct streaming of the audio data, the spotty helper now features improved support for those dynamic playlists Spotify offers. If you're using Spotty in Connect mode, you should have access to the daily mixes etc. This feature was introduced by the librespot team - Librespot is the underlying library which does all the Spotify streaming interaction.

    So this is the biggest release in a long time, with the smallest contribution of myself :-D.

    Some limitations still apply:
    • Seeking within the OGG stream isn't possible at this point. When you see, Spotty would fall back to transcode the stream into something it can seek with.
    • Podcasts still cannot be played.
    • OGG direct streaming unfortunately is not available on the armel platform. I haven't managed to compile the latest helper for this platform. But it should still continue to work as before.
    • I've given up trying to build for arm-muslhf. That binary was kind of redundant anyway, as the glibc linked version seems to be working very well.


    Enjoy the music!
    Last edited by mherger; 2019-04-12 at 14:18.
    Michael

    http://www.herger.net/slim-plugins - Spotty, MusicArtistInfo

  2. #2
    Senior Member
    Join Date
    Feb 2015
    Location
    Lancs, UK
    Posts
    187
    Quote Originally Posted by mherger View Post
    I'm happy to announce Spotty 2.8.0 - which I call the philippe44 release! Thanks to philippe44's contribution, Spotty now can play without any transcoding involved. We can finally play the Spotify OGG stream directly on the Squeezebox. Transcoding options still are available, of course. Previously Spotify's OGG stream would have been transcoded to PCM, then in LMS from PCM to FLAC (by default), adding more CPU overhead than necessary on your LMS machine.
    Early days, but seems to work fine here (Duet running latest 7.92) - obviously not going to try everything this early in the morning (have to get off to work) but certainly no transcoding here as you say.

    Many thanks gentlemen, very much appreciated.

    --

    Ray Woodward [Windows 10, LMS 7.92, Squeezebox Duet]

  3. #3
    Junior Member
    Join Date
    Apr 2019
    Posts
    11

    Problem with Spotty 2.80 and Spotty Helper ARMv8 v0.20

    Hello Michael,

    since update zu v2.8.0 the Spotty Helper Application for ARM v8 does not work anymore:

    "There has been a problem running the Spotty helper application. Most likely your operating system and/or platform is not supported. Please report the following details to me:

    Operating system: Debian / armv7l-linux

    Helper Applications Folder:
    /usr/share/squeezeboxserver/Bin/armhf-linux
    /usr/share/squeezeboxserver/Bin
    /usr/share/squeezeboxserver/Bin/arm-linux
    /usr/local/sbin
    /usr/local/bin
    /sbin
    /bin
    /usr/sbin
    /usr/bin
    /var/lib/squeezeboxserver/cache/InstalledPlugins/Plugins/Spotty/Bin
    /var/lib/squeezeboxserver/cache/InstalledPlugins/Plugins/Spotty/Bin/arm-linux
    /var/lib/squeezeboxserver/cache/InstalledPlugins/Plugins/SpottyBinFreeBSD/Bin
    /var/lib/squeezeboxserver/cache/InstalledPlugins/Plugins/UPnPBridge/Bin
    ldd (Debian EGLIBC 2.13-38+rpi2+deb7u7) 2.13"


    Can you give me a download oppertunity for downgrading to Spotty v2.7.6 and Spotty Helper Application for ARMv8 v0.12.2? It would be helpful for me to have a suitable repository URL repo.xml for downgrading.Thank you very much for helping.

    I use a Simple Audio Roomplayer+ with SimpleAudio Reloaded+-Software which uses LMS 7.9.1. My LMS-status:

    Logitech Media Server Version: 7.9.1 - 1522157629 @ Fri Mar 30 12:27:11 CEST 2018
    Hostname: SimpleAudio5
    Server IP Address: 192.168.1.116
    Server HTTP Port Number: 9000
    Operating system: Debian - EN - utf8
    Platform Architecture: armv7l-linux
    Perl Version: 5.14.2 - arm-linux-gnueabihf-thread-multi-64int
    Audio::Scan: 0.95
    Database Version: DBD::SQLite 1.34_01 (sqlite 3.7.7.1)
    Total Players Recognized: 1


    With regards Gerald

  4. #4
    Babelfish's Best Boy mherger's Avatar
    Join Date
    Apr 2005
    Location
    Switzerland
    Posts
    20,312
    Quote Originally Posted by vensi08 View Post
    /var/lib/squeezeboxserver/cache/InstalledPlugins/Plugins/SpottyBinFreeBSD/Bin
    /var/lib/squeezeboxserver/cache/InstalledPlugins/Plugins/UPnPBridge/Bin
    ldd (Debian EGLIBC 2.13-38+rpi2+deb7u7) 2.13"
    You certainly don't need the SpottyBinFreeBSD plugin.

    I wonder whether you are the one user who need the muslhf build I removed in 2.8.0... Please download the old build from github's history, rename it to spotty-custom, and move it to /var/lib/squeezeboxserver/cache/InstalledPlugins/Plugins/Spotty/Bin. Then restart LMS. Would that work?

    I might build another Spotty helper plugin if that was the case. Thanks for the heads up!
    Last edited by mherger; 2019-04-14 at 12:19.
    Michael

    http://www.herger.net/slim-plugins - Spotty, MusicArtistInfo

  5. #5
    Senior Member
    Join Date
    Jan 2010
    Location
    Hertfordshire
    Posts
    3,122
    Quote Originally Posted by vensi08 View Post
    Hello Michael,

    since update zu v2.8.0 the Spotty Helper Application for ARM v8 does not work anymore:

    "There has been a problem running the Spotty helper application. Most likely your operating system and/or platform is not supported. Please report the following details to me:

    Operating system: Debian / armv7l-linux

    Helper Applications Folder:
    /usr/share/squeezeboxserver/Bin/armhf-linux
    /usr/share/squeezeboxserver/Bin
    /usr/share/squeezeboxserver/Bin/arm-linux
    /usr/local/sbin
    /usr/local/bin
    /sbin
    /bin
    /usr/sbin
    /usr/bin
    /var/lib/squeezeboxserver/cache/InstalledPlugins/Plugins/Spotty/Bin
    /var/lib/squeezeboxserver/cache/InstalledPlugins/Plugins/Spotty/Bin/arm-linux
    /var/lib/squeezeboxserver/cache/InstalledPlugins/Plugins/SpottyBinFreeBSD/Bin
    /var/lib/squeezeboxserver/cache/InstalledPlugins/Plugins/UPnPBridge/Bin
    ldd (Debian EGLIBC 2.13-38+rpi2+deb7u7) 2.13"


    Can you give me a download oppertunity for downgrading to Spotty v2.7.6 and Spotty Helper Application for ARMv8 v0.12.2? It would be helpful for me to have a suitable repository URL repo.xml for downgrading.Thank you very much for helping.

    I use a Simple Audio Roomplayer+ with SimpleAudio Reloaded+-Software which uses LMS 7.9.1. My LMS-status:

    Logitech Media Server Version: 7.9.1 - 1522157629 @ Fri Mar 30 12:27:11 CEST 2018
    Hostname: SimpleAudio5
    Server IP Address: 192.168.1.116
    Server HTTP Port Number: 9000
    Operating system: Debian - EN - utf8
    Platform Architecture: armv7l-linux
    Perl Version: 5.14.2 - arm-linux-gnueabihf-thread-multi-64int
    Audio::Scan: 0.95
    Database Version: DBD::SQLite 1.34_01 (sqlite 3.7.7.1)
    Total Players Recognized: 1


    With regards Gerald
    "Operating system: Debian / armv7l-linux"

    Is this ARM v8?

    Sent from my SM-G900F using Tapatalk

  6. #6
    Junior Member
    Join Date
    Apr 2019
    Posts
    11
    Quote Originally Posted by mherger View Post
    You certainly don't need the SpottyBinFreeBSD plugin.

    I wonder whether you are the one user who need the muslhf build I removed in 2.8.0... Please download the old build from github's history, rename it to spotty-custom, and move it to /var/lib/squeezeboxserver/cache/InstalledPlugins/Plugins/Spotty/Bin. Then restart LMS. Would that work?

    I might build another Spotty helper plugin if that was the case. Thanks for the heads up!
    Hello Michael,

    Unfortunately, your suggestion doesn't work. I still have the following error message from the plugin:

    "There has been a problem running the Spotty helper application. Most likely your operating system and/or platform is not supported. Please report the following details to me:

    Operating system: Debian / armv7l-linux

    Helper Applications Folder:
    /usr/share/squeezeboxserver/Bin/armhf-linux
    /usr/share/squeezeboxserver/Bin
    /usr/share/squeezeboxserver/Bin/arm-linux
    /usr/local/sbin
    /usr/local/bin
    /sbin
    /bin
    /usr/sbin
    /usr/bin
    /var/lib/squeezeboxserver/cache/InstalledPlugins/Plugins/Spotty/Bin
    /var/lib/squeezeboxserver/cache/InstalledPlugins/Plugins/Spotty/Bin/arm-linux
    /var/lib/squeezeboxserver/cache/InstalledPlugins/Plugins/SpottyAARCH64Bin/Bin
    /var/lib/squeezeboxserver/cache/InstalledPlugins/Plugins/UPnPBridge/Bin
    ldd (Debian EGLIBC 2.13-38+rpi2+deb7u7) 2.13"

    Thanks for helping Gerald

  7. #7
    Junior Member
    Join Date
    Apr 2019
    Posts
    11
    Hello Michael,

    Unfortunately, your suggestion doesn't work. I still have the following error message from the plugin:


    "There has been a problem running the Spotty helper application. Most likely your operating system and/or platform is not supported. Please report the following details to me:

    Operating system: Debian / armv7l-linux

    Helper Applications Folder:
    /usr/share/squeezeboxserver/Bin/armhf-linux
    /usr/share/squeezeboxserver/Bin
    /usr/share/squeezeboxserver/Bin/arm-linux
    /usr/local/sbin
    /usr/local/bin
    /sbin
    /bin
    /usr/sbin
    /usr/bin
    /var/lib/squeezeboxserver/cache/InstalledPlugins/Plugins/Spotty/Bin
    /var/lib/squeezeboxserver/cache/InstalledPlugins/Plugins/Spotty/Bin/arm-linux
    /var/lib/squeezeboxserver/cache/InstalledPlugins/Plugins/SpottyAARCH64Bin/Bin
    /var/lib/squeezeboxserver/cache/InstalledPlugins/Plugins/UPnPBridge/Bin
    ldd (Debian EGLIBC 2.13-38+rpi2+deb7u7) 2.13"

    Thanks for helping.

    Gerald

  8. #8
    Senior Member
    Join Date
    Jan 2010
    Location
    Hertfordshire
    Posts
    3,122
    Quote Originally Posted by vensi08 View Post
    Hello Michael,

    Unfortunately, your suggestion doesn't work. I still have the following error message from the plugin:


    "There has been a problem running the Spotty helper application. Most likely your operating system and/or platform is not supported. Please report the following details to me:

    Operating system: Debian / armv7l-linux

    Helper Applications Folder:
    /usr/share/squeezeboxserver/Bin/armhf-linux
    /usr/share/squeezeboxserver/Bin
    /usr/share/squeezeboxserver/Bin/arm-linux
    /usr/local/sbin
    /usr/local/bin
    /sbin
    /bin
    /usr/sbin
    /usr/bin
    /var/lib/squeezeboxserver/cache/InstalledPlugins/Plugins/Spotty/Bin
    /var/lib/squeezeboxserver/cache/InstalledPlugins/Plugins/Spotty/Bin/arm-linux
    /var/lib/squeezeboxserver/cache/InstalledPlugins/Plugins/SpottyAARCH64Bin/Bin
    /var/lib/squeezeboxserver/cache/InstalledPlugins/Plugins/UPnPBridge/Bin
    ldd (Debian EGLIBC 2.13-38+rpi2+deb7u7) 2.13"

    Thanks for helping.

    Gerald
    Unless I am missing something you don't want the ARMv8 helper with an ARMv7 server.

    Sent from my SM-G900F using Tapatalk

  9. #9
    Junior Member
    Join Date
    Sep 2010
    Posts
    25
    Since this morning I hear only 'clicking' sounds when I use Spotty...

    Max2Play - LMS 7.9.1 - Spotty 2.8.0

  10. #10
    Senior Member
    Join Date
    Jan 2010
    Location
    Hertfordshire
    Posts
    3,122
    Quote Originally Posted by bkonijn View Post
    Since this morning I hear only 'clicking' sounds when I use Spotty...

    Max2Play - LMS 7.9.1 - Spotty 2.8.0
    What has changed since it last worked?

    Sent from my SM-G900F using Tapatalk

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •