Home of the Squeezebox™ & Transporter® network music players.
Results 1 to 5 of 5
  1. #1
    Raul da Silva
    Guest

    AlienBBC Beta Release Available - includes support forWindows SlimServer users

    As Bill posted... It's almost there. The AlienBBC plugin seems to load
    properly and the Alien menu section in SlimServer 5.4.1 lists properly.

    I then restart with command line.

    Command line: slim --d_parse --d_source ... I get a normal SS parse
    listing.


    I then try to play a BBC stream (BBC 1 Live in this case) via the remote; I
    get the following dump:

    ================================================== ==========
    2005-01-11 18:58:15.5860 Backtrace:

    frame 0: Slim::Player::Source:laymode (/PerlApp/Slim/Control/Command.pm
    line 363)
    frame 1: Slim::Control::Command::execute (C:/Program
    Files/SlimServer/server/Plugins/Alien/Plugin.pm line 383)
    frame 2: Plugins::Alien::Plugin::setup_player (C:/Program
    Files/SlimServer/server/Plugins/Alien/Plugin.pm line 296)
    frame 3: Plugins::Alien::Plugin::__ANON__ (/PerlApp/Slim/Hardware/IR.pm
    line 546)
    frame 4: Slim::Hardware::IR::executeButton
    (/PerlApp/Slim/Control/Command.pm line 209)
    frame 5: Slim::Control::Command::execute (/PerlApp/Slim/Hardware/IR.pm
    line 570)
    frame 6: Slim::Hardware::IR:rocessCode (/PerlApp/Slim/Hardware/IR.pm
    line 429)
    frame 7: Slim::Hardware::IR::releaseCode (/PerlApp/Slim/Hardware/IR.pm
    line 327)
    frame 8: Slim::Hardware::IR::checkRelease (/PerlApp/Slim/Utils/Timers.pm
    line 52)
    frame 9: Slim::Utils::Timers::checkTimers (slimserver.pl line 428)
    frame 10: main::idle (slimserver.pl line 398)
    frame 11: main::main (slimserver.pl line 61)
    frame 12: PerlSvc::Interactive (perlsvc line 1203)
    frame 13: PerlSvc::_interactive (slimserver.pl line 0)
    frame 14: (eval) (slimserver.pl line 0)

    2005-01-11 18:58:15.5881 66:f2:bd:5e:31:c3: Switching to mode stop from stop
    2005-01-11 18:58:15.5883 Already in playmode stop : ignoring mode change
    2005-01-11 18:58:15.5897 Trying to open protocol stream for
    http://www.bbc.co.uk
    /radio1/realaudio/media/r1live.rpm
    2005-01-11 18:58:15.5900 Looking for handler for protocol http
    2005-01-11 18:58:15.5901 Found handler for protocol http
    ================================================== ===========

    The Squeezebox display shows, "Connecting...", then it just goes back to
    "Now Playing - Nothing"

    I thought this may be a problem with mplayer, so I tried the BBC1 stream
    directly to see if mplayer is working.

    Mplayer reports:

    ================================================== ==========
    C:\Program Files\SlimServer\server\Bin\MSWin32-x86-multi-thread>mplayer
    http://www.bbc.co.uk/radio1/realaudio/media/r1live.rpm
    MPlayer 1.0pre6-3.2.3 (C) 2000-2004 MPlayer Team
    CPU: Intel Pentium 4/Xeon/Celeron Foster (Family: 8, Stepping: 7)
    Detected cache-line size is 64 bytes
    CPUflags: MMX: 1 MMX2: 1 3DNow: 0 3DNow2: 0 SSE: 0 SSE2: 0
    Compiled with runtime CPU detection - WARNING - this is not optimal!
    To get best performance, recompile MPlayer with
    --disable-runtime-cpudetection.

    Playing http://www.bbc.co.uk/radio1/realaudio/media/r1live.rpm.
    Resolving www.bbc.co.uk for AF_INET...
    Connecting to server www.bbc.co.uk[212.58.240.110]:80 ...
    Cache size set to 320 KBytes
    Connected to server: www.bbc.co.uk
    Cache fill: 0.00% (0 bytes)

    Exiting... (End of file)
    ================================================== ==========

    Hmm... mplayer just opens the stream and exits... Nothing.

    I then tried playing a local Real .ram file and mplayer plays it fine.


    Very strange. Any ideas?


    -raul

  2. #2
    Jules Taplin
    Guest

    AlienBBC Beta Release Available - includes support forWindows SlimServer users

    Right. Raul. First thing - mplayer is a picky beast...

    Try that command line with a '-playlist' in it (a .rpm file is strictly
    not an audio file, but a playlist for the real one).

    So... try:

    C:\Program Files\SlimServer\server\Bin\MSWin32-x86-multi-thread>mplayer -playlist
    http://www.bbc.co.uk/radio1/realaudio/media/r1live.rpm

    See if that gets you anywhere.


    -- Jules


    Raul da Silva wrote:

    >As Bill posted... It's almost there. The AlienBBC plugin seems to load
    >properly and the Alien menu section in SlimServer 5.4.1 lists properly.
    >
    >I then restart with command line.
    >
    >Command line: slim --d_parse --d_source ... I get a normal SS parse
    >listing.
    >
    >
    >I then try to play a BBC stream (BBC 1 Live in this case) via the remote; I
    >get the following dump:
    >
    >================================================= ===========
    >2005-01-11 18:58:15.5860 Backtrace:
    >
    > frame 0: Slim::Player::Source:laymode (/PerlApp/Slim/Control/Command.pm
    >line 363)
    > frame 1: Slim::Control::Command::execute (C:/Program
    >Files/SlimServer/server/Plugins/Alien/Plugin.pm line 383)
    > frame 2: Plugins::Alien::Plugin::setup_player (C:/Program
    >Files/SlimServer/server/Plugins/Alien/Plugin.pm line 296)
    > frame 3: Plugins::Alien::Plugin::__ANON__ (/PerlApp/Slim/Hardware/IR.pm
    >line 546)
    > frame 4: Slim::Hardware::IR::executeButton
    >(/PerlApp/Slim/Control/Command.pm line 209)
    > frame 5: Slim::Control::Command::execute (/PerlApp/Slim/Hardware/IR.pm
    >line 570)
    > frame 6: Slim::Hardware::IR:rocessCode (/PerlApp/Slim/Hardware/IR.pm
    >line 429)
    > frame 7: Slim::Hardware::IR::releaseCode (/PerlApp/Slim/Hardware/IR.pm
    >line 327)
    > frame 8: Slim::Hardware::IR::checkRelease (/PerlApp/Slim/Utils/Timers.pm
    >line 52)
    > frame 9: Slim::Utils::Timers::checkTimers (slimserver.pl line 428)
    > frame 10: main::idle (slimserver.pl line 398)
    > frame 11: main::main (slimserver.pl line 61)
    > frame 12: PerlSvc::Interactive (perlsvc line 1203)
    > frame 13: PerlSvc::_interactive (slimserver.pl line 0)
    > frame 14: (eval) (slimserver.pl line 0)
    >
    >2005-01-11 18:58:15.5881 66:f2:bd:5e:31:c3: Switching to mode stop from stop
    >2005-01-11 18:58:15.5883 Already in playmode stop : ignoring mode change
    >2005-01-11 18:58:15.5897 Trying to open protocol stream for
    >http://www.bbc.co.uk
    >/radio1/realaudio/media/r1live.rpm
    >2005-01-11 18:58:15.5900 Looking for handler for protocol http
    >2005-01-11 18:58:15.5901 Found handler for protocol http
    >================================================= ============
    >
    >The Squeezebox display shows, "Connecting...", then it just goes back to
    >"Now Playing - Nothing"
    >
    >I thought this may be a problem with mplayer, so I tried the BBC1 stream
    >directly to see if mplayer is working.
    >
    >Mplayer reports:
    >
    >================================================= ===========
    >C:\Program Files\SlimServer\server\Bin\MSWin32-x86-multi-thread>mplayer
    >http://www.bbc.co.uk/radio1/realaudio/media/r1live.rpm
    >MPlayer 1.0pre6-3.2.3 (C) 2000-2004 MPlayer Team
    >CPU: Intel Pentium 4/Xeon/Celeron Foster (Family: 8, Stepping: 7)
    >Detected cache-line size is 64 bytes
    >CPUflags: MMX: 1 MMX2: 1 3DNow: 0 3DNow2: 0 SSE: 0 SSE2: 0
    >Compiled with runtime CPU detection - WARNING - this is not optimal!
    >To get best performance, recompile MPlayer with
    >--disable-runtime-cpudetection.
    >
    >Playing http://www.bbc.co.uk/radio1/realaudio/media/r1live.rpm.
    >Resolving www.bbc.co.uk for AF_INET...
    >Connecting to server www.bbc.co.uk[212.58.240.110]:80 ...
    >Cache size set to 320 KBytes
    >Connected to server: www.bbc.co.uk
    >Cache fill: 0.00% (0 bytes)
    >
    >Exiting... (End of file)
    >================================================= ===========
    >
    >Hmm... mplayer just opens the stream and exits... Nothing.
    >
    >I then tried playing a local Real .ram file and mplayer plays it fine.
    >
    >
    >Very strange. Any ideas?
    >
    >
    >-raul
    >
    >

  3. #3
    Bill Burns
    Guest

    AlienBBC Beta Release Available - includes support forWindows SlimServer users

    Jules Taplin wrote:

    > So... try:
    >
    > C:\Program Files\SlimServer\server\Bin\MSWin32-x86-multi-thread>mplayer
    > -playlist
    > http://www.bbc.co.uk/radio1/realaudio/media/r1live.rpm
    >
    > See if that gets you anywhere.


    Output from this command is below, confirming the missing codecs issue
    on WinXP.

    --
    Bill Burns
    Long Island NY USA
    mailto:billb (AT) ftldesign (DOT) com


    C:\Program Files\SlimServer\server\Bin\MSWin32-x86-multi-thread>mplayer
    -playlist http://www.bbc.co.uk/radio1/realaudio/media/r1live.rpm
    MPlayer 1.0pre6-3.2.3 (C) 2000-2004 MPlayer Team
    CPU: Advanced Micro Devices Athlon MP/XP/XP-M Barton (Family: 6,
    Stepping: 0)
    Detected cache-line size is 64 bytes
    CPUflags: MMX: 1 MMX2: 1 3DNow: 1 3DNow2: 1 SSE: 0 SSE2: 0
    Compiled with runtime CPU detection - WARNING - this is not optimal!
    To get best performance, recompile MPlayer with
    --disable-runtime-cpudetection.

    Resolving www.bbc.co.uk for AF_INET...
    Connecting to server www.bbc.co.uk[212.58.240.110]:80 ...
    Cache size set to 320 KBytes
    Connected to server: www.bbc.co.uk
    c:/windows/fonts/arial.ttf doesn't look like a font description, ignoring.
    Cannot load font: c:/windows/fonts/arial.ttf
    Playing
    rtsp://rmlivev8.bbc.net.uk/farm/*/ev7/live24/radio1/live/r1_dsat_g2.ra.
    Resolving rmlivev8.bbc.net.uk for AF_INET...
    Connecting to server rmlivev8.bbc.net.uk[212.58.240.100]:554 ...
    Cache size set to 320 KBytes
    Connected to server: rmlivev8.bbc.net.uk
    Cache fill: 17.50% (57344 bytes) REAL file format detected.
    ======= WAVE Format =======
    Format Tag: 28515 (0x6F63)
    Channels: 2
    Samplerate: 44100
    avg byte/sec: 44100
    Block align: 640
    bits/sample: 16
    cbSize: 26
    Unknown extra header dump: [80] [0] [10] [0] [17] [0] [80] [2] [10] [0]
    [1] [0]
    [0] [3] [8] [0] [0] [25] [0] [0] [0] [0] [0] [2] [0] [4]
    ===========================
    demux_real: invalid chunksize! (0)
    Clip info:
    name: BBC Radio 1
    author: BBC
    copyright: (C) British Broadcasting Corporation 2004
    ================================================== ========================
    Opening audio decoder: [realaud] RealAudio decoder
    opening win32 dll 'cook.so.6.0'
    Error loading dll
    ERROR: Could not open required DirectShow codec cook.so.6.0.
    Read the RealAudio section of the DOCS!
    ADecoder preinit failed
    ADecoder init failed
    Opening audio decoder: [realaud] RealAudio decoder
    opening win32 dll 'cook3260.dll'
    Error loading dll
    ERROR: Could not open required DirectShow codec cook3260.dll.
    Read the RealAudio section of the DOCS!
    ADecoder preinit failed
    ADecoder init failed
    Opening audio decoder: [realaud] RealAudio decoder
    opening win32 dll 'cook.bundle/Contents/MacOS/cook'
    Error loading dll
    ERROR: Could not open required DirectShow codec
    cook.bundle/Contents/MacOS/cook.

    Read the RealAudio section of the DOCS!
    ADecoder preinit failed
    ADecoder init failed
    Cannot find codec for audio format 0x6B6F6F63.
    Read DOCS/HTML/en/codecs.html!
    ================================================== ========================
    Audio: no sound
    Video: no video


    Exiting... (End of file)

  4. #4
    Steve Bernard, Jr
    Guest

    AlienBBC Beta Release Available - includes support forWindows SlimServer users

    On Wed, 12 Jan 2005 12:57:11 -0500, Bill Burns <billb (AT) ftldesign (DOT) com> wrote:
    > Jules Taplin wrote:
    >
    > > So... try:
    > >
    > > C:\Program Files\SlimServer\server\Bin\MSWin32-x86-multi-thread>mplayer
    > > -playlist
    > > http://www.bbc.co.uk/radio1/realaudio/media/r1live.rpm
    > >
    > > See if that gets you anywhere.

    >
    > Output from this command is below, confirming the missing codecs issue
    > on WinXP.
    >


    Well, like I posted last night, I grabbed the proper codecs and put
    them in a Codecs directory where mplayer knew about them. This
    allowed me to play Real files through the command line. In fact, I
    just tried that specific BBC stream and it played fine...from the
    command line. None of this has helped my Squeezebox or Softsqueeze to
    play tracks through AlienBBC. I have no hard evidence that the
    behavior it's exhibiting now (Connecting... for several seconds and
    then stopping) is a result of missing codecs or some completely
    unrelated issue.

    The page to download the beta has some tips, and my debugging output
    looks pretty much like what Bill Burns posted yesterday. One question
    on the site is: " Does the command window/shell say that it has parsed
    an entry in the rstp playlist?" and I don't see anything that looks
    like it's saying that. I certainly see nothing with --d_source that
    indicates mplayer.exe was launched, so the problem may lie further
    upstream than missing codecs.

    Not that missing the proper codecs wouldn't also be a problem, of course.

    --Steve

    P.S. The Real codecs I am using were obtained by downloading Real
    Alternative from
    http://www.free-codecs.com/Real_Alte...e_download.htm , installing
    just Real Alternative (not Media Player Classic), and then copying the
    Codecs folder in the Real Alternative program directory to the
    directory where mplayer is. This caused it to stop complaining about
    missing Real codecs.

  5. #5
    Bill Burns
    Guest

    AlienBBC Beta Release Available - includes support forWindows SlimServer users

    Steve Bernard, Jr wrote:

    > P.S. The Real codecs I am using were obtained by downloading Real
    > Alternative from
    > http://www.free-codecs.com/Real_Alte...e_download.htm , installing
    > just Real Alternative (not Media Player Classic), and then copying the
    > Codecs folder in the Real Alternative program directory to the
    > directory where mplayer is. This caused it to stop complaining about
    > missing Real codecs.


    Thanks for that! I installed the codecs and now I can play the BBC
    streams using mplayer from the command line.

    Attempting to play BBC through the SB still gives "Connecting ..." for a
    few seconds, no sound.

    --
    Bill Burns
    Long Island NY USA
    mailto:billb (AT) ftldesign (DOT) com

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •