Home of the Squeezebox™ & Transporter® network music players.
Page 2 of 3 FirstFirst 123 LastLast
Results 11 to 20 of 25
  1. #11
    Senior Member
    Join Date
    Mar 2010
    Posts
    105
    I've experimented a bit more. "Pull" has to be set to "up", otherwise nothing at all happens when I press the button in its operational state. However, while it has worked when I did a test run, it now appears to only switch off the RPi after the next reset. Very strange.

  2. #12
    Senior Member paul-'s Avatar
    Join Date
    Jan 2013
    Posts
    1,815
    The GPIO on the rpi has default values for the internal pullup/down resistors, we can change them, but not until the kernel finishes booting, that can be too late. You need to use a GPIO that matches. IN the case of Audiophonics, use the GPIO connections that they recommend.
    piCorePlayer a small player for the Raspberry Pi in RAM.
    Homepage: https://www.picoreplayer.org

    Please donate if you like the piCorePlayer

  3. #13
    Senior Member
    Join Date
    Mar 2010
    Posts
    105
    Quote Originally Posted by paul- View Post
    The GPIO on the rpi has default values for the internal pullup/down resistors, we can change them, but not until the kernel finishes booting, that can be too late. You need to use a GPIO that matches. IN the case of Audiophonics, use the GPIO connections that they recommend.
    Is there an explicit recommendation anywhere? I just tried to model the settings on that post in the other thread.


    Gesendet von iPhone mit Tapatalk

  4. #14
    Senior Member
    Join Date
    Mar 2010
    Posts
    105
    If you meant the GPIOs, I‘m using the button/power supply together with an Audiophonics HAT, which has special pins for this. So I am using the standard GPIOs, but I don‘t know what the overlay settings should be. (I think I know, but then the shutdown sometimes only happens after the next reboot finishes (which I trigger via the web interface), not on its own.


    Gesendet von iPhone mit Tapatalk

  5. #15
    Senior Member
    Join Date
    Mar 2010
    Posts
    105
    Quote Originally Posted by paul- View Post
    The defaults should work for the module, as I used that board to develop the setup. But,I’ll check it out.
    I've experimented a bit more. When disabling the overlays and instead using the pop-powerbutton.sh script from the home directory (after linking /bin/busybox to /usr/bin/getopt), the script works out of the box with the default values:

    Code:
    tc@piCorePlayer:~$ ./pcp-powerbutton.sh 
    No command line settings, Using defaults
    
    piCorePlayer Power button shutdown script starting...
    Asserting pins : 
    ShutDown : GPIO17=in, High
    BootOK   : GPIO22=out, High
    piCorePlayer shutting down.
    Power to the RPi is cut by the Audiophonics board. What would the corresponding overlay settings be?

  6. #16
    Senior Member paul-'s Avatar
    Join Date
    Jan 2013
    Posts
    1,815
    The settings would be what is printed, just add pull down on gpio 17.

    Thanks for letting me know about the getopt issue, there is a hard path set in the script.
    Last edited by paul-; 2019-05-11 at 04:58.
    piCorePlayer a small player for the Raspberry Pi in RAM.
    Homepage: https://www.picoreplayer.org

    Please donate if you like the piCorePlayer

  7. #17
    Senior Member
    Join Date
    Mar 2010
    Posts
    105
    Quote Originally Posted by paul- View Post
    The settings would be what is printed, just add pull down on gpio 17.

    Thanks for letting me know about the getopt issue, there is a hard path set in the script.
    I'm actually not sure which overlay corresponds to which "Signal" (BootOK, ShutDown)?
    Last edited by pputzer; 2019-05-11 at 05:06.

  8. #18
    Senior Member paul-'s Avatar
    Join Date
    Jan 2013
    Posts
    1,815
    Poweroff is gpio 22, active high
    piCorePlayer a small player for the Raspberry Pi in RAM.
    Homepage: https://www.picoreplayer.org

    Please donate if you like the piCorePlayer

  9. #19
    Senior Member
    Join Date
    Mar 2010
    Posts
    105
    Quote Originally Posted by paul- View Post
    Poweroff is gpio 22, active high
    Name:  Bildschirmfoto 2019-05-11 um 15.38.10.png
Views: 24
Size:  16.0 KB

    With this setting, the power button never stops blinking after switching on power. Pushing it again does not trigger a shutdown. When shutting down the device from the web interface, it does not power off.

  10. #20
    Senior Member paul-'s Avatar
    Join Date
    Jan 2013
    Posts
    1,815
    the shutdown is gpio 17, active high, and pull down
    piCorePlayer a small player for the Raspberry Pi in RAM.
    Homepage: https://www.picoreplayer.org

    Please donate if you like the piCorePlayer

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •