Home of the Squeezebox™ & Transporter® network music players.
Results 1 to 9 of 9
  1. #1
    Junior Member
    Join Date
    Mar 2019
    Posts
    5

    piCorePlayer 4.1.0 Refusing Airplay Connections

    Hello Everyone. I'm sorry if this has been addressed, but I have tried searching and the results have come back with an overwhelming number of results and I can't seem to find what I'm looking for. I have a multiroom audio system running on six Raspberry Pis, all running piCorePlayer 4.1.0. The LMS side of everything works fine without issue, however, when I try to play media from an iOS device (ver. 12.1.4), I get the error message "Unable to Connect to "XXX"" every single time. If I restart squeezelite and shairplay, it will work for a while, but I will eventually get the same issue. It does this on all of my piCorePlayers. I tried to figure out how to get and view the debug log, but again, too many results came up when I searched, leaving me frustrated and more confused. I am not very technically proficient in programming and computers, but great with following instructions. Any help would be immensely appreciated.

  2. #2
    Senior Member paul-'s Avatar
    Join Date
    Jan 2013
    Posts
    1,683
    Are you using Shairport-sync or the Shairtunes plugin to LMS? https://forums.slimdevices.com/showt...ndows-support)
    piCorePlayer a small player for the Raspberry Pi in RAM.
    Homepage: https://www.picoreplayer.org

    Please donate if you like the piCorePlayer

  3. #3
    Junior Member
    Join Date
    Mar 2019
    Posts
    5
    Shairport-Sync

  4. #4
    Senior Member paul-'s Avatar
    Join Date
    Jan 2013
    Posts
    1,683
    When using Shairport sync, squeezelite has to let go of Alsa in order to work. With that many players and that you have an LMS server, I would use the plugin.
    piCorePlayer a small player for the Raspberry Pi in RAM.
    Homepage: https://www.picoreplayer.org

    Please donate if you like the piCorePlayer

  5. #5
    Junior Member
    Join Date
    Mar 2019
    Posts
    5
    Thank you very much for the suggestion! I will try this and report if I still have issues. Thank you again.

  6. #6
    Junior Member
    Join Date
    Mar 2019
    Posts
    5
    Just wanting to close the loop. I have installed the plugin on LMS my Synology NAS. I have been testing over the last 20 mins and have not experienced any issues. Thank you again for your support!

  7. #7
    Senior Member
    Join Date
    Jan 2011
    Location
    Staffordshire. UK
    Posts
    2,546
    If you still have problems

    From the Squeezelite command line options

    -C <timeout> Close output device when idle after timeout seconds, default is to keep it open while player is éon
    I use Shairport-sync and Squeezelite on the same pi and have added

    Code:
    -C 5
    to the Squeezelite settings.

    This lets me switch between both output choices and also a gmrender-resurrect instance.

  8. #8
    Junior Member
    Join Date
    Mar 2019
    Posts
    5
    I will book mark this and attempt the timeout code if I still experience issues. Thank you for your suggestions as well!

  9. #9
    Senior Member Greg Erskine's Avatar
    Join Date
    Sep 2006
    Location
    Sydney, Australia
    Posts
    1,597
    FYI: By default piCorePlayer sets -C to 15.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •